The Nurburgring's update stopped installing at 97% !! Help [FIXED}


This is what happened:

1- I downloaded the Nurburgring’s update.

2- It gave me the option to play while it’s downloading.

3- So I did! I continued to play and then It disappeared from the “Queue”

4- and now every time I try to play in the ring it show the note that you see in the top.

This is what I have tried so far:

1- rebooting the system.
2- unpluging all the cables and plug them back in.
3- I chatted with the Xbox one supper team. They weren’t able to solve it.

Please Help.


this is where the problem started :

2- It gave me the option to play while it’s downloading.

never choose that option, i know thats not helping now, but for future reference.

will it let you uninstall the update? then reboot, then download again but wait till it fully installs before starting game

richard1973: Thanx. I tried to uninstall and then re install. But It’s not in the “Queue” anymore!.

Just restart Forza. All of the title updates are mandatory when connected to Xbox Live; so, it’ll force the install with another prompt.

You may need to uninstall and reinstall the game if nothing else fixes it.

A similar issue happened to me as well. Mine currently shows 96% and it hasn’t moved in 2 days either. I am unsure about what to do.

I am on a limited satellite broadband data cap. It is very frustrating every time an update occurs. I have to uninstall and then re-install the game in order to apply all of the previous fixes just to be able to download and apply the latest update that is required. That alone is equivalent to 2 months of my data limit. I wish there were a way to obtain these fixes on a physical media or even a separate web link to manually download them to a flash drive and then insert it into the XBox One.

Thank you all,

I tried every thing you guys said. and nothing happened.

The only thing I didn’t do yet. is to uninstall the whole game and then reinstall it again.

If I do so, Will I lose my data? My cars my CR’s and my saving ?


Thanx all for your comments.

I gambled and uninstalled the whole game. and then reinstalled it.

It took almost a whole day of installing. but eventually everything came back, My saving and my cars.

Again, Thanx all.