Question about G29 and FH4 on steam

Hi guys,

I configured my G29 wheel and bought FH4 on steam
My issue is hard to describe but i will try my best…

in my G29 Hub configuration, there’s a checkbox for “self center in non-ffb game”, I untick that,
in FH4, I copied the configuration from someone else, (vibration set to 20, ffb to 80 etc…)

now, when i was in game, then wheel feel like spinning free, with no force feedback feel when the car goes fast,
I alt-tab to the logitech hub, tick/untick the box “self-center in non ffb”, and suddenly the wheel is heavier, which now i can play…

However, just everytime I reboot my computer, I have to do that…
-start the game
-start the g29 hub
-alt tab, tick/untick the checkbox

The question is, i’m not sure if the heavy steering is from the hub…or from the game itself?
what i’m seeing now is that the wheel center itself, which is good
but when the car goes straight fast, the steering should feel heavier to mimic real life highway driving… but it doesn’t

So…i guess my question is:
-which configuration matters, the game or the g29 hub? am i missing something?
-how do i have my “lock” feeling when the car goes on highway…

Hi everyone! I bought FH4 on steam on the day of the premiere. I saw a huge problem with my Logitech G29. While I’m driving on the center of the wheel i have dead zone and I must turn very hard to turn the car. (Sorry for my bad english). If you know something about it Thank you so much.

1 Like

Hello Zippy. If you bought FH4 from steam, this is a common problem with wheels. I contacted the support team and they replied me that this is a known issue and their devs are currently investigating it. So we have to wait few more days.

Think hub is saying keep it off but forza was able to override anyway
With your wheel and the game/other games there is a deadspot in center (ffb)
The feel with latest version/default settings was “ok”, “like a real car” going bit offroad the wheel is “free”
go road->offroad->jump (stiff, free, in air stiffer) if it always feels same then hub has control (turn off)

did you fix the problem i am having the same problem and it is very annoying

Sounds to me like an issue I also encountered at the beginning. You should check the following.

Ingame go to → settings → steering settings → select “wheel” → click “advanced options”. There you’ll find two settings dealing with “tolerance range” (fourth and fifth entry) set the first to “0” and the second to “50” and test if you got rid of the deadzone. These two setting define how wide the deadzone is and how far you’ve to turn the wheel to get to full lock. Work your way to your desired setting from there.

Note: I don’t have an English language version of the game so the terms may not be the correct ones but you should be able to work with my explaination anyway.

I hope this helps.

1 Like