New Update Broke Game

The game has always worked for me since day 1. I never had any crashing problems. Started the game yesterday and played for about 1/2 hour. Noted the version change when it booted. When I went back an hour later to play, the game opened to the first screen for about 15 seconds, went black, then back to desktop. It did that the rest of the night. Tried resetting and reinstalling, neither worked. Looked for fixes on forum and tried them, nothing. This morning still not working so I tried moving game from ssd to regular drive. The game worked but I noticed it had the previous version number. Played for a 1/2 hour or so, shut it down to check if it will start again and back to crashing. I submitted a ticket but have zero expectations for help as I have seen the lack of help lurking on these boards. Is anyone else having this issue? I am playing on PC and have everything up to date, including video drivers. Do not have afterburner or riva tuner running. Processor is i7 4 GHz, video card is GTX970, Windows 10 version is current. I also moved it back to ssd and it still doesn’t run. Any help would be appreciated. Thanks.

maybe submit a ticket here

posting in the support section of the forum would have been more appropriate too

I just tried it again and it worked. I guess it is just hit or miss. I did submit a ticket as I said in my post. I tried the fixes first though. I should have posted in support but I was trying to get as much info in the post and didn’t think about it. I’ll get it right next time, hopefully there won’t be a next time.