6 Pages<<3456PrevNext
Rank: Driver's Permit
#101 Posted : Thursday, December 8, 2016 3:31:28 AM(UTC)
>Recommended specs completely blow an xbone out the water by at least five fold

>Recommended for 30fps performance

Laaaaaaaaaaaaaaazyyyyyyyyyy deeeeeeeeeevssssssssss
Rank: Driver's Permit
#102 Posted : Thursday, December 8, 2016 1:31:17 PM(UTC)
Hi all

Today I've just received my GTX 1080 Strix Oc edition (after I've sold my one month's old same 1070) and I've installed it on my Maximus VIII Formula Z170, i7-6700k (Oc to 4.6ghz)with 16gb ddr4 Avexir ROG. The game is installed on my boot drive Samsung 950 Pro msata.
After all this I couldn't believe seeing the game at many moments inside the jungle woods near a waterfall (can't remember its name) to while driving around to drom fps at around 50 or while driving to have fps locked at 60 and while maintaining 60 fps it just "paint" at that very moment the shadows of the trees and bushes!?!?!

I've been playing this on a 55" ultra hd samsung suhd with 3840x2160 and settings set to auto ultra
I've even tried custom settings with motion blur off as suggested by many sites and everything set to ultra except msaa which I had it on x2 or x4 or x8 but results stay almost the same. Also if I unlock the fps to variable (not locked at 60) then I get much stuttering wherever I drive

So my question is only one....what more a game could need especially when it doesn't support SLI?!?!?!?!?
Maybe it only pushes one core only and it's "bottleneck"-ing there as many users say?
1080 made a difference compared to 1070 I was running yesterday but still I was waiting more..........what better hardware could someone have?

Thanks for your time
Rank: Driver's Permit
#103 Posted : Saturday, December 17, 2016 11:15:43 AM(UTC)
At my Vocational Tech program in the Morning i take, Those computers are running I7's GTX 745's and 8-16 gb's of ram. The game runs really smooth on a 1280x720 resolution.
Rank: Racing Permit
#104 Posted : Saturday, December 17, 2016 1:41:21 PM(UTC)
Anybody care telling me if this game still hacks two of eight cores and cannot stay at 60fps at whatever settings?
Rank: Racing Permit
#105 Posted : Saturday, December 24, 2016 3:16:19 PM(UTC)
Originally Posted by: JESUSARIUS REX Go to Quoted Post
These recommended specs shows the utter garbage optimization. For the graphics of the game, it should easily run at 60fps for me. My overclocked 290 can V-Sync GTA V at 72 hz with almost max settings @1080p. The fact that these are recommended for 30 FPS is like a total slap in the face. LOW ON FORZA DOESN'T EVEN GET ME A SOLID LOCKED 30 FPS. IT'S A PC GAME. No one buys PC games to play a garbo 30 FPS (Not even for most people). Not to mention how if you don't have a current gen card (480 or 1060) you can't even get the solid 30 FPS, even if your card is more powerful than both (IE MY 290!!!!!!!!!!!!!! Same thing with the 970.). My Laptop with a 860m somehow runs the game better than my 290, yet my 860m can't even maintain 60fps in GTA V low 1080p....

This post should have never been made. Saying that the recommened specs are for 30 FPS aggravates me beyond belief. If I hadn't bought this game through best buy I would be getting a refund IMMEDIATELY.

Post is false. I have no trouble staying locked at 30 on High settings with Dynamic Optimization. I can even lock it at 60 and stay there 90% of the time with no drops below 50. I buy games to play them. Do I care if I can get 60fps all the time?, nope. I usually play around with settings to get the highest ones I can that don't ever drop below 40.

My CPU also does not lock at one core. All 6 are utilized almost equally and the GPU is used at 100%.
CPU - AMD FX 6300 @ 3.5ghz
GPU - Sapphire Nitro+ RX 470 w/4gb VRAM
RAM - 16GB DDR3-1333
SSD - 1 TB Samsung 860 QVO
Rank: Driver's Permit
#106 Posted : Monday, December 26, 2016 12:19:19 PM(UTC)
Purchased the game yersterday as christmas gift for myself, after having tried the demo for a solid hour.

First, my specs:

- Core i7 6700 (non k)
- 16 gb ram (2 x 8 gb)
- Gigabite GTX 1070 Gaming G1 (running in standard mode and not in performance mode)
- The game is on an HDD
- Latest Nvidia drivers

In the demo I was able to play with everything maxed out, as suggested by GeForce Experience and the game itself, also I unlocked the frame rate by turning the V-sync off.

Most of the time I got 60 fps dropping in the 50-60 area when there's deep vegetation or many cars (eg. race start) but the worst scenario is entering an area with buildings, in that case I get 45-50 fps.

No lag and for the moment not a single bit of stuttering.

Now some weird things I noticed:

- Unlocking the frame rate gives me lower fps than having them locked to 60 (lol), so I keep playing @ 60 fps capped with V-Sync because otherwise I'd be running at 50+ fps
- No difference in frame rate playing with MSAA and FXAA settings
- Heavy fps drops in the tuning menu when looking at rims and keeping pressed an arrow to skip fast to the rims at the end, like if the game is having a hard time loading the objects
- If I'm in an area which runs at low fps and I enter the photo mode, the fps drop persist even if everything is freezed
- The demo seemed to run a bit better that the full game

Another thing I noticed is that I see a lot of vegetation pop up in the background, the leaves on the trees seems low res and generally all the graphic to me seems to be noticeably lower than what I used to see in Forza 6: Apex (it was more clean and detailed with better reflections and effects).

That's all.

I hope they'll fix this game soon because since when I bought my new pc (september) every single game I played was in this same situation with no optimization at all...
Rank: Driver's Permit
#107 Posted : Wednesday, December 28, 2016 7:49:04 AM(UTC)
Im running on laptop no studer , rare frame drop and overal good performance
specs : i7 6700hq
gpu 960m 4gb
ram 16gb

game runs 1600x900, on high settings and caped on 30 fps ,, it good for me no need to push for 60 . for driving game 30 fps is plenty enough.
Rank: Driver's License
#108 Posted : Wednesday, December 28, 2016 8:37:08 AM(UTC)
Originally Posted by: Dicoluc Go to Quoted Post
Purchased the game yersterday as christmas gift for myself, after having tried the demo for a solid hour.

First, my specs:

- Core i7 6700 (non k)
- 16 gb ram (2 x 8 gb)
- Gigabite GTX 1070 Gaming G1 (running in standard mode and not in performance mode)
- The game is on an HDD
- Latest Nvidia drivers

In the demo I was able to play with everything maxed out, as suggested by GeForce Experience and the game itself, also I unlocked the frame rate by turning the V-sync off.

Most of the time I got 60 fps dropping in the 50-60 area when there's deep vegetation or many cars (eg. race start) but the worst scenario is entering an area with buildings, in that case I get 45-50 fps.

No lag and for the moment not a single bit of stuttering.

Now some weird things I noticed:

- Unlocking the frame rate gives me lower fps than having them locked to 60 (lol), so I keep playing @ 60 fps capped with V-Sync because otherwise I'd be running at 50+ fps
- No difference in frame rate playing with MSAA and FXAA settings
- Heavy fps drops in the tuning menu when looking at rims and keeping pressed an arrow to skip fast to the rims at the end, like if the game is having a hard time loading the objects
- If I'm in an area which runs at low fps and I enter the photo mode, the fps drop persist even if everything is freezed
- The demo seemed to run a bit better that the full game

Another thing I noticed is that I see a lot of vegetation pop up in the background, the leaves on the trees seems low res and generally all the graphic to me seems to be noticeably lower than what I used to see in Forza 6: Apex (it was more clean and detailed with better reflections and effects).

That's all.

I hope they'll fix this game soon because since when I bought my new pc (september) every single game I played was in this same situation with no optimization at all...


Image quality was reduced a few patches ago. Much more pop-in and close up LOD changes vs release version. It's the laziest way of "optimizing" a title. Give me ultra, let me decide if I need to reduce settings.

|Win 10 Pro|6850k @ 4.4Ghz|16GB DDR4 3200 4x4|MSI Gaming X 1080 SLI|
Rank: Racing Permit
#109 Posted : Monday, January 9, 2017 2:03:41 PM(UTC)
Just wanted to post in here in case someone was interested...

I bought a Surface Book last week: i7, 256GB SSD, 8GB RAM, dGPU (not a "performance-base" model).

This device was purchased for business use, but with the dGPU I was hoping that some Forza would be possible for those times when I'm mobile and want to, for example, knock out a #forzathon. I wasn't expecting stellar performance, even if I purchased a top-line Surface Book there's no way performance would match that of an Xbox One. But, the game is definitely playable, and didn't crash once when I was testing it out. So when I'm travelling, I just have to bring my Xbox One Elite controller, and my Surface Book, and I'll be good to go. That's pretty damn cool.

Unfortunately, for the price I paid for this device I could get a VR-ready 4K PC that would run the game on Ultra no problem. But... I needed the portability.

Anyone looking for more information just send me a message and I'll try to help.
Rank: Driver's Permit
#110 Posted : Tuesday, January 17, 2017 2:10:58 AM(UTC)
hello im running my pc on high and it sticks to 60 fps most of the time and 40 on the gold coast so i was wandering how it would go on ultra i did a test and i get 50 to 60 fps but on the gold coast it goes down to 30 is that ok any help would be great thanks my pc specks are
i7 6800k cpu
32g gskill ripjawz quad chenel ram
msi gaming r9 390
kingston hyper x 250ssd
pc specks
i7 6800k cpu
32g gskill ripjawz quad chenel ram
msi gaming r9 390
kingston hyper x 250ssd

Rank: Driver's Permit
#111 Posted : Saturday, January 21, 2017 1:51:29 PM(UTC)
Is playing perfectly fine on my pc 70-140 fps
specs:
i7-6700
gtx 1070 asus dual
cosair 16gb ram (2311 mhz)
samsung 850 evo 500GB
asus z170 pro gaming mobo
Rank: D-Class Racing License
User is suspended until 5/11/4755 6:38:30 AM(UTC)
#112 Posted : Tuesday, February 7, 2017 8:11:11 PM(UTC)
AMD Fury (4Gb) on 21:9 monitor with a fast i7, off solid state drives etc
DDR3 ram at 1643Mhz
G27 wheel.

generally smooth with a mix of low-med-high- and ultra settings
I get 75fps (Freesync max) highs, and maintain above 40fps (freesync low) everywhere, including the middle strip of surfers paradise at all times of day irrelevant of traffic.
After months of benchmarking and tuning, and tweaking Windows, I play with about 90-95% framerates at 67-72 frames per second.

If this game was intended for PC, and not gimped to make a cheap console LOOK like it punches above its' weight.. this game would hold 75Hz easily, without judder at high-ultra settings.
This of course is NOT what we get.

When I first purchased this game and was running a 780GTX (much less grunt and a little less RAM) I could happily run Ultra, (still can) but with low frames that were unacceptable.
Lowering Textures to Low got me out of trouble for most of the framerate lows. The settings to make this game work smoothly are all over the place.

This game has been intentionally crippled to perform poorly.
Hopefully the developers will not be closed down before optimisation for PC (the general rule followed for UWP marketplace titles under a Win10/DirectX12 ecosystem).

Optimisation shouldn't reduce the quality (vs the XBone), and we don't need HDR...
If Microsoft had nothing to do with this title, I firmly believe we would be experiencing very few of the issues that plagues the PC release of this game.

IT professional, geek gamer since the eighties... I run just about every game at my monitor max resolution (75-120 depending on which monitor I setup), generally at Ultra settings. (EG Battlefield 1)
This game highlights the way the industry is going.
Gamers might as well buy into consoles, sure.. but you'd be silly to support the company that does THIS to the industry!

If this game wasn't released for PC,.. I would simply have passed it up. Sadly. As it is I have thrown a lot of money at hardware since this games release to make the 'ride smooth'.

Rank: Driver's Permit
#113 Posted : Sunday, February 26, 2017 9:17:39 AM(UTC)
Hi All,

Like most other peoples i have problem also.

PC:

MSI B85 - G43
i5 4460 3.20Ghz
12GB DDR3 RAM
Gigabyte RX 480 G1 Gaming 8GB
PSU : Cooler Master 600W

I have no bugs with starting the game but i have problems and i cant play normal.When i put settings on Ultra or High i have fps drops everywhere..Lower drops out of the city.When i put setting on Low it has the same drops.Low or High or Ultre - same performance. I`m waiting for update Playground.This is not normal.You made game who has epic Graphics details,Epic engines sound but it is not playable.

Please Repair your game!!
Rank: Driver's Permit
#114 Posted : Sunday, February 26, 2017 11:14:50 AM(UTC)
Originally Posted by: FringedTunic657 Go to Quoted Post
Hi All,

Like most other peoples i have problem also.

PC:

MSI B85 - G43
i5 4460 3.20Ghz
12GB DDR3 RAM
Gigabyte RX 480 G1 Gaming 8GB
PSU : Cooler Master 600W

I have no bugs with starting the game but i have problems and i cant play normal.When i put settings on Ultra or High i have fps drops everywhere..Lower drops out of the city.When i put setting on Low it has the same drops.Low or High or Ultre - same performance. I`m waiting for update Playground.This is not normal.You made game who has epic Graphics details,Epic engines sound but it is not playable.

Please Repair your game!!


what is your ram usage in game? before i upgraded from 16gb ddr4 to 32gb ram my ram was pegged at 99%
Rank: Driver's Permit
#115 Posted : Friday, March 3, 2017 3:26:03 PM(UTC)
Hi i'm also having some small performance issues. I too get drops randomly down in the 40 fps area. I have tried ultra, high and medium and all gives the same results. If you check youtube everyone is saying that you should turn off core 0 in task manager for this game only and that actually removes the drops (at least a little) and thats why i start to wounder why the developers don't try to fix this game. I know i don't have a good processor (i will change soon) but i know that you shouldn't get drops like that. Really dissapointed at the developers....... (on the pro side it's fun to see cross-platform)

Setup:
Asus m5a97 r2.0
fx 8450 4ghz
16gb 1600mhz
Asus strix rx 480 8gb
850w psu
Rank: Racing Permit
#116 Posted : Saturday, March 4, 2017 12:01:39 PM(UTC)
Originally Posted by: ChaffyPaladin18 Go to Quoted Post
Originally Posted by: FringedTunic657 Go to Quoted Post
Hi All,

Like most other peoples i have problem also.

PC:

MSI B85 - G43
i5 4460 3.20Ghz
12GB DDR3 RAM
Gigabyte RX 480 G1 Gaming 8GB
PSU : Cooler Master 600W

I have no bugs with starting the game but i have problems and i cant play normal.When i put settings on Ultra or High i have fps drops everywhere..Lower drops out of the city.When i put setting on Low it has the same drops.Low or High or Ultre - same performance. I`m waiting for update Playground.This is not normal.You made game who has epic Graphics details,Epic engines sound but it is not playable.

Please Repair your game!!


what is your ram usage in game? before i upgraded from 16gb ddr4 to 32gb ram my ram was pegged at 99%



From what I could remember, mine tops out at like 7.5GB but then uses like a 12GB page file. I have 16GB of HyperX Fury DDR4 2113. Although it is only one stick. Next month I plan on swapping out for 2x 8GB of either HyperX Savage 3000Mhz or Corsair Vengeance 3000Mhz.

The fact it won't use more than 8GB despite having 16GB says to me these lazy developers have just copy and pasted straight from their methods of the Xbox one given that crusty console has 8GB. Absolutely pathetic from Playground Games. There's no coincidence how FH3 is locked at 30fps on Xbox One and runs like garbage on PC with overkill hardware, yet FM6 runs at 60fps on Xbox One and scales like a dream on PC.

Given the recommended specs given by the devs, I dont see how upgrading from 16GB to 32GB would help though to be honest.
Rank: Racing Permit
#117 Posted : Wednesday, March 8, 2017 6:03:22 AM(UTC)
Everything on Max and Ultra, smooth as glass


Asus Maximus VIII Hero Alpha Z170
I7 6700K @ 4.5/water cooled
Seagate Constellation ES.3 ST2000NM0033 2TB 7200 RPM 128MB Cache SATA 6.0Gb/s 3.5
32G DDR4 Ram @3000
EVGA GeForce GTX 1080 FTW2 GAMING iCX, 8GB GDDR5X
ASUS PG279Q @2560x144 1444Hz G-Sync
Forza Horizon 3/4 & Forza 7
Dell AW3418DW" G-sync, Logitech G29
I7 6700K@4.5. 32g ram, SSD, GTX1080TI FE @ 2012 & 5530 Full water cool setup.
Rank: Driver's Permit
#118 Posted : Saturday, March 11, 2017 3:33:08 PM(UTC)
PC:
i5 6500 @ 3.20 GHz
MSI GTX 1060 6G
16 GB RAM

Settings:
Everything on High
16x AF
8x MSAA
Locked at 40 FPS

I get no stuttering in game, except tiny stutters in Surfers Paradise (but that happens on my brothers Xbox One too). But what I do get are random crashes when driving around and it scares the buggers outta me when the audio freezes :/

Edited by user Saturday, March 11, 2017 3:34:33 PM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#119 Posted : Monday, March 13, 2017 11:51:40 PM(UTC)
PC:

CPU: 6700k @ 4.5 Ghz
GPU: ASUS 1070GTX-8GB Founder's edition
RAM: 4*8GB G.Skill Ripjaw 3200Mhz
SSD: Samsung 750 EVO 500GB
Motherboard: ASUS Z170-Pro
PSU: Coolermaster 700W
Monitor: LG @ 2560x1080

Playing on full ultra with capping it on 60FPS. Unlocking the frame-rate will cause eye cancer after a while.
Game performs well in 90% of the time. Runs perfect at night times. huge frame drops in surfers paradise down to 40 in a sunny days. Which is weird considering I can blaze through forests when ever it's raining without any issue.
Blazing fast loading. (3-4 sec max)
I've had about 3-4 bad crashes while playing after playing for a month.

Edited by user Tuesday, March 14, 2017 11:55:16 AM(UTC)  | Reason: Not specified

Rank: D-Class Racing License
User is suspended until 5/11/4755 6:38:30 AM(UTC)
#120 Posted : Saturday, March 18, 2017 7:21:42 AM(UTC)
Quote:

From what I could remember, mine tops out at like 7.5GB but then uses like a 12GB page file. I have 16GB of HyperX Fury DDR4 2113. Although it is only one stick. Next month I plan on swapping out for 2x 8GB of either HyperX Savage 3000Mhz or Corsair Vengeance 3000Mhz.

The fact it won't use more than 8GB despite having 16GB says to me these lazy developers have just copy and pasted straight from their methods of the Xbox one given that crusty console has 8GB. Absolutely pathetic from Playground Games. There's no coincidence how FH3 is locked at 30fps on Xbox One and runs like garbage on PC with overkill hardware, yet FM6 runs at 60fps on Xbox One and scales like a dream on PC.

Given the recommended specs given by the devs, I dont see how upgrading from 16GB to 32GB would help though to be honest.


Yes, get the extra stick of RAM.

Running memory in Dual Data Mode will alleviate bandwidth bottlenecks to your Video Card.

I built a mate a Battlefield 1 machine recently, and wanting some upgrade space for down the track, opted for only one 8Gb ram stick (saved a few dollars vs buying 2x 4Gb).
The general rule of thumb for decades was it was a few percent, at most, in framerate between single stick vs dual stick memory configs.

Then I saw his BF1 performance; went online, and read- for his Radeon RX470 , would receive massive framerate benefits (about 30%) if he got that extra ram stick.
Its' on the 'to do' list for him.. but Please.. do so!

It is more than likely the main issue you are presently experiencing.
Rank: Driver's Permit
#121 Posted : Saturday, April 8, 2017 5:45:09 AM(UTC)
I have found that if you lock your framerate at 30 FPS and set the pre-rendered frames to 2 or 1 I can achieve incredibly smooth 30 FPS at ultra on a OCed GTX 960M 4 GB.
Rank: Driver's License
#122 Posted : Tuesday, April 18, 2017 3:27:04 AM(UTC)
Originally Posted by: Hossein AAA Go to Quoted Post
PC:

CPU: 6700k @ 4.5 Ghz
GPU: ASUS 1070GTX-8GB Founder's edition
RAM: 4*8GB G.Skill Ripjaw 3200Mhz
SSD: Samsung 750 EVO 500GB
Motherboard: ASUS Z170-Pro
PSU: Coolermaster 700W
Monitor: LG @ 2560x1080

Playing on full ultra with capping it on 60FPS. Unlocking the frame-rate will cause eye cancer after a while.
Game performs well in 90% of the time. Runs perfect at night times. huge frame drops in surfers paradise down to 40 in a sunny days. Which is weird considering I can blaze through forests when ever it's raining without any issue.
Blazing fast loading. (3-4 sec max)
I've had about 3-4 bad crashes while playing after playing for a month.


What you are saying is that the shadows are causing you problems. If you set your shadows down to low, you should have better performance. Another thing to do for better frame rate is to turn of motion blur. That is on the first video settings page. No shadows occur at night and during cloudy rainy periods. Turning off motion blur off will help a lot.

Edited by user Tuesday, April 18, 2017 3:28:55 AM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#123 Posted : Tuesday, April 18, 2017 5:19:24 AM(UTC)

I have a problem with this configuration,

some recommendations ???


lenovo y700

i7 6700hq
16 gb ram
win10 home 64bit
geforce gtx 960m
Rank: D-Class Racing License
User is suspended until 5/11/4755 6:38:30 AM(UTC)
#124 Posted : Tuesday, April 18, 2017 10:40:56 PM(UTC)
PanzerMarshall.. what is the problem?
(every person has different ideals)

is it controller lag?
glitchy graphics?
not enough sense of speed?
little jolts (stutter/judder) to an otherwise fluid game?

some recommendations?- sure; tell us what the issue is you are experiencing or want to improve?

Why don't you list your present game present or mix of customer settings...
Rank: Driver's Permit
#125 Posted : Monday, April 24, 2017 2:15:13 PM(UTC)
Imma just leave this here...

Phenom II x4 955 C2 @3.7ghz
Rx460 4gb
5400rpm HDD
8gb 1333mhz DDR3

Locked 30FPS
1080p/2x AA/16x AF/Shadows High/Environments High/Static High/Dynamic High/FXAA Off/everything else Medium or off where available

Not even a stutter. What is it with y'all and your terrible performance on such high end rigs in these forums? Sure the game is poorly optimized and I'm not playing at 4k obviously, but damn I'm seriously below recommended specs.

I know, pics or it didn't happen. Don't worry, I got it coming in a bit
6 Pages<<3456PrevNext

Notification

Icon
Error