This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
Rank: Driver's Permit
 2 users liked this post.
#1 Posted : Monday, September 19, 2016 1:37:44 AM(UTC)
This game has two big performance problems. First of them is wrong frame pacing, and second is loading hitches in some tracks.

About frame pacing, I've encountered similar problems with every game using borderless windowed mode. That's why I only use exclusive fullscreen mode. For those problems, RTSS with a 60 fps lock does wonders, but RTSS is not compatible with UWP games. I went to try DXTory after reading that it was compatible with UWP games, but I could not get it to work with Forza Apex. I don't know why.

So, in the nvidia profile for Forza Apex I changed framerate limit to 40 to test how it affects the game, and the game was 40.9 fps for the most part. So I used the 59 fps limit and now the game has perfect framepacing (obviously combined with ingame option 60 fps + VSYNC).

The second problem with hitches seems to mostly affect Brazil track. As is the track is splitted in three parts and the game loads only one at a time, because the hitches are always in the same zone. I hope Turn10 can fix this sometime because having 32 GB of RAM and 8 GB of VRAM to find out that the game have to hitch to load a part of a track is sad. Moving the game into a SSD does nothing.


Also is really odd that every time I launch the game, the windows bar doesn't disappear from the screen, neither the mouse cursor. I really hate this kind of behaviour mostly for a game that can't be played with a mouse. Devs, show the mouse cursor when the user is moving the mouse. Your animated logo at the beginning of the game look clownish with a big white cursor in the middle of the screen.



My system:
2700K @ 5 ghz HT ON
32 GB RAM
GTX1080 8GB (372.70 WHQL driver)
Windows 10 Anniversary update

Edited by user Monday, September 19, 2016 2:44:57 AM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#2 Posted : Monday, September 19, 2016 9:13:25 AM(UTC)
Originally Posted by: MaLDoX Go to Quoted Post


So, in the nvidia profile for Forza Apex I changed framerate limit to 40 to test how it affects the game, and the game was 40.9 fps for the most part. So I used the 59 fps limit and now the game has perfect framepacing (obviously combined with ingame option 60 fps + VSYNC).


Do you use frame rate limiter original or v2 (version 2) from Nvidia Inspector?

Rank: Driver's Permit
#3 Posted : Tuesday, September 20, 2016 4:24:16 AM(UTC)
I have the same issues, I would love to know if this is something Turn10 is working on??

Matt
Rank: Driver's Permit
#4 Posted : Tuesday, September 20, 2016 4:25:21 AM(UTC)
Originally Posted by: Skeleton081983 Go to Quoted Post
Originally Posted by: MaLDoX Go to Quoted Post


So, in the nvidia profile for Forza Apex I changed framerate limit to 40 to test how it affects the game, and the game was 40.9 fps for the most part. So I used the 59 fps limit and now the game has perfect framepacing (obviously combined with ingame option 60 fps + VSYNC).


Do you use frame rate limiter original or v2 (version 2) from Nvidia Inspector?




For Inspector 1.9.7.3 you have to use 59 fps limit.

For Inspector 1.9.7.6 (that uses a different tag for every value) you have to use ~60.7 for v1 or 60 fps for limiter v2.
Rank: D-Class Racing License
#5 Posted : Friday, September 23, 2016 5:01:32 PM(UTC)
What are you guys doing to get Apex to be affected by any changes in the NVCP or Inspector? I can change any and all settings in the NVCP, via a profile or globally, and absolutely nothing changes in Apex. I tried with the latest Inspector as well and nothing I change has any affect on the game. I'm trying to fix frame pacing and stutter issues as well, but with zero programs that can interface with UWP non fullscreen apps it is very difficult.
Rank: Racing Permit
#6 Posted : Monday, September 17, 2018 10:08:43 AM(UTC)
Originally Posted by: MaLDoX Go to Quoted Post
This game has two big performance problems. First of them is wrong frame pacing, and second is loading hitches in some tracks.

About frame pacing, I've encountered similar problems with every game using borderless windowed mode. That's why I only use exclusive fullscreen mode. For those problems, RTSS with a 60 fps lock does wonders, but RTSS is not compatible with UWP games. I went to try DXTory after reading that it was compatible with UWP games, but I could not get it to work with Forza Apex. I don't know why.

So, in the nvidia profile for Forza Apex I changed framerate limit to 40 to test how it affects the game, and the game was 40.9 fps for the most part. So I used the 59 fps limit and now the game has perfect framepacing (obviously combined with ingame option 60 fps + VSYNC).

The second problem with hitches seems to mostly affect Brazil track. As is the track is splitted in three parts and the game loads only one at a time, because the hitches are always in the same zone. I hope Turn10 can fix this sometime because having 32 GB of RAM and 8 GB of VRAM to find out that the game have to hitch to load a part of a track is sad. Moving the game into a SSD does nothing.


Also is really odd that every time I launch the game, the windows bar doesn't disappear from the screen, neither the mouse cursor. I really hate this kind of behaviour mostly for a game that can't be played with a mouse. Devs, show the mouse cursor when the user is moving the mouse. Your animated logo at the beginning of the game look clownish with a big white cursor in the middle of the screen.



My system:
2700K @ 5 ghz HT ON
32 GB RAM
GTX1080 8GB (372.70 WHQL driver)
Windows 10 Anniversary update


Hi bro. Sorry for a 2 years late reply, but I need some help. Do you still play Forza 6 Apex? I tried the nVidia Inspector frame rate limiter trick but the game is not smooth enough, the frame time is still irregular, I measured it with RivaTuner. Also tried to limit the frame rate with RivaTuner, but introduces some small hiccups that are random despite the frame time reporting being 16.6 ms.

I could use some help on how to make this game smoother, anything is more than welcomed, hope you can give me some light on the issue.

Notification

Icon
Error