Rank: Driver's Permit
 3 users liked this post.
#1 Posted : Thursday, May 5, 2016 10:39:52 AM(UTC)
I have a problem with the game stuttering every 2 -3 seconds. Except for these freeze lags it runs very smooth, but the stuttering makes it unplayable! Any one else suffering from this, and maybe have a solution for it?

Specs:
i5 4690K
8 GB RAM
asus GTX 960 2 GB
Rank: Driver's Permit
#2 Posted : Thursday, May 5, 2016 11:55:05 AM(UTC)
I have the same problem, but only on night races. Game runs great for daytime and even wet races, but on night races, it stutters every 1-2 seconds.

PC Specs:
i7-4790 3.6GHz
GTX 970 (365.10 drivers)
16 GB RAM

Edit: Figured out a temporary fix: Go to Video Settings in Forza, change Dynamic Optimization to CUSTOM, and change Performance Target to 60 FPS. The smoothing and shadows seem to take a bit of a hit, but it removed the stuttering. Hope it helps.

Edited by user Thursday, May 5, 2016 12:02:00 PM(UTC)  | Reason: Not specified

Rank: Racing Permit
#3 Posted : Thursday, May 5, 2016 12:04:08 PM(UTC)
My first instinct would be to try to adjust graphics settings, I force 60 FPS on mine. I have a 970 and these settings seem to work okay.

Options --> Video

Dynamic Render Quality: Low
Dynamic Optimization: Custom
Performance Target: 60 FPS

This forces the game to run 60 FPS which likely will make it feel smoother.
Rank: Driver's Permit
#4 Posted : Thursday, May 5, 2016 1:03:55 PM(UTC)
I've got a 970M with new driver and even with the advised settings, still have super stuttering everyone second or so. Absolutely unplayable.

UPDATE 1: did a clean reinstall of current driver, restarted PC, and all seems well.

UPDATE 2: definitely got rid of the super stutter, but it still plays like a beta for sure. Random FPS drops, flicking from headlights, driver names above cars disappearing randomly. Almost playable.

UPDATE 3: well now it just went back to super stutter.

Edited by user Sunday, May 8, 2016 5:38:20 AM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#5 Posted : Thursday, May 5, 2016 1:11:57 PM(UTC)
Same here, after a while it stutter like hell, graphic settings -> Ultra.

Specs:
Xeon v3 1231 @ 3.8Ghz
32GB RAM
GTX 980Ti 6GB // 365.10
Rank: Driver's License
#6 Posted : Thursday, May 5, 2016 1:33:25 PM(UTC)
Same issue here. The game will stutter after a while regardless of the graphical settings. I tried the highest possible for me, medium, low, lowest, nothing helps.

My specs:
Intel Core i5-3570k @4.2GHz
2x4GB Kingston HyperX DDR3 1866MHz CL9
EVGA GTX670 SC 2GB
Rank: B-Class Racing License
#7 Posted : Thursday, May 5, 2016 1:41:31 PM(UTC)
I had this a few times in rainy weather, and when i sometimes crashed into a opponent, it started lagging like crazy. quitting and restarting race seems to fix it for me tho.
Rank: Driver's License
 1 user liked this post.
#8 Posted : Thursday, May 5, 2016 1:57:01 PM(UTC)
Agreed with all above.
Every cut-scene and every race start does it lag / stutter / frame drop.
Taking advice from those above i even tried to turn the graphic settings to minimum, all this resulted in the game failing to render anything other than the lights at Yas Marina.
Game completely froze and crashed.

Despite the fact that it's a Beta / Early Access I can't hide my sadness as i've been really looking forward to playing a Forza title on PC.

P.S
Handling characteristics using a Microsoft 360 Controller are just appaling

Specs:
AMD FX6350 BE @ 4GHz
16GB CRUCIAL BALLISTIX TRACER RAM (1866Mhz)
EVGA GTX960 SSC 2GB GRAPHICS CARD @1404Mhz
CORSAIR H80iGT Liquid cooling

Regards

SCOOBY
Rank: B-Class Racing License
#9 Posted : Thursday, May 5, 2016 2:07:05 PM(UTC)
Scooby, silly question perhaps but did you update to latest Nvidia Drivers? v365.10.
Rank: Driver's Permit
#10 Posted : Thursday, May 5, 2016 3:32:51 PM(UTC)
Yeah I got the latest nvidia drivers, tried all different combinations of graphics settings possible but no cigar. Seems to affect some tracks more than others, and some conditions more than others though. Hopefully an update will take care of it soon!
Rank: Driver's Permit
#11 Posted : Thursday, May 5, 2016 5:17:32 PM(UTC)
It's the V-sync setting, I also had the stuttering and went into my Nvidia panel and changed my Adaptive sync to Use application setting and completely fixed the stuttering.
Rank: Driver's Permit
#12 Posted : Thursday, May 5, 2016 5:29:16 PM(UTC)
Originally Posted by: Trackah123 Go to Quoted Post
Scooby, silly question perhaps but did you update to latest Nvidia Drivers? v365.10.


I have found those drivers give poor performance on other games sir,esp middle earth shadow of mordor.
Rank: Driver's Permit
#13 Posted : Thursday, May 5, 2016 5:32:34 PM(UTC)
Stuttering,joining the club...
i5 3570k
Gskill 8gb ram@2133
gtx 760 hawk
Rank: Driver's Permit
#14 Posted : Thursday, May 5, 2016 7:24:52 PM(UTC)
Originally Posted by: NeoMegaX Go to Quoted Post
I've got a 970M with new driver and even with the advised settings, still have super stuttering everyone second or so. Absolutely unplayable.

UPDATE 1: did a clean reinstall of current driver, restarted PC, and all seems well.

UPDATE 2: definitely got rid of the super stutter, but it still plays like a beta for sure. Random FPS drops, flicking from headlights, driver names above cars disappearing randomly. Almost playable.



I have a 3GB 970M inside of an ASUS G751-JT paired with a i7-4710HQ, and I can play on high with little to no problems..... interesting......
Rank: Driver's License
#15 Posted : Thursday, May 5, 2016 8:12:51 PM(UTC)
Originally Posted by: Trackah123 Go to Quoted Post
Scooby, silly question perhaps but did you update to latest Nvidia Drivers? v365.10.


Hi there, yes, i updsted the graphics driver as soon as it landed.

The usual suspects are running just fine ( AC, PC, iRacing, Dirt Rally and The Crew )

The first lap of any race is truly appalling then the game seems to settle down somewhat. It's obviously not happy having to render all that info at the same time, once the field spreads out alittle the stuttering settles a little
Rank: Driver's License
#16 Posted : Thursday, May 5, 2016 9:36:17 PM(UTC)
Originally Posted by: mevoki Go to Quoted Post
I have a problem with the game stuttering every 2 -3 seconds. Except for these freeze lags it runs very smooth, but the stuttering makes it unplayable! Any one else suffering from this, and maybe have a solution for it?

Specs:
i5 4690K
8 GB RAM
asus GTX 960 2 GB


Yup, Yas Marina night races got very stuttery. FPS Monitor showed no frames dropping.. Seemed like almost 15-40 FPS on that track. Game is very playable for me with the exception of Yas Marina

i7 6700k
16 GB DDR4
GTX 980
Rank: Driver's License
#17 Posted : Thursday, May 5, 2016 10:45:45 PM(UTC)
Also getting the stuttering at times.

1440p max settings

3770K @4.5 GHz
980 Ti
8GB RAM
SSD

All drivers up to date.

Edited by user Thursday, May 5, 2016 10:46:41 PM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#18 Posted : Thursday, May 5, 2016 10:56:28 PM(UTC)
It stutters like crazy when i drive in the day time.. MS fix this mess the only game that worked great from the start for is KI.

i76700k
GTX970
Rank: A-Class Racing License
#19 Posted : Thursday, May 5, 2016 11:06:05 PM(UTC)
Just a TEST for people that are a bit savvy: if you have more 12GB of RAM in your PC, can you try running the game WITHOUT a pagefile present in your Windows and without an active virusscanner?

It might sound obvious to some but pagefiles always get used for the wrong reasons and since even NVME PCIe SSD's are slower in random read/write than RAM, it could cause stuttering in almost every application (including games).

Looking forward to your results; my PC is a bit more underpowered than most machines mentioned in this thread but running 1080p on a GTX960 and I have experienced 0 stutters. Then again, I never used pagefiles and rely heavily on RAM (I always but my PC's with double the RAM needed for the current games at purchase) meaning I have 16GB but should be upgrading to 32GB soon.
Rank: Driver's Permit
#20 Posted : Friday, May 6, 2016 5:09:30 AM(UTC)
Same ugly stuttering here:

CPU: AMD FX-8350@4.4GHz
RAM: 16GB DDR3 1866MHz
GPU: AMD Fury-X (Crimson 16.5.1)
SSD: Samsung 850 Pro
Monitor: LG 27MU67-B (Freesync On & Off)
Rank: Driver's Permit
#21 Posted : Friday, May 6, 2016 6:44:24 AM(UTC)
It has memory leak, so as soon as it eats all the RAM it starts to stutter.

I hope that they will fix it soon, I really like it but cant enjoy it since i have to quit game after every race.
Rank: B-Class Racing License
#22 Posted : Friday, May 6, 2016 7:14:26 AM(UTC)
Well Forza is still in Beta, so it's probably not 100% stable yet. i've read other posts and it might be related to multiple monitors (dual screen setups) and extreme high refresh rates and such.
Rank: Driver's Permit
#23 Posted : Friday, May 6, 2016 7:48:46 AM(UTC)
With all these stuttering problems, I'm getting kind of worried now if i'll run into the same issue for when my gtx 980 ti arrives. currently *knock on wood* I don't have any stuttering issues with my gtx 680.

I'll keep this thread in mind for when I upgrade my GPU.
Rank: Driver's Permit
#24 Posted : Friday, May 6, 2016 9:02:12 AM(UTC)
I'm having stutter issue too. On the first lap of any race, it stutters a bit, then they disappera. But when I load the next track, the stutters come back, and are much heavier.

SPEC:
i7 3630QM
GT650m
8 GB RAM

I play the game on the minimum settings, and when it doesn't stutter, is very playable, above 30/40 fps.
Could be a BUG with RAM or VRAM usage?
Rank: Driver's Permit
#25 Posted : Friday, May 6, 2016 10:01:50 AM(UTC)
I Have the same Problem! PLEASE FIX THAT!!
I have the last drivers on all devices in my computer!
This event is so random!, Memory leek or something and a problem with the V-sync images, I do not understand what it is!

SPEC:
Intel® Coreā„¢ i7 4700HQ
8GB DDR3 1600 MHz
NVIDIA® GeForce® GT 745M 2GB
SSD Crucial 240GB
6 Pages123>>Next

Notification

Icon
Error