Rank: Driver's Permit
#1 Posted : Thursday, September 17, 2015 8:18:50 AM(UTC)
Hello, I purchased the Forza 6 Xbox One Limited Edition bundle. With it, I also bought the Thrustmaster TX Racing wheel, T3PA Pedals and TH8A Shifter.

I am having a lot of problems with Forza 6 detecting the Thrustmaster TX racing wheel. When I power my Xbox One ON, the wheel is connected to it. It works perfectly fine in the Xbox One menu, I can navigate through that menu just fine with the wheel. However when I select Forza 6 & the game launches I get this "Controller disconnected, not currently paired to a gamepad. Please press the Xbox button with the gamepad that you would like to play with and choose your profile from the account picker with the gamepad." I press the Thrustmaster TX's Xbox button which just brings me back to Xbox One's menu, and the wheel worked great there for navigation etc. Then I choose the game again, and get the same above message every single time. No matter what, Forza 6 does not recognize & authenticate my wheel. I had it somehow mysteriously pair successfully once before, but after powering the Xbox off & on again; exactly the same thing happened!

This is VERY frustrating, so much so that I want to return EVERYTHING back to the store!

Can someone please help me fix this properly?

P.S. The Thrustmaster wheel is all up to date on the latest firmware & works perfectly with my PC & Project Cars every single time; just not with Xbox & Forza 6.

EDIT: After speaking with Thrustmaster Support: The ONLY way I can get Forza 6 to detect my wheel in game is if I disconnect the Xbox One's power supply, while leaving the wheel plugged in to Xbox... After connecting the power supply, and turning Xbone ON, it works. This is a temporary fix, but we need a permanent fix to this problem!!

Sidenote, another bug I ran into while racing with the wheel, suddenly in game my controls get re-mapped! Eg: The rewind button is normally by default set to "X".. While in game it will change that randomly to "Y" all on it's own! Please fix this.

Edited by user Thursday, September 17, 2015 10:02:55 AM(UTC)  | Reason: Not specified