This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
2 Pages12Next
Rank: Driver's Permit
#1 Posted : Monday, October 6, 2014 10:22:11 AM(UTC)
So, I am already on my second TX wheel (on the first the D-Pad stopped working so I had it replaced).

My problem now is that when I connect the wheel to the Xbox it does the full calibration procedure (spinning back and forth) and if I quickly press a button or two after that it responds to that also. But a couple seconds later the Xbox no longer takes any input at all from the wheel. The wheel still has power and the leds are lit, but no matter what I do the Xbox no longer responds to it. I have gone through the full 'USB reset' guide from Thrustmaster (fully power the console off, remove power cable, connect the wheel and then the power cable again, turn the console on using the button on the front and using no other controller before I try to use the wheel again) and it does nothing.

I have also (again) connected the wheel to my PC where it works fine, all buttons etc. respond, and re-updated the firmware.

I'm at a loss what to do at this point. Not looking forward to sending this wheel back for a replacement again, it is a major hassle, takes too long and I want to get back playing Forza Horizon 2...

Any ideas/suggestions what to do would be much appreciated.
Rank: D-Class Racing License
#2 Posted : Monday, October 6, 2014 10:38:36 AM(UTC)
I've never experienced this issue. Have you tried plugging into a different USB port on the xbox one? It could be that one port has become faulty
Rank: Driver's Permit
#3 Posted : Monday, October 6, 2014 11:00:51 AM(UTC)
Yes, I've tried the side USB port (the one I normally use for the wheel) as well as both the ones on the back of the console.
Rank: Driver's License
#4 Posted : Monday, October 6, 2014 11:11:41 PM(UTC)
Mine just started acting up tonight after I installed Horizon 2. When it boots up, it starts the calabration (spins the wheel) and when it's just about done it powers off (goes dead, all LEDs off). I powered the XBox One completely off and then did the usual restart proceedure (turn on XB1, plug in wheel to power, plug usb into Xbox) but each time it does the same thing, it starts the wheel spin calibration and then dies. Haven't found any other reports of this, will probably have to report to Thrustmaster and see what they say. I'll try it with a PC tomorrow.
Racing is Life. Anything that happens before or after is just waiting. - Steve McQueen
Rank: Driver's Permit
#5 Posted : Tuesday, October 7, 2014 11:50:42 PM(UTC)
I did a complete factory reset of my Xbox to see if the wheel would be detected after that but still the same, it gets calibrated and responds to input for about five seconds and then dies.

I'm not at all impressed with Thrustmaster at this point, their quality control and build quality for these wheels is abysmal. This is the second one that has died for me and neither of them had seen a lot of use (real life doesn't permit me to game anywhere near how much I would like to do...), maybe 30 hours of use in total for both wheels. And on these forums, Amazon's reviews etc. there are a large number of posts about defective wheels.

Returning it to Amazon UK in the next few days. Talked to them and they will do a refund but not a replacement - I suspect they have had so many returned multiple times that they have removed it from their listings. Currently it can only be ordered from 3rd party retailers listed on Amazon UK, there is no longer any listing by Amazon itself...
Rank: B-Class Racing License
#6 Posted : Wednesday, October 8, 2014 6:20:10 AM(UTC)
You think Fanatec doesn't have problems? a guy one inside sim racing had 3 fanatec Elete bases fail in a row ! This is why he won't buy Fanatecs new base

Here's what he posted in inside sim racing

This time I'm safely going to wait another year, seeing and hearing what people really think of the new wheel base after a couple of months using it... To much/to soon I have put my faith (and money) by believing the marketing stories of Fanatec, while the result was that I had to send back 3 products for repair just within 1 year of use... The Fanatec customer service was good, that was/is not the case, but the products shouldn't broke down after a short time when they were as good as Fanatec said they were...
Rank: Driver's Permit
#7 Posted : Wednesday, October 8, 2014 11:57:04 PM(UTC)
I don't really see the point of bringing up Fanatec in this thread?

I started it by asking for help/suggestions with my 2nd defective Thrustmaster TX wheel and now that I have determined that I am not realistically ever going to get it back in working order, and also no longer able to get it replaced from the seller (Amazon UK) , the final outcome being that I an returning it for a refund. Then I also pointed out my obvious disappointment with the evident lack of quality in this Thrustmaster product, something that I am obviously not alone in experiencing.

I don't have a Fanatec wheel or any other Fanatec product so I really don't know if they have any problems nor does it directly affect me if they do.

I do own other Thrustmaster products (the HOTAS Warthog system) which I am very happy with, but I will most likely not consider Thrustmaster again when looking for a new racing wheel.
Rank: C-Class Racing License
#8 Posted : Thursday, October 9, 2014 1:50:01 AM(UTC)
Originally Posted by: Fafne Go to Quoted Post
I don't really see the point of bringing up Fanatec in this thread?

I started it by asking for help/suggestions with my 2nd defective Thrustmaster TX wheel and now that I have determined that I am not realistically ever going to get it back in working order, and also no longer able to get it replaced from the seller (Amazon UK) , the final outcome being that I an returning it for a refund. Then I also pointed out my obvious disappointment with the evident lack of quality in this Thrustmaster product, something that I am obviously not alone in experiencing.

I don't have a Fanatec wheel or any other Fanatec product so I really don't know if they have any problems nor does it directly affect me if they do.

I do own other Thrustmaster products (the HOTAS Warthog system) which I am very happy with, but I will most likely not consider Thrustmaster again when looking for a new racing wheel.


I agree - Thrustmaster's quality control is appalling. I certainly won't be buying another one of their products. Mine went up in smoke within moments of first using it - then after going through their lengthy and inept RMA procedure the wheel came back....STILL BROKEN. It's been over a month since I bought the thing and I've had about 5 minutes use out of it in total!

I've had to RMA things before (360 red ring of death, anyone), but I've never experience such a poor service as I have received from Thrustmaster. Worst of all, if you want to eventually use the wheel, you HAVE to go through the RMA. If you return it to the retailer for a replacement, the new wheel is just as likely to be broken.

The REALLY annoying thing is that when the wheel DOES actually work it's apparently really rather good. Such a shame their quality control and customer service lets them down so badly. I've noticed GAME don't stock the wheel either any more, they must have got fed up with all the returns as well!.
Rank: Driver's Permit
#9 Posted : Thursday, October 9, 2014 5:00:34 AM(UTC)
Originally Posted by: Khan Go to Quoted Post
Mine just started acting up tonight after I installed Horizon 2. When it boots up, it starts the calabration (spins the wheel) and when it's just about done it powers off (goes dead, all LEDs off). I powered the XBox One completely off and then did the usual restart proceedure (turn on XB1, plug in wheel to power, plug usb into Xbox) but each time it does the same thing, it starts the wheel spin calibration and then dies. Haven't found any other reports of this, will probably have to report to Thrustmaster and see what they say. I'll try it with a PC tomorrow.



I am seeing the exact same problem with my wheel. Fired off an email to Thrustmaster support waiting for their analysis. Any more news about this issue?

Rank: B-Class Racing License
#10 Posted : Thursday, October 9, 2014 6:54:55 AM(UTC)
Thrustmasterssupport is fantastic imo as they have replaced my GTE wheel and I got to keep my old one for spare parts, they have been nothing but perfect with their support and replacements! I have one of the wheels from the first batch and it works perfectly and I have 2700 points on Forza 5 so I have actually used my wheel!

Edited by user Thursday, October 9, 2014 7:26:02 AM(UTC)  | Reason: Not specified

Rank: B-Class Racing License
#11 Posted : Thursday, October 9, 2014 7:23:55 AM(UTC)
Also when someone has only posted twice here it seems that well you know your creditability is suspect just like the other thrustmaster bashing lately!

Edited by user Thursday, October 9, 2014 7:25:09 AM(UTC)  | Reason: Not specified

Rank: S-Class Racing License
 4 users liked this post.
#12 Posted : Thursday, October 9, 2014 1:57:02 PM(UTC)
Originally Posted by: jaredo Go to Quoted Post
Also when someone has only posted twice here it seems that well you know your creditability is suspect just like the other thrustmaster bashing lately!


That would be 'credibility'. If you have some advice to offer I'm sure the complainants in this thread would be glad to hear it. So far all Iyou have offered is inflammatory trolling.

Rank: B-Class Racing License
#13 Posted : Thursday, October 9, 2014 4:32:10 PM(UTC)
He said he was done , I replied that mine is fine , all wheels have problems and thrustmaster support replaces parts that break or don't work ,
Rank: Driver's Permit
#14 Posted : Friday, October 10, 2014 2:38:03 AM(UTC)
This is a bit hilarious really..

I have only posted twice before so I have no 'creditability' (dictionaries/spell checkers are great, aren't they?) Well, I post when I actually have something to say, in this case I was looking for assistance with a defective steering wheel. The best outcome I was hoping for was someone having a work-around that would have allowed me to keep the wheel and keep playing. And generally I prefer to play rather than post on a forum, go figure...

And I am 'Thrustmaster bashing'? By reading entire posts and not only select portions thereof, you might have picked up on the fact that I stated I own other Thrustmaster products I am perfectly happy with. I have been playing flight sims for 15+ years now and I have been using different Thrustmaster flightsticks for just about as long. The Thrustmaster HOTAS Warthog that I am currently using is state-of-the-art and easily the best controller I have ever had hooked up to either a PC or a console. That, however, doesn't change the fact that my experience with the TX Racing Wheel has been a massive disappointment.

While trying to tell everyone in the thread that Thrustmaster wheels are perfect, you also let slip that you have also needed to have one replaced. That is really not a vote in favor of Thrustmaster's quality control when it comes to steering wheels right there... I'm not entirely sure that Thrustmaster would feel that you are helping their case, maybe it is time to vacate the thread...?

I got a complete refund from Amazon UK so I put in an order for another steering wheel, the Mad Catz one. I have already understood from reviews etc. that the Force Feedback etc. is not up to par with the TX Racing and that the wheel is noisy, but I'm just hoping it will actually work for a while until something better is released. I have been using a Wheelstand Pro for the TX Racing and I hope that by drilling new holes in the base plate I should be able to attach the Mad Catz wheel to the same stand. If anyone actually owns the Mad Catz Pro Racing Wheel for Xbox One, it would be much appreciated if you could tell me how far apart the holes to bolt it down with are so that I know if I should send for a new base plate from Wheelstand Pro right away or if I can make do with my current one.
Rank: B-Class Racing License
#15 Posted : Friday, October 10, 2014 8:52:14 AM(UTC)
Well I know thrustmaster customer support rocks! What's funny is that if the d pad was the problem they would have you just send the rim back not the base! Also why did you not post about the original problem? Yes I had a GTE rim go bad the button was stuck and they didn't bother having me even send it back they wanted a video! So you saying the cheap stock rim s d pad failed and they had you send the whole thing back ? Lol

Rank: Series Champion
#16 Posted : Friday, October 10, 2014 1:52:36 PM(UTC)
Originally Posted by: jaredo Go to Quoted Post
Well I know thrustmaster customer support rocks! What's funny is that if the d pad was the problem they would have you just send the rim back not the base! Also why did you not post about the original problem? Yes I had a GTE rim go bad the button was stuck and they didn't bother having me even send it back they wanted a video! So you saying the cheap stock rim s d pad failed and they had you send the whole thing back ? Lol



Your experience does not equal Fact.

When my fanatec was DOA I had to send back the pedals and everything, not just the wheel which was the faulty part. When I needed warranty the second time around I got told to go jump by fanatec.
Now I know others had good support from them, but I did not.
The same can easily be said for thrustmaster, or any other manufacturer. So no, you dont know support from thrustmaster rocks. You know that you had a good experience. You could be that 1% for all you know.


Talking to brick walls since 2007.
Motivational Poster. Praise Dragnet
Rank: B-Class Racing License
#17 Posted : Friday, October 10, 2014 2:29:19 PM(UTC)
i purchased a realistic brake mod for my t500 pedals need a replacement part and they sent me a whole new kit!

My wheel had a centering problem and the support lady knew what she was doing and soon it was perfect and has been ever since. If you have a problem they have a great email system that lets you know they are looking into the matter. support get back to you and you are not forgotten !

Rank: B-Class Racing License
#18 Posted : Friday, October 10, 2014 2:37:41 PM(UTC)
I have been useing Thrustmaster products since the 90s and have always trusted their products to be of the highest quality!
Rank: Driver's Permit
#19 Posted : Wednesday, October 15, 2014 9:49:30 AM(UTC)
I have experienced the same problem as the OP. Called Thrustmaster support and was told to hook wheel up to my pc to see if it registered properly on that. Through the Thrustmaster control panel, everything is 100% accurate and in working order. So, problem is with the Xbone and not the wheel. The only thing I have done between the time the wheel worked on the Xbone and now is add a new profile for my girlfriend so that she could play Dance Central. I'm deleting the profile and then going through all the resets to see if this does anything.
Rank: Driver's Permit
#20 Posted : Wednesday, October 15, 2014 4:37:25 PM(UTC)
I figured I'd give the wheel one more shot before deleting the girlfriend's profile and, of course, it worked. My suggestion to anyone experiencing this issue is to plug the wheel via USB into your pc and go to the Thrustmaster Control Panel to verify that the wheel is actually responsive and then back to the Xbone. It worked for me and I'm back to playing the game properly with my TX and Playseat. What a blast!
Rank: Driver's Permit
#21 Posted : Wednesday, November 5, 2014 12:39:04 AM(UTC)
Originally Posted by: Fafne Go to Quoted Post
So, I am already on my second TX wheel (on the first the D-Pad stopped working so I had it replaced).

My problem now is that when I connect the wheel to the Xbox it does the full calibration procedure (spinning back and forth) and if I quickly press a button or two after that it responds to that also. But a couple seconds later the Xbox no longer takes any input at all from the wheel. The wheel still has power and the leds are lit, but no matter what I do the Xbox no longer responds to it. I have gone through the full 'USB reset' guide from Thrustmaster (fully power the console off, remove power cable, connect the wheel and then the power cable again, turn the console on using the button on the front and using no other controller before I try to use the wheel again) and it does nothing.

I have also (again) connected the wheel to my PC where it works fine, all buttons etc. respond, and re-updated the firmware.

I'm at a loss what to do at this point. Not looking forward to sending this wheel back for a replacement again, it is a major hassle, takes too long and I want to get back playing Forza Horizon 2...

Any ideas/suggestions what to do would be much appreciated.


Hi

I am having the same issue. By any chance where you using a USB extender?
Rank: Driver's Permit
#22 Posted : Thursday, February 19, 2015 11:14:20 AM(UTC)
Hi I am having the exact same issue.

Any luck with getting this to work?
Rank: Driver's Permit
#23 Posted : Friday, May 1, 2015 12:51:30 AM(UTC)
ok guys so here i am in 2015 and FEELING SO SORRY I DIDNT LOOK AT REVIEWS b4 actually getting this item(THRUST MASTER TX EDITION) .......I just ordered this wheel along with the 3 peddals shifter and stand (glad i didnt get the chair at this point)spent just about 800us ,unbox set up ,GUES WHAT !base works wheels doesnt ,i update on pc which it doesnt state u have to manditory do on pc ,and still nothing ......so i spend 800 wait one week for a faulty junk that has been having issues from what i see for few years already you would think they fix this issues already if they continue to make acceseries for it .........DONT BOTHER CALLING THEM ,worthless can barely speak inglish................
Rank: Driver's Permit
#24 Posted : Tuesday, September 1, 2015 5:24:30 PM(UTC)
Just got my wheel tonight and its doing this same issue. Its responds initially for about 5 seconds then nothing. Tried all the usb, reset the usbs, reset my xbox, and nothing. Base guide button works but nothing on the wheel itself. Anybody get an answer on this or find a fix?
Rank: Driver's Permit
#25 Posted : Saturday, September 19, 2015 12:25:23 PM(UTC)
Still having the same issue too. Trying to keep this post alive to see if there is a known fix.
2 Pages12Next

Notification

Icon
Error