9 Pages<<789Prev
Rank: Racing Permit
#201 Posted : Monday, January 26, 2015 8:05:11 PM(UTC)
Help i have the digital version of this game
ive never had a problem before
it just wont load up
wot do
Rank: Racing Legend
 1 user liked this post.
#202 Posted : Monday, January 26, 2015 8:20:32 PM(UTC)
On the Xbox One, correct? Do the complete console shut down from the Dashboard with no programs open, hold the X button on the front of the Xbox One until the unit shuts down by itself.

The disconnect the external power pack cord from the wall, or at least the wall-side plug from the power pack. Let it sit for about three minutes until all power drains. Reconnect, wait until the power pack shows the orange-ish color (not the "on" white) and then start your console as you normally do. Let the unit fully boot (it may take a few minutes), then try to launch the game again.

IF you get a screen of Horizon 2 doing a sync with The Cloud, DO NOT interrupt it. Let it totally finish.

Edited by user Monday, January 26, 2015 8:21:33 PM(UTC)  | Reason: Not specified

Pay It Forward
This posting is provided as is; with no warranties, and confers no rights.

Rank: Racing Legend
#203 Posted : Monday, January 26, 2015 8:30:20 PM(UTC)
Do you mean after the sync and the final load before you get in the game?

If so do nothing. DO NOT CANCEL out of it. Let it finish.
I blame the ants.
Rank: Driver's Permit
#204 Posted : Wednesday, January 28, 2015 8:01:23 AM(UTC)
No I mean as soon as you insert the game disc and press A to start. All I get is "Loading.......Please Wait!" I have tried the complete system shut down along with router reset. Going to try again soon but nothing so far. Its also weird because Titanfall does the same thing but Destiny works fine. I say this is weird because all three games are cloud and multiplayer based.

Edited by user Wednesday, January 28, 2015 8:39:37 AM(UTC)  | Reason: Not specified

Rank: D-Class Racing License
#205 Posted : Tuesday, February 3, 2015 4:04:21 PM(UTC)
So I fired up Forza and for the last 3+hours it has been "loading". Not sure what is going on here? I understand there is some sort of monthly update? But this is ridiculous. Is something wrong with my xboxone?
Rank: Driver's License
#206 Posted : Wednesday, February 4, 2015 7:56:10 PM(UTC)
[Mod Edit - Can't get past splash screen ("Loading, please wait") on Xbox One thread merged - MM]

It just sits there cycling through the splash screen images. I tried uninstalling/reinstalling but it's the same issue. Tried calling Xbox Live support, said I had 2 email addresses associated with my Live account (which I don't), said I didn't have a phone number associated with my account (which I do), then the call dropped. Before it dropped, she said she was looking up a phone # for Forza support which I'm guessing doesn't exist.

Has anyone had a similar issue with not advancing past the splash screen?

Edited by user Thursday, February 5, 2015 12:37:06 AM(UTC)  | Reason: Not specified

Rank: Driver's License
#207 Posted : Wednesday, February 4, 2015 8:02:51 PM(UTC)
Have you done a reset on your Xbox (I am assuming you have a Xbox one)?
Rank: Racing Legend
#208 Posted : Wednesday, February 4, 2015 8:08:27 PM(UTC)
If you mean the lading screen let it finish loading and if it has doen a full resync it can take hours.

It sometimes looks like its doing nothing but in reality it is working, just lsowly.

Let it finish, go away and do something else and come back an hour or two later.
I blame the ants.
Rank: Driver's License
#209 Posted : Wednesday, February 4, 2015 9:02:44 PM(UTC)
Originally Posted by: banderson1962 Go to Quoted Post
It just sits there cycling through the splash screen images. I tried uninstalling/reinstalling but it's the same issue. Tried calling Xbox Live support, said I had 2 email addresses associated with my Live account (which I don't), said I didn't have a phone number associated with my account (which I do), then the call dropped. Before it dropped, she said she was looking up a phone # for Forza support which I'm guessing doesn't exist.

Has anyone had a similar issue with not advancing past the splash screen?


This happens to me all the time. Just do a hard reset on your xbox.( hold down the power button for 20 seconds)
Rank: Racing Legend
 1 user liked this post.
#210 Posted : Wednesday, February 4, 2015 9:13:23 PM(UTC)
Originally Posted by: Dont Quit Noob Go to Quoted Post
Originally Posted by: banderson1962 Go to Quoted Post
It just sits there cycling through the splash screen images. I tried uninstalling/reinstalling but it's the same issue. Tried calling Xbox Live support, said I had 2 email addresses associated with my Live account (which I don't), said I didn't have a phone number associated with my account (which I do), then the call dropped. Before it dropped, she said she was looking up a phone # for Forza support which I'm guessing doesn't exist.

Has anyone had a similar issue with not advancing past the splash screen?


This happens to me all the time. Just do a hard reset on your xbox.( hold down the power button for 20 seconds)


Don't hard reset while it is in that state as you run the risk of it corrupting your save.

I would still suggest let it be to try and load.

If you get so impatient then pres the guide button then menu button and choose quit before doing the hard reset.

I personally would still wait it out because doing anything else risks corrupting the save.
I blame the ants.
Rank: Driver's Permit
#211 Posted : Monday, March 30, 2015 5:24:16 AM(UTC)
The problem I'm having is it won't synch. It doesn't even start to synch. I've called Microsoft, and they had me re-install my profile and the game itself. Still won't synch. I believe the file to be corrupted. What else can be done?

Since the first corruption, I've already lost all my progress, now the game won't synch the new progress, no synching.....Where are you Turn 10??

Edited by user Tuesday, March 31, 2015 8:12:55 AM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#212 Posted : Thursday, April 9, 2015 8:47:05 AM(UTC)
Well this started about 3 days ago and what happens is, It go's through the Playground games and turn 10 logo screens and onto the login/load save data screen and when it starts loading my save data just doesn't load. I haven't bought any dlc for it recently.
Rank: D-Class Racing License
#213 Posted : Thursday, April 9, 2015 12:18:46 PM(UTC)
To be fair to Turn 10, and a huge thank you to HeliosT10, I've had my gift cars reinstated after losing my save game due to syncing.
It's a help, time to start the game again!!

Again huge thanks to Helios!
OldTimerGamer - Been gaming for over 30 years.
Rank: Driver's Permit
#214 Posted : Thursday, April 30, 2015 4:03:49 PM(UTC)
I had to do a full restart of the game, I lost all of my saved game that I had, I was at a gold wrist band, I had in game winnings of over 30 million, rewards exceeding 15 million, not to mention the Turn 10 rewards of 14.7 million, I'm hoping that Turn 10 can at least get me some of those credits that I lost back. I've read in a few place about some HeliosT10, I'm wondering how to get ahold of this individual, and hopefully this person could help me get back some of what I lost.

Edited by user Thursday, April 30, 2015 4:08:30 PM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#215 Posted : Thursday, May 21, 2015 10:01:47 AM(UTC)
ok im having the loading issue for the past week and looking at the threads the last time this happen was 7 months ago,,,are people getting dropped out of the severs
Rank: Driver's Permit
#216 Posted : Thursday, May 21, 2015 12:07:37 PM(UTC)
Forza Horizon 2 won't load on xbox one
Rank: Racing Permit
#217 Posted : Wednesday, September 23, 2015 2:42:23 PM(UTC)
The subject title pretty much sums it up. I've tried uninstalling it and reinstalling it, I've rebooted my Xbox One a couple times, I made sure the disc was clean and had no scratches and I even tried just leaving it on the load screen for a bit. And nothing. Any ideas? Thanks!

Edit: It seems to be working now.

Edited by user Friday, September 25, 2015 1:43:57 PM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#218 Posted : Thursday, January 21, 2016 8:38:30 PM(UTC)
Every time i load up forza horizon 2 it freezes when it gets to the rpm gauges while loading i cant fix it
9 Pages<<789Prev

Notification

Icon
Error