Rank: Driver's Permit
#1 Posted : Wednesday, March 3, 2021 1:07:13 PM(UTC)

I wasted an evening trying to get this to work. It seems totally broken to me.

Going in to the menu seems to change the game resolution - text looks slightly blurred and then the menu's refuse to work, whether I try with a kb or a controller.

When I can get the game to run, everything appears smooth for about 20 or so seconds then I get serious micro-stuttering and the frame rate lurches between 72 and 53 fps. If I make the target frame rate as unlimited, it still stutters, even though the FPS is in the 140-130 range.

When I first played this game it ran perfectly fine. That was over a year ago and I had an GTX 1070 then. Now I've got an RTX 2080.

i7 8700
RTX 2080 graphics card.

Runing latest Windows 10 and Nvidia drivers.

Any way to fix and make it playable?
Rank: D-Class Racing License
#2 Posted : Thursday, March 11, 2021 9:05:26 AM(UTC)
Same problem for me, I tried to redownload the game and to switch the installation drive without success.
I think that it is an issue related to nvidia drivers or windows update, if you find a solution please update this thread
Rank: Driver's Permit
#3 Posted : Thursday, March 11, 2021 11:56:45 AM(UTC)
I found this reply in a 2 year old thread.
Open Control Panel in Windows. Click Devices and Printers. Select your controller (plug it in), right click on it, and click Properties. Click on the Hardware tab. Right click on USB Input Device, and click Properties. You end of on the General tab. Click the Change Settings button and then click the Driver tab. Click on disable device.
Again this reply is 2 years old, but it solved the input recognition problem both in the menus and while driving for me. I can finally play the game at max settings.
Rank: Driver's Permit
#4 Posted : Monday, March 15, 2021 2:25:27 AM(UTC)
Okay, I might have found a workaround for this issue... that I can't quiet explain.

- start the game and wait for the "press any key" splashscreen to appear (it should still be windowed)
- click somewhere on the window
- when the game registers the input and starts loading you click on any other window (folder, discord, etc.) wait ~half a second, then click on the FM7 again
and it should go fullscreen without that blurry mess

I have no idea why this works for me, but somehow taking the focus out of the game and bringing it in again seems to trigger something.

Edited by user Sunday, April 4, 2021 4:50:07 AM(UTC)  | Reason: Not specified