4 Pages123>>Next
Rank: Driver's Permit
 11 users liked this post.
#1 Posted : Thursday, December 10, 2020 12:09:53 PM(UTC)
Hi guys. I'm really struggling with this but as soon as I get to the location for the top gear race the game loads the mission and then puts me into the car etc however the car just stops and the game gets stuck in a loading screen. Would appreciate it if anyone can help me fix.
Rank: Driver's Permit
 9 users liked this post.
#2 Posted : Saturday, December 12, 2020 4:14:46 PM(UTC)
Same for me.

Will two with the issue get a reply?

Rank: Driver's Permit
 3 users liked this post.
#3 Posted : Sunday, December 13, 2020 4:05:06 PM(UTC)
Having the same issue on xbox one x. I start the top gear challenge then the car stops and the loading circle in the bottom right never goes away. waited 10min before restarting the game did that 10 times with the same results. Here I thought cyberpunk had glitches at least cdpr is putting patches out while horizon 4 has been out for over 3 years guess turn10studios just don't care. Smh

Edited by user Friday, December 18, 2020 10:20:24 PM(UTC)  | Reason: Not specified

Rank: C-Class Racing License
 3 users liked this post.
#4 Posted : Monday, December 14, 2020 7:00:24 AM(UTC)
I have the same issue on Xbox one. Can anyone help?
Rank: Driver's Permit
 2 users liked this post.
#5 Posted : Monday, December 14, 2020 1:24:28 PM(UTC)
Picked the game back up after a hiatus.
Having the same issue on PC and XBox Series X.
Rank: Driver's Permit
 2 users liked this post.
#6 Posted : Tuesday, December 15, 2020 3:39:37 AM(UTC)
Same here, please help!!!!!
Rank: Driver's Permit
 2 users liked this post.
#7 Posted : Tuesday, December 15, 2020 2:40:48 PM(UTC)
Same here on PC. Very frustrating. Have to force quit the game
Rank: Driver's Permit
 2 users liked this post.
#8 Posted : Tuesday, December 15, 2020 7:17:05 PM(UTC)
Same here on Pc.
Rank: D-Class Racing License
 2 users liked this post.
#9 Posted : Tuesday, December 15, 2020 7:21:45 PM(UTC)
Samesies on a Series X.

Edited by user Tuesday, December 15, 2020 9:56:43 PM(UTC)  | Reason: Not specified

Rank: Driver's Permit
 1 user liked this post.
#10 Posted : Wednesday, December 16, 2020 7:12:51 AM(UTC)
my husband and i are both having this issue as well! we are both on PC.
Rank: Driver's Permit
 1 user liked this post.
#11 Posted : Wednesday, December 16, 2020 11:09:10 AM(UTC)
same issue on my PC too
Rank: Driver's License
 1 user liked this post.
#12 Posted : Wednesday, December 16, 2020 9:34:34 PM(UTC)
Same here, after over two years of crashing and losing data and the game crashing, I think I’ve had enough!
Rank: Driver's Permit
 1 user liked this post.
#13 Posted : Thursday, December 17, 2020 2:03:08 PM(UTC)
Same for me.
Rank: Driver's Permit
 1 user liked this post.
#14 Posted : Thursday, December 17, 2020 5:18:49 PM(UTC)
Same for me on PC. I even tried waiting a lot in case it should still load but nothing happened. I couldn’t even get to the menu so I had to alt+f4 my way out of there. If any of you find a solution for this, let us know!
Rank: Driver's Permit
 3 users liked this post.
#15 Posted : Thursday, December 17, 2020 9:49:03 PM(UTC)
Seriously, on one hand, the game is great, on the other hand, If I can I refund immediently. Since my 20 years of gaming I never had so much issues with a single game. Usually one or two fixes or workarouds if anything was wrong and the game was runnin. Forza? You fix (actually most of the time you cant fix, you have to wait when they fix it) something to find out another error or glitch next week. This is madness. And worst you actually can consider yourself happy if you havent ever activation hang error, that stops me for being even play the game for 3 months (some people can not play it for a year). So you can be happy to even be able to play this buggy game. I think it shoudl be nominated as much bugged game ever.
Rank: D-Class Racing License
 2 users liked this post.
#16 Posted : Friday, December 18, 2020 12:32:45 AM(UTC)
I'm actually sure I've done this before, but that aside, still crashes at the first stage but I could select all the other stages and complete them. Just not the first :-/

Edited by user Saturday, December 19, 2020 4:09:45 PM(UTC)  | Reason: Not specified

Rank: Driver's Permit
 2 users liked this post.
#17 Posted : Friday, December 18, 2020 9:19:09 PM(UTC)
Originally Posted by: grapino1791 Go to Quoted Post
Hi guys. I'm really struggling with this but as soon as I get to the location for the top gear race the game loads the mission and then puts me into the car etc however the car just stops and the game gets stuck in a loading screen. Would appreciate it if anyone can help me fix.


same prob here!
playing on Xbox One S with game pass ultimate
:(
Rank: Driver's Permit
 2 users liked this post.
#18 Posted : Saturday, December 19, 2020 6:57:11 AM(UTC)
I have the same issue with Top Gear story. Does not load and to continue play the game I need to restart the game
Rank: Driver's Permit
 2 users liked this post.
#19 Posted : Saturday, December 19, 2020 9:01:10 AM(UTC)
Same here, Xbox one series x.
Rank: Driver's Permit
 2 users liked this post.
#20 Posted : Sunday, December 20, 2020 4:45:39 AM(UTC)
Same for me Xbox one S
Rank: Driver's Permit
 2 users liked this post.
#21 Posted : Sunday, December 20, 2020 6:13:11 AM(UTC)
Same problem here on Series X.

Does nobody found a fix so far? :(
Rank: Driver's Permit
 2 users liked this post.
#22 Posted : Sunday, December 20, 2020 6:13:22 AM(UTC)
Same problem here on Series X.

Does nobody found a fix so far? :(
Rank: Driver's Permit
#23 Posted : Sunday, December 20, 2020 12:03:37 PM(UTC)
Having the same issue, it stops at start on first mission with endless loading and using 99% of my GTX970 graphic card.

Edited by user Sunday, December 20, 2020 12:04:55 PM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#24 Posted : Sunday, December 20, 2020 12:24:09 PM(UTC)
Same for me, however after this crash, my GPU is stuck at 99% and I get 20-28 FPS on low with GTX 1050.

Before I started the top gear mission, I was running 40 FPS on high, all smooth, 38% GPU usage.

I have taken the following steps, alas to no avail:

1. Update drivers(When has this ever worked for someone lol)
2. Set GPU as standard in Nvidia Control Panel
3. Optimize Horizon 4 in Geforce Experience
4. Restart PC
5. Force usage of GPU by using external monitor through HDMI(port is linked to GPU)
6. Shove my foot through my keyboard


Task manager only states 3% GPU usage when playing and laptop does not seem to spin fans very hard. And believe me, when my GPU is at 99% normally it sounds like Alonso's V10 Renault(see Hamilton's reaction to my GPU here:Hamilton blown away by Alonso's V10.
Rank: Driver's Permit
#25 Posted : Monday, December 21, 2020 7:36:34 AM(UTC)
I’m having the same issues on Xbox one. I just completed these missions not too long ago, like a couple weeks ago. Now I’m trying to 3 star everything and I can’t even run the first mission. Something with the new update. Hopefully they figure it out sooner or later.
4 Pages123>>Next

Notification

Icon
Error