Rank: Driver's Permit
#1 Posted : Friday, November 20, 2020 3:25:56 PM(UTC)
So, I was playing team adventure earlier & several of the cars were jumping about - flashing backwards & forwards, may be a better way of putting it ??
What's that all about then ? It is because the players have a bad connection ? It's seriously off putting !
I had to laugh at the end of the race though - One of the other team was trying to force me into the wall heading towards the finish, but their car ghosted. They went right through my car & it shot off into the wall, instead of crossing the finish line !!
Rank: Driver's Permit
#2 Posted : Tuesday, November 24, 2020 7:25:22 AM(UTC)
For me that usually means that my internet connection is not working well and often I get disconnected from the server and kicked back to Solo mode. Internet service in my area is consistently not that good.
Rank: Racing Permit
#3 Posted : Wednesday, November 25, 2020 8:47:45 AM(UTC)
I agree that it may be an connection thing, but does seem to be happening more often (I'm running a series X now and I think it brought a lot of issues as well). I just finished a race last night where I was in 3rd a second or two behind 2nd. When I got to the line, his car was just sitting there and I finished second.
Rank: B-Class Racing License
#4 Posted : Wednesday, December 2, 2020 2:30:33 PM(UTC)
This is happening and more since the series x update, it has completely broken the game.
Can’t upload tunes or designs as of today, and this has been like it all day.
I’m getting kicked from the trial over and over.
There is literally no point playing it now since the game is so broken,
I hate to think what it’s going to be like with everyone wanting to play online tomorrow, with it being the new season and all

Notification

Icon
Error