2 Pages12Prev
Rank: B-Class Racing License
#26 Posted : Thursday, November 19, 2020 7:25:49 PM(UTC)
Found a bug with the tune import. If you check for tunes you have saved in previous titles, it just shows a duplicate of tunes you have saved in Horizon 4. I plan to open a ticket tomorrow.
Rank: Racing Permit
#27 Posted : Friday, November 20, 2020 8:06:51 AM(UTC)
Season shows 89% completion and there are only 5 daily left, so it should be 95%.
Probably because of the missing Rivals event....
Rank: Driver's License
#28 Posted : Friday, November 20, 2020 10:03:30 PM(UTC)
Originally Posted by: Baz828 Go to Quoted Post
Handling alot of the Cars handling has changed, alot of my Cars that i use for online racing, Forzathon and just driving around the map that used to handle really well, have next to no grip at all now.


YES!! I fully agree with this. I thought that I must have got really bad at online Cross Country racing because the vehicles I have used for 12 months have very different (worse) handling now. Strange!!
Rank: D-Class Racing License
#29 Posted : Thursday, November 26, 2020 11:46:06 AM(UTC)
Once again an update has screwed up everyone of my tunes but as I did last time to sort out the mess I reinstalled the game and hoped that I would get the same positive result but hey I dunno if it's because i'm now on the xbox series x but no all my tunes are still screwed. Tunes that reached 250mph easy struggle to exceed 200mph my off roaders now stall on the slightest of slopes between this and last week being unable to get onto forza online and so losing out on the rewards I truly think i've just about had enough. With every car so underpowered I couldn't retune them if I tried which makes the point of the game namely competing and being competitive moot so it took the so called ''amazing'' XBox Series X to do it but I seriously have just about had enough. Unless somebody out there has a fix for said screw up then i'll just have to be happy with the £2-300 profit I'll make reselling my ''amazing'' new console to someone else to pass on for xmas. I truly hope there is a fix out there as i've played Forza for over ten years and love the game but it won't be the end of the world if there is no help or a fix as it will be just one less stress in my life.

Edited by user Friday, November 27, 2020 9:52:43 AM(UTC)  | Reason: Not specified

Rank: B-Class Racing License
#30 Posted : Tuesday, December 1, 2020 1:25:18 AM(UTC)
I am having similar issues, the game hangs and freezes when trying to go into my designs or vinyls.
I am maxed on designs and vinyls so I always get some degree of hanging and I will sometimes get disconnected from Horizon Life, this is happening all the time now, it freezes for about 2-3mins then I get disconnected then the designs or vinyls load.
I am using an Xbox one X and no other games are an issue.

I am also getting disconnected from the trial as well, I have done the trial multiple times last week and this, since I really enjoyed them, and I will get disconnected not all the time but say one in every five games.
I am hard lined with all ports forwarded, I have fibre optic broadband and my speeds, upload and download are just fine. Again all other games work perfectly.

This has all started since the Xbox Series X update. I really hope it gets fixed soon.
Rank: Driver's License
#31 Posted : Wednesday, December 2, 2020 8:14:44 AM(UTC)
[quote=DarthBra;1178772]I am having similar issues, the game hangs and freezes when trying to go into my designs or vinyls.
I am maxed on designs and vinyls so I always get some degree of hanging and I will sometimes get disconnected from Horizon Life, this is happening all the time now, it freezes for about 2-3mins then I get disconnected then the designs or vinyls load.
I am using an Xbox one X and no other games are an issue.

I am on a Windows PC. As of yesterday afternoon I get disconnected from the H4 servers when entering My Designs. Game immediately finds H4 servers, but fails to reconnect. Returning to Free Roam immediately reconnects and all other Features that require the servers work fine. Also posted issue in Paint Booth Forum just now. Have yet to submit a ticket, as lately I have not been getting responses. but usually my issues do get corrected before or @ next update.

Edited by user Wednesday, December 2, 2020 8:56:46 AM(UTC)  | Reason: Not specified

2 Pages12Prev

Notification

Icon
Error