Rank: Driver's Permit
#1 Posted : Wednesday, July 29, 2020 1:09:57 AM(UTC)
Hi,

OS: Windows 10 Home 64bit - Version 2004 - Build 19041.421

I installed FM7 on my PC and now can't play online as I get the below error when trying to join any lobbies
Error: Failed to acquire server data

I have tried:
I have re-installed the game = no difference
Allowed in Windows 10 firewall = no difference
I turn off the Windows 10 Firewall = no difference
I opened ports on router = no difference
I put PC in DMZ on router = no differnce
Tried altogether = no difference

This use to work.

Thanks,
Gaz

Edited by user Wednesday, July 29, 2020 1:27:29 AM(UTC)  | Reason: Not specified

Regards,
Garry
Rank: Driver's Permit
#2 Posted : Wednesday, July 29, 2020 3:12:44 AM(UTC)
I have just tried without the router and it was the same.
Now it is working and I am not sure how or why, but both PC now have open nat and connected.
Regards,
Garry
Rank: D-Class Racing License
#3 Posted : Friday, July 31, 2020 11:58:34 AM(UTC)
Same issue here tonight. Very frustrating as nothing fixed it.
Rank: Racing Permit
#4 Posted : Sunday, August 2, 2020 10:37:40 AM(UTC)
I've been getting this a lot recently, as well as pretty reliably dropping out of every online race I start after about 2 laps- super frustrating.

Never had any issues like this before on my PC, and nothing in my network set up has changed, can only assume that something has changed on the Forza/Microsoft side of things, especially if other players are having the same issue.

For fiddles sake T10/Forza, please fix this! Especially if we've got a super long wait until the next Forza comes out!

Notification

Icon
Error