This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
Rank: Driver's Permit
 1 user liked this post.
#1 Posted : Thursday, March 12, 2020 4:29:04 PM(UTC)
I've been playing Horizon 4 with no issues since it came out. Starting a few weeks ago I've had connectivity issues trying to join online sessions. Nothing has changed hardware wise for me so assuming something either changed in the game or with xbox live services. I've tried all the troubleshooting guides and nothing works. Until today I could usually fix it by disabling and then re-enabling my network adapter then clicking "Check Again" the server connectivity would show connected. But now it has stayed "Blocked" all day no matter what. Even when I was able to get the server connectivity working it always still showed that "Teredo is unable to qualify". Since I was able to play the game with no issues I assumed I don't need it. However now that I can't get server connectivity anymore I started looking at Teredo again. Tried following the troubleshooting steps but in device manager even with "show hidden" enabled I do not see anything with the name "Teredo". Not sure if it's needed or not. Xbox support mentioned forwarding ports on my router but that's seems absurd as it's been running fine for so long without it. Again unless something has changed with xbox services to require it. So made my PC have a static IP and added the 8 recommended port forwards from Xbox support. Rebooted router and PC and still blocked. I also turned on IPv6 in my router which was not enabled before today. Not sure what else to do at this point. I really enjoy FH4 and prety much only game I play but if I can't do the Forzathon Live's etc. what's the point.
Rank: Driver's Permit
#2 Posted : Thursday, March 12, 2020 7:12:18 PM(UTC)
So after I added the port forwarding I rebooted the router. Then I rebooted my PC. After restarting it still said "Blocked". Was about to post on FB group but wanted to try another online game to make sure it worked. I launched Steam and then played a minute of Shroud of the Avatar. Then I quit Steam. I clicked "Check Again" and all of a sudden NAT Type is "Open" and Server Connectivity is "Connected". So either there was some lag after reboot for the port forwarding changes to take effect or launching and quitting Steam did something. Hmmm.
Rank: Driver's Permit
#3 Posted : Friday, March 13, 2020 4:29:38 AM(UTC)
And today after rebooting back to Blocked. Arrrgggg.
Rank: Driver's Permit
#4 Posted : Friday, March 13, 2020 9:00:55 AM(UTC)
Same here.
Most of the time I can’t connect to play online at all, Forzathon for me only lasts a round then I get disconnected - it happens more often than not.
Steam is perfectly normal for me, my computer is still the same, my internet is also perfectly normal. Only Horizon is the one having connection problems.
I’ve tried fixing teredo, changing router and still no better.
Rank: Driver's Permit
#5 Posted : Saturday, March 14, 2020 11:37:29 AM(UTC)
Hello!
Looks like the new windows 10 update was breaking a few things.

I've managed to fix it with a friend by doing the following steps. These steps are not related and I would suggest to check teredo's settings each time you try to apply the setting and a good restart.

Possible solutions that I followed.

1. CMD with Admin Rights: netsh interface teredo set state type=enterpriseclient
2. CMD with Admin Rights:
netsh
int teredo
set state disabled
int ipv6
set teredo client
exit

3. Go to regedit:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters
Set the DisabledComponents Value data to 0 (Zero) and select OK.
Close Registry Editor.
Restart your computer.
- (Windows should reinstall Teredo Tunneling adapter automatically.)

4. Powershell:
Reset-NetTeredoConfiguration
Set-NetTeredoConfiguration -Type Enterpriseclient

Here is where you can check if it was really working.

https://imgur.com/EkdTsUq

After trying the 1st and 2nd solution without luck, I managed to fix it by applying the 3rd one.
Rank: Driver's Permit
#6 Posted : Thursday, April 9, 2020 3:01:42 PM(UTC)
hey guys, i have literally tried every single online fix for this and nothing seems to work!

i cannot go online in Horizon 4. I am very upset and frustrated. All my Steam games and other games work perfect...this is clearly a Microsoft/Xbox problem exclusively!

is there any fix for this that is not online? because i have tried everything thus far with no luck.

do i just abandon my Forza games entirely now? hope they come to Steam at some point??

HELP! *FACE_CRY*
Rank: Forza Staff
#7 Posted : Friday, April 10, 2020 9:23:48 AM(UTC)
Have you followed these steps?

https://support.forzamot...nection-Troubleshooting

and this one?

Remember to restart PC after following these steps (not power down, but restart)

https://beta.support.xbo.../troubleshoot-party-chat
Rank: Driver's License
#8 Posted : Friday, April 10, 2020 9:37:22 AM(UTC)
I have had more problems with this than I can count. The best option that has worked for me is literally reinstalling the Teredo service from command prompt, there should be a script that you can find somewhere and copy and just type in yes after the prompt to reinstall it comes up. Restart your computer and also your router after that, try that a few times, after each restart open Xbox networking in settings and also the Xbox console companion and go to your network settings on there. If all else fails go into your router settings via the admin settings page. Look for IPV6 Firewall connectivity, either turn your security level off or to a lower setting, or look for a specific option for Xbox services to make sure it's allowed. I can't say if you have that or not, each router is different. I have spoken to Microsoft techs, internet techs, and the Xbox techs really with no clear answer for a proper fix. The problem lies with Microsoft itself not Xbox apparently, randomly after an update the Teredo is unable to qualify and is essentially blocking IPV6 Firewall connectivity. The only other solution is to roll back some windows updates (if Teredo was working prior to a update) or possibly just doing a system reformat.

Anyway I hope that helps! Trust me, I also get super frustrated when that happens, but Microsoft refuses to address it properly.
Rank: Driver's Permit
#9 Posted : Friday, April 10, 2020 11:19:50 AM(UTC)
I have tried everything...even the tips in this post.

Honestly, this is criminal. We have paid 100 dollars for this game only for it to break with no hope of getting it fixed, microsofts lazy asses are leaving us out to hang.

I will never purchase another microsoft product again. This is absolutely horrendous.

either the forza games come to steam or from here on out i am done with the forza series.
Rank: Driver's Permit
#10 Posted : Friday, April 10, 2020 4:10:47 PM(UTC)
https://youtu.be/aFSkwCn1PqY I'll save you the headache. This worked for me. But now I have another problem! :D
Rank: Driver's Permit
#11 Posted : Saturday, April 11, 2020 12:30:39 AM(UTC)
https://www.reddit.com/r...ing_adapter_missing_in/

Hi, For me this solution have fixed all problems with teredo permanently.
Since this fix, i Always Have : ( run the command prompt as an Admin and run "netsh int teredo show state")

Type : enterpriseclient (Group Policy)
Server Name : win1901.ipv6.microsoft.com.
Client Refresh Interval : 2 secondes (Group Policy)
Client Port  : 3544 (Group Policy)
State  : qualified
Client Type : teredo host-specific relay
Network : managed
NAT : cone
NAT Special Behaviour : UPNP: Non, PortPreserving: Oui
Local Mapping : **.**.**.**:3544
External NAT Mapping : **.**.**.**:3544

I have masqued My's IPs for security.

:) :) :)

Notification

Icon
Error