This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
Rank: Driver's Permit
#1 Posted : Sunday, August 11, 2019 5:23:48 AM(UTC)
I just bought Forza Horizon 4 but when I go to launch it, it says that I need to update my Graphics Drivers. I checked my graphics drivers, and they do nit need updating, my Nvidia one or my Intel one.
However, if I press the ignore and continue button then the game just closes just after the speedometer opening scene.
Any help would be greatly appreciated,
Thanks, Jenson.
Rank: Driver's Permit
#2 Posted : Monday, August 12, 2019 10:06:10 AM(UTC)
If you have 2 gpu drivers installed (integrated intel and dedicated nvidia), make sure the game uses the nvidia driver to run. Because if your system is running the game on integrated intel gpu then it will obviously crash. Also just in case check if a newer driver has arrived for ur nvidia gpu.
Rank: D-Class Racing License
#3 Posted : Tuesday, August 13, 2019 4:19:47 AM(UTC)
If your on a laptop check that your not in battery saver mode, Battery saver mode will turn off your graphics card to reduce power.
I did the same thing but it ran OK on just UHD graphics, didnt crash, just dropped frames but was still stable.

Post back what it was and if you fixed it.

Moderated since 24-06-19 How much longer?
Rank: Driver's Permit
#4 Posted : Tuesday, August 13, 2019 7:02:17 PM(UTC)
Just a couple quick question to OP since he didn’t clarify. Are you using a laptop or desktop? Did you check for new drivers thru Nvidia’s website or your PC manufacturer’s support page?

If you are on a desktop, make sure you have your display cable plugged into your graphics card. (Not your motherboard!) I would also recommend going into your windows power settings via the control panel to set your power setting to “High performance.”


If you are on a laptop, open Nvidia Control Panel and make sure your Nvidia processor is the default option. If you use this laptop always plugged into its power brick I recommend going into your windows power settings via the control panel to set your power setting to “High performance.” If you use this laptop on the go, I would recommend just clicking the battery icon in the lower left corner and sliding the slider all the way to the right. Then when your using your laptop for other things you can quickly switch back to a lower power state for longer battery life.



Just a friendly driver helping out,
OpenedPainter10


Just a friendly driver helping out,

OpenedPainter10

(Playing Forza since the original Xbox!)
Rank: Driver's Permit
#5 Posted : Wednesday, August 14, 2019 1:19:18 PM(UTC)
I am using a laptop and is Allways in high power mode.

It gave me a number that I needed to be updated to. I googled it and the Nvidia website came up with a downloader. I installed it but couldn’t install it because there was another windows update going on.

How do I make sure that the Nvidia graphics card is dedicated to the game?
Thanks for all the help so far!
Rank: Driver's Permit
#6 Posted : Wednesday, August 14, 2019 8:06:29 PM(UTC)
Thanks for the info!

Just out of curiosity, what type of Nvidia card do you have? I usually recommend installing drivers via Nvidia’s Driver Downlod selector here: https://www.nvidia.com/Download/index.aspx?lang=en-us If you can’t figure out what type of card you have, there is an automatic tool from Nvidia here: https://www.geforce.com/drivers

This video shows how to make your Nvidia GPU your default GPU.
https://youtu.be/Y7DrQmDXHuY


OpenedPainter10
Just a friendly driver helping out,

OpenedPainter10

(Playing Forza since the original Xbox!)
Rank: Driver's Permit
#7 Posted : Thursday, August 15, 2019 9:31:44 AM(UTC)
I think I gave the 860M - I will have to check!

Thanks for the video,
Rank: Driver's Permit
#8 Posted : Thursday, August 15, 2019 1:26:12 PM(UTC)
I am on holiday at the moment - I will only be able to take action when I’m home but thanks for all the suggestions!

Notification

Icon
Error