This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
Rank: Driver's Permit
#1 Posted : Saturday, August 10, 2019 4:29:52 AM(UTC)
I recently upgraded my standard edition to ultimate and have noticed a significant difference to the initial load time.
With the standard edition, I could continue to load the game in seconds, but with the ultimate edition I'm left looking at a rotating Senna for over a minute...
I've attempted a reinstall and the behaviour is exactly the same.
Is this a known issue for PC installs?

Edited by user Saturday, August 10, 2019 8:06:13 AM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#2 Posted : Tuesday, August 13, 2019 12:40:08 AM(UTC)
Yeah, i have same problem for month or longer. Still no fix.
Rank: R-Class Racing License
 1 user liked this post.
#3 Posted : Tuesday, August 13, 2019 5:20:12 AM(UTC)
Probably taking longer to load since there's more DLC it has to verify that you own. If it's doing it through the Microsoft store, it'd explain a lot


Vice president, moderated club.
Rank: Driver's Permit
#4 Posted : Wednesday, August 14, 2019 3:15:52 AM(UTC)
Thanks for the replies.

DLC verification does sound like a possible cause...

Hopefully it'll get some attention soon.
Rank: Racing Permit
#5 Posted : Wednesday, August 14, 2019 3:49:49 AM(UTC)
Try to deinstall the car pass. This helped a friend of mine that had this issue. And he was able to still use all the cars.

Notification

Icon
Error