This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
Rank: C-Class Racing License
 1 user liked this post.
#1 Posted : Tuesday, July 9, 2019 11:38:00 AM(UTC)
Normally the "1" means a prize unlocked, so when you go to check it out, it automatically unlocks the reward. In my case nothing happens. I'm at 98% currently for this season, already unlocked the season's prizes, so what is the "1" in this case for then? The monthly prizes have not yet reached 50% so it's not that.

Is this a glitch?

Rank: Racing Permit
#2 Posted : Tuesday, July 9, 2019 12:28:52 PM(UTC)
glitch related to the outfit prize
Rank: R-Class Racing License
#3 Posted : Tuesday, July 9, 2019 6:33:14 PM(UTC)
As mentioned, it's related to the 50% suit reward. Seems to happen if you already had the suit, and with clothing items, they can't be claimed again, so there it sits.


Vice president, moderated club.
Rank: A-Class Racing License
#4 Posted : Wednesday, July 10, 2019 8:20:51 PM(UTC)
Whatever the glitch is, it's preventing any other rewards in the playlist from activating. Just completed the playlist 100% and didn't get the 5000 credits. The green 1 is still there. Whatever happened is blocking any further rewards by the looks of it. That's what I was afraid would happen when I first saw the glitch. The thing is, even when you have an item like the suit it should still go though the motions as if you won, you just don't get the suit. That's what made me think this would happen. Hope they patch it quick. I want the Impala and some of the other cars.

Notification

Icon
Error