This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
Rank: Driver's Permit
#1 Posted : Friday, April 12, 2019 6:41:51 PM(UTC)
What a disappointing experience. I used to play on XBox (had 360/OG1/1S/1X), but have since gotten out of console and play mostly on PC. Most of the stuff I play on PC is not related to XBL (Destiny 2, Division 2, F1 2018, etc.), but I've been eyeing a sale on FH4 since I haven't played it (sold my consoles before it came out), and was looking forward to playing it at high frame rates on my 1440p/144Hz monitor. So when I saw the current sale, I jumped on it and got the Ultimate Edition (I'm a long time series fan and customer, pre-ordered FM7 Ultimate for example).

The game will not start no matter what. I have tried all the fixes in all of the threads I could find (at least a few with [SOLVED] and/or [ANSWERED], at least 2 on here) to no avail. A lot of people mention MSI Afterburner, I don't use this. I've tried closing all other programs including some system services, re-installing (what's 70 GB here, 70 GB there, bandwidth and time be damned), switching to the windows admin account, nothing works.

My setup is pretty standard:
Gigabyte Z370 Gaming 7
i7-8700K
32GB PC3200 RAM
1TB SSD
SAPPHIRE NITRO+ VEGA 64 8GB
Win 10 Pro 64 Bit with all updates as of today installed
AMD Adrenalin 2019 Edition 19.4.1 Driver (current stable as of today)

This PC is rock stable and plays Destiny 2 on Max settings at 2560x1440 averaging 100-144 fps the entire time.

FH4 makes it to the _windowed_ splash screen (not full screen) and then waits there, sometimes 10 seconds, sometimes for what feels like upwards of a minute (and sometimes it feels like >1m), then that window just goes away. Game never starts.

Any hope for me?

Edited by user Wednesday, April 17, 2019 8:12:05 AM(UTC)  | Reason: Not specified

Rank: Series Champion
 1 user liked this post.
#2 Posted : Saturday, April 13, 2019 2:48:12 AM(UTC)
Have you done the windows store cache reset?
Have you made sure you have full permissions for the folder the game is installed in. You might be able to install but still not have the required permissions to run it. It's a weird bug but it's part of the way windows allocates file and folder permissions and sometimes it screws up spectacularly!

Edited by user Saturday, April 13, 2019 4:24:56 AM(UTC)  | Reason: Not specified

Rank: Driver's Permit
 1 user liked this post.
#3 Posted : Saturday, April 13, 2019 3:23:26 PM(UTC)
Yes, I've tried doing the extreme
Quote:
[in cmd.exe]
cd /
takeown /D Y /SKIPSL /R /F .
icacls "c:\Windows" /c /t /grant "ALL APPLICATION PACKAGES":F
icacls "c:\Program Files\WindowsApps" /c /t /grant "ALL APPLICATION PACKAGES":F

[in PowerShell]
Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}


I also tried wsreset.exe. Nothing has worked.

<rant>
It's unbelievable how poorly managed the installs are, I've seen stuff that's nowhere near what a company like Microsoft, who's been writing Operating Systems professionally for decades, should be doing: halfway aborted installs, computer will go to sleep while there's an install download in progress then pretend it's fully installed (it's not, only 40% has been downloaded), I try "uninstall" and it says it did it but all the files are still there, after a reboot the entry shows again but it says it's only 8kB or 16kB, trying to reinstall it gets stuck perpetually on "Acquiring license"... it's a nightmare and it's shameful. None of this should be happening, including the messed up permissions. Instead of using the Windows platform to their advantage to get a leg up on the competition (Sony doesn't have an OS), they've completely crapped on the PC side of Play Anywhere. It's a shame this game is exclusive to XBox (I would add slash (/) PC, but it doesn't work on PC).
</rant>
Rank: A-Class Racing License
#4 Posted : Saturday, April 13, 2019 4:21:13 PM(UTC)
It works fine on PC (most of the time). I had the same problem you're describing with H3 at first. It was fixed. One thing you can try is going into the windows settings, find the H4 app then reset it. that works for some people. Other than that if you want help you need to go to the official support page (there's a pin post about how to submit a problem and where to go in these forums).
Rank: Series Champion
 1 user liked this post.
#5 Posted : Monday, April 15, 2019 5:48:13 AM(UTC)
Yeah the installs are poor. I told them during the test phase of windows 10 this was a problem and i and others were ignored. It's because they had a system in place which was overseen by MS Office staff, and was only for that. When games were thrown in, it didn't work but they already had a sizeable investment in it so carried on regardless. Now WE have to deal with all the problems that causes!
Rank: Driver's Permit
#6 Posted : Monday, April 15, 2019 3:30:33 PM(UTC)
None of the stuff I've read fixes this, I've reinstalled a total of 5 times now, resets, everything. Here's what I am seeing in the Event Viewer:
Quote:
Activation for Microsoft.SunriseBaseGame_8wekyb3d8bbwe!SunriseReleaseFinal failed. Error code: The app didn't start in the required time.. Activation phase: COM ActivateExtension

SunriseBaseGame is definitely FH4, Sunrise is its code name. I haven't been on Windows in a bit, anyone have a clue as to that the source for this "Activation" fail could be? The above is an error, before it is an informational message:
Quote:
Activation of app Microsoft.WindowsStore_8wekyb3d8bbwe!App attempted. Execution state: Attempted activation of the app, 0, The operation completed successfully..
Rank: Driver's Permit
#7 Posted : Monday, April 15, 2019 3:36:40 PM(UTC)
Originally Posted by: MasTRE007 Go to Quoted Post
FH4 makes it to the _windowed_ splash screen (not full screen) and then waits there, sometimes 10 seconds, sometimes for what feels like upwards of a minute (and sometimes it feels like >1m), then that window just goes away. Game never starts.


Do you use MacType? If so, disable it before starting the game. You can also update MacType and add ForzaHorizon.exe to mactype.ini file in the exclusions section.
Rank: Series Champion
#8 Posted : Monday, April 15, 2019 11:48:20 PM(UTC)
Where are you installing it?
Rank: S-Class Racing License
#9 Posted : Tuesday, April 16, 2019 10:05:03 AM(UTC)
Few things to try, did you check your Permissions? Not the game it is the way the windows store works and the problems it has.

https://www.maketecheasi...apps-folder-windows-10/

https://answers.microsof...-47d9-9f0f-2ae845ff3447

https://www.google.com/s...amp;biw=1920&bih=918

Edited by user Tuesday, April 16, 2019 10:05:45 AM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#10 Posted : Tuesday, April 16, 2019 5:05:46 PM(UTC)
Originally Posted by: MasTRE007 Go to Quoted Post

FH4 makes it to the _windowed_ splash screen (not full screen) and then waits there, sometimes 10 seconds, sometimes for what feels like upwards of a minute (and sometimes it feels like >1m), then that window just goes away. Game never starts.


Same exact problem for me. Installed in default location on SSD. I just uninstalled it until there's an update to this issue.
Rank: Driver's Permit
#11 Posted : Tuesday, April 16, 2019 8:01:15 PM(UTC)
Originally Posted by: WiniestDisc7277 Go to Quoted Post
Do you use MacType? If so, disable it before starting the game. You can also update MacType and add ForzaHorizon.exe to mactype.ini file in the exclusions section.

nope. but now I'm gonna look into it :) if I ever get FH4 working, first lol

Originally Posted by: BBTD MitchyK7 Go to Quoted Post
Where are you installing it?

c:, a 1TB SSD on which Win10 is installed.
Rank: Driver's Permit
 1 user liked this post.
#12 Posted : Tuesday, April 16, 2019 8:47:48 PM(UTC)
My dudes, I figured it out! This computer is a dual boot with another operating system which stores system time in UTC (Windows uses local time by default), and the system time when booting in Win10 was UTC instead of Pacific US. On a whim I decided to set the time automatically, and that fixed it! I'm religiously taking ownership of everything in c:\Program Files\WindowsApps\ now just for good measure, but I am finally able to play this game :)
Rank: Series Champion
#13 Posted : Wednesday, April 17, 2019 3:55:43 AM(UTC)
Good to know and good that you came back to tell people how you fixed your problem. Usually people fix it and never come back!
Taking ownership of files is one of the most important things you can do if windows store is playing up.
Rank: B-Class Racing License
#14 Posted : Wednesday, April 17, 2019 5:32:38 AM(UTC)
Originally Posted by: WiniestDisc7277 Go to Quoted Post
Originally Posted by: MasTRE007 Go to Quoted Post
FH4 makes it to the _windowed_ splash screen (not full screen) and then waits there, sometimes 10 seconds, sometimes for what feels like upwards of a minute (and sometimes it feels like >1m), then that window just goes away. Game never starts.


Do you use MacType? If so, disable it before starting the game. You can also update MacType and add ForzaHorizon.exe to mactype.ini file in the exclusions section.


I use MacType and have had to disable it to get the game to run. Could you possibly tell me in layman's terms how to exclude FH4?

I looked in mactype.ini, there is no exclusions section so I added this:

[ExcludeSub] (I also tried [Exclusions] and [Exclude] )
ForzaHorizon4.exe

I restarted MacType but the game still won't run (unless I disable MacType fully). It would be nice to get the exclusion working if possible.

edit - I also added it to every applicable section I could think of, in the default,ini file which already included exclude sections with other EXEs listed. That didn't work either.

Edited by user Wednesday, April 17, 2019 5:48:01 AM(UTC)  | Reason: Not specified

Rank: Series Champion
#15 Posted : Wednesday, April 17, 2019 5:47:13 AM(UTC)
This any use to you FullNietzsche?

https://github.com/snowie2000/mactype/issues/209
Rank: B-Class Racing License
#16 Posted : Wednesday, April 17, 2019 5:50:13 AM(UTC)
Originally Posted by: BBTD MitchyK7 Go to Quoted Post
This any use to you FullNietzsche?

https://github.com/snowie2000/mactype/issues/209


I found that before actually when I googled, it only tells us that the exclude function wasn't working in 2016 and apparently still isn't in 2019 (I'm using the latest version).

But the above poster says it works, so I'd be interested to get the exact instructions.

(MacType is great but it could be massively improved in terms of user-friendliness, it's incredibly convoluted and complex to use for such a simple little program. Well I mean, it works easily enough out of the box but if you need to change anything, then it gets silly.)

Edited by user Wednesday, April 17, 2019 5:50:45 AM(UTC)  | Reason: Not specified

Rank: Driver's License
 2 users liked this post.
#17 Posted : Wednesday, April 17, 2019 8:11:15 AM(UTC)
I'm glad to see the OP got their game working.
Rank: Driver's Permit
 1 user liked this post.
#18 Posted : Wednesday, April 17, 2019 8:26:22 AM(UTC)
Originally Posted by: BBTD MitchyK7 Go to Quoted Post
Good to know and good that you came back to tell people how you fixed your problem. Usually people fix it and never come back!

For sure, I came here for help and you guys really made me feel at home and welcomed, so def want to pay it forward!

Originally Posted by: BBTD MitchyK7 Go to Quoted Post
Taking ownership of files is one of the most important things you can do if windows store is playing up.

Good to know, I only really use Win for gaming, but games are likely some of the larger and more complex programs installed thru WS. That Take Ownership registry fix which adds it to the context menu (posted by leetorts -- thx!) is a godsend!

Thanks again to all who helped. I'm now rockin' FH4 in 2560x1440 on Ultra, holding at a steady 100+ fps! 😎

Notification

Icon
Error