This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
Rank: Driver's Permit
#1 Posted : Wednesday, November 14, 2018 11:19:49 AM(UTC)
Yush, tittle say all, my language is finnish/english but, Forza Hub windows 10 app launch at japan/china language. I try to find option in app to change that but, there is none setup/option for this & app unistall/reinstall not help at all. Any solution for this?
Rank: Driver's Permit
 1 user liked this post.
#2 Posted : Sunday, November 25, 2018 12:44:52 AM(UTC)
I had this for a long time and today i was finaly able to resolve this.

These are the Steps that helped in my case, maybe they will help in your case to:
- Open the Settings App in Wndows 10
- Click on "Time & Language"
- Click on "Region & language"
- Check the installed languages

In my case 3 Languages were installed. German, Japanese and English (in this Order!)
-> i guess "Forza Hub" is not localized for German, so it took the next Language which was Japanese.
-> by changing the Order and putting English as the second Language, Forza Hub now uses English.

(I installed the Japanese Language Pack because I learn Japanese and mainly use the Input Method from time to time ... but I'm still a beginner)
Rank: Driver's Permit
#3 Posted : Thursday, December 27, 2018 9:09:10 AM(UTC)
Originally Posted by: ryokucha JP Go to Quoted Post
I had this for a long time and today i was finaly able to resolve this.

These are the Steps that helped in my case, maybe they will help in your case to:
- Open the Settings App in Wndows 10
- Click on "Time & Language"
- Click on "Region & language"
- Check the installed languages

In my case 3 Languages were installed. German, Japanese and English (in this Order!)
-> i guess "Forza Hub" is not localized for German, so it took the next Language which was Japanese.
-> by changing the Order and putting English as the second Language, Forza Hub now uses English.

(I installed the Japanese Language Pack because I learn Japanese and mainly use the Input Method from time to time ... but I'm still a beginner)


-This way, this sound this usual fix the problem but, sadly i still have same problem after this change. It's not fix my problem. x3

Notification

Icon
Error