This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
Rank: Driver's License
#1 Posted : Thursday, October 11, 2018 12:14:47 AM(UTC)
I just applied a 30mb update for the 86' Merkur - the updated file had a strange name which contained numbers and letters and also an underscore, not sure. When I went into the "manage game" settings, under the 'updates' tab, it said there was an update for this car, so I clicked 'update all'.

Sorry, I'm a little new to Xbox, so apologies if this is a noob question or has already been covered in another thread. Thanks for insights.
Rank: Racing Permit
#2 Posted : Thursday, October 11, 2018 10:37:37 AM(UTC)
My guess is that it's a sound patch so the car sounds more like a V8 rather than a 4 cylinder. There were a few posts pointing it out, maybe they listened and patched it.
Rank: Driver's License
 1 user liked this post.
#3 Posted : Thursday, October 11, 2018 11:48:53 PM(UTC)
Originally Posted by: lanciastratos73 Go to Quoted Post
My guess is that it's a sound patch so the car sounds more like a V8 rather than a 4 cylinder. There were a few posts pointing it out, maybe they listened and patched it.


Wouldn't make sense to patch one car sound and forget about the rest of the cars that need a sound fix. If Turn 10 does finally decide to fix the all the wrong engine sounds, they'll do it in one major update.
Rank: X-Class Racing License
#4 Posted : Friday, October 12, 2018 7:30:41 AM(UTC)
Originally Posted by: MetalCurve22 Go to Quoted Post
Originally Posted by: lanciastratos73 Go to Quoted Post
My guess is that it's a sound patch so the car sounds more like a V8 rather than a 4 cylinder. There were a few posts pointing it out, maybe they listened and patched it.


Wouldn't make sense to patch one car sound and forget about the rest of the cars that need a sound fix. If Turn 10 does finally decide to fix the all the wrong engine sounds, they'll do it in one major update.


It's not the first time they have fixed some cars and not others in regards to sound.
Rules of troubleshooting:
1) Have you tried turning it off and on again?
2) Is your Internet working?
3) https://support.xbox.com/en-US/xbox-live-status < Check here for service issues.
4) If all else fails open a service ticket and/or forum post.

Rank: B-Class Racing License
#5 Posted : Friday, October 12, 2018 1:37:54 PM(UTC)
It still sounds the same to me, so idk what that random patch you got did. I didn't receive an update on my end.
Rank: Driver's License
#6 Posted : Monday, October 22, 2018 7:27:02 AM(UTC)
Well, how strange. Maybe it needed to download the file from the store and install it or something? I don't believe it has impacted the game in any way.
Rank: C-Class Racing License
#7 Posted : Monday, October 22, 2018 11:57:53 AM(UTC)
Haven't checked it out yet, but maybe the patch went the other direction - replaced the engine model in Forzavista to match the sound

Notification

Icon
Error