This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
Rank: Driver's Permit
#1 Posted : Monday, October 1, 2018 5:55:01 AM(UTC)
Hi all,

I have been playing around with the demo to see how things run before buying the game. It's not gone well.

System -
i7 - 4790K @stock speeds
32GB RAM
GTX 1060 6GB
SSD main drive

All system software is up to date, have just reimaged Windows 10. All drivers updated, BIOS/ GPU drivers etc.
I also rolled back the GPU drivers to double check (4 total) with no real change in performance.

System Preset - Very Low
CPU Simulation - MIN 62.5 MAX 136
CPU Render - MIN 32.3 MAX 51.1
GPU - MIN 30.1 MAX 48.9

System Preset - Ultra/extreme
CPU Simulation - MIN 39.9 MAX 114.1
CPU Render - MIN 24.7 MAX 41.1
GPU - MIN 17.1 MAX 30.7

Seems like something isn't right, should be a much larger gap between the highest and lowest setting scores. Either are unplayable really.

My flatmate has an older system AMD 8320, 8GB Ram, R9 270X 2GB . He is able to play comfortably at medium settings, very low settings he gets well above 60FPS.

Any ideas? I have seen reviews on Youtube with people getting 100+FPS with my GPU, don't understand how im getting 1/3 of that...

Cheers,
Kenny
Rank: Driver's License
#2 Posted : Monday, October 1, 2018 6:11:59 AM(UTC)
LOL it's defintely something wrong with...your PC or settings :) i have i5 with 1060 6gb and it runs smooth 60fps on Extreme setting with V-sync ON :) The optimisation and performace on 1060 is very good so its something wrong with your PC maybe. Try if you have enabled 60fps mode etc.
i5 7600k 16GB RAM gtx 1060 6GB Aorus 24" FHD Acer
Rank: Driver's Permit
#3 Posted : Monday, October 1, 2018 6:33:54 AM(UTC)
Originally Posted by: LazyTeddy25 Go to Quoted Post
LOL it's defintely something wrong with...your PC or settings :) i have i5 with 1060 6gb and it runs smooth 60fps on Extreme setting with V-sync ON :) The optimisation and performace on 1060 is very good so its something wrong with your PC maybe. Try if you have enabled 60fps mode etc.


Yeah it doesn't seem right to me anyway.

I have tried running with VSync on/off and also every step up to 144fps cap. (144hz Monitor), no difference.
Rank: Driver's Permit
#4 Posted : Monday, October 1, 2018 6:44:35 AM(UTC)
Please check this settings https://i.gyazo.com/04b4...5f3204ff89634f553ad.png
Game run fine here. Ultra/Extreme settings at 1920x1080 70 fps stable.

My system spec
ASUS ROG Strix Z270F
Intel 7700k 4.2Ghz
Palit 1060 6gb
Corsair Vengeance 32gb ram ddr4 3200MHz xmp profile 2.0
SSD 960 EVO NVMe M.2 250GB

Edit: Before i changed the settings. My GPU was using Power Saving on FH4.

Edited by user Monday, October 1, 2018 6:47:16 AM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#5 Posted : Monday, October 1, 2018 7:10:56 AM(UTC)
Originally Posted by: SolesBBoy Go to Quoted Post
Please check this settings https://i.gyazo.com/04b4...5f3204ff89634f553ad.png
Game run fine here. Ultra/Extreme settings at 1920x1080 70 fps stable.

My system spec
ASUS ROG Strix Z270F
Intel 7700k 4.2Ghz
Palit 1060 6gb
Corsair Vengeance 32gb ram ddr4 3200MHz xmp profile 2.0
SSD 960 EVO NVMe M.2 250GB

Edit: Before i changed the settings. My GPU was using Power Saving on FH4.


Thanks, I checked and have no apps listed in this section. I even added forza, changed the setting and ran the game. Same results unfortunately.



Rank: A-Class Racing License
#6 Posted : Monday, October 1, 2018 7:22:12 AM(UTC)
Have you checked your task manager to see if any other program is using the CPU at the same time?

Windows 10 has an unfortunate habit of doing CPU intensive things when it feels like it.
Rank: Driver's Permit
#7 Posted : Monday, October 1, 2018 7:23:46 AM(UTC)
Originally Posted by: FullNietzsche Go to Quoted Post
Have you checked your task manager to see if any other program is using the CPU at the same time?

Windows 10 has an unfortunate habit of doing CPU intensive things when it feels like it.


I did check this, had it open whilst benchmarking, CPU didnt go much over 60% at any time. cheers!

Notification

Icon
Error