This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
5 Pages123>>Next
Rank: Driver's Permit
 5 users liked this post.
#1 Posted : Friday, September 28, 2018 12:28:50 AM(UTC)
I've been trying to connect to Horizon Life for some while. But my friends were able to join each other instantly. Is anyone else having these issues?

Edit: I am wondering if it could be my NAT type. I had a similar issue when playing the CoD: Blackout beta. My NAT was strict.

Edit: i was finally able to connect to online servers. What I did was open the Xbox App, Go to setting on the toolbar to the left, Go to network and check if anywhere on the page it says Blocked.
Usually it will link you somewhere with more description on what your issue was. Some might have NAT issues like having a strict NAT and if that is the case I recommend Port forwarding. My issue was one of those Toredo issues. The support page listed the commands I needed to be able to be unblocked form Xbox live and its' services and other fixes for having blocked issues.
Hopefully some of you find the issue and resolve it (Time to resolve my other issue where I can't hear the game at all...I was given the double whammy when it came to issues). Also when I first connected to the online serves I was prompted those DNS errors but after the next try I was continuously able to connect
Good luck to the rest and hope to see you guys out there!

Edited by user Tuesday, October 2, 2018 8:12:53 PM(UTC)  | Reason: Not specified

Rank: Driver's License
 1 user liked this post.
#2 Posted : Friday, September 28, 2018 12:46:40 AM(UTC)
is there any error? as mine doe's the same thing loads and loads and loads then i get a dns error.
Rank: D-Class Racing License
#3 Posted : Friday, September 28, 2018 12:50:27 AM(UTC)
Originally Posted by: Chosen by Nova Go to Quoted Post
I've been trying to connect to Horizon Life for some while. But my friends were able to join each other instantly. Is anyone else having these issues?

Edit: I am wondering if it could be my NAT type. I had a similar issue when playing the CoD: Blackout beta. My NAT was strict.


Have you qualified and finished the prologue in each season?
Feel free to add me on Xbox Live. Gamertag: The Novacat

Rank: Driver's Permit
#4 Posted : Friday, September 28, 2018 1:07:34 AM(UTC)
Have not yet but I'd assume that wouldn't be an issue since my friends were only starting into the Autumn season. But hey, might as well give it a shot.
Rank: Driver's Permit
#5 Posted : Friday, September 28, 2018 9:22:55 AM(UTC)
Same here...
Rank: Driver's License
#6 Posted : Friday, September 28, 2018 1:32:21 PM(UTC)
I have same issue also and have completely finished prologue and am well into the game.
It's a common issue, a lot of reddit users have the same issue.

I haven't found anything online that speaks of a solution yet I hope someone important can see these complaints.
Rank: Driver's Permit
#7 Posted : Friday, September 28, 2018 1:59:47 PM(UTC)
Same issue happening here, playing from PC. I'm wondering if there's some sort of port forwarding I need to put in place, or firewall exceptions that need to be added.
Rank: Driver's Permit
#8 Posted : Friday, September 28, 2018 3:06:34 PM(UTC)
I'm on Xbox One X and also having difficulties. My NAT type is open, though.
Rank: Driver's Permit
#9 Posted : Friday, September 28, 2018 3:34:20 PM(UTC)
Can't connect to Online at all on PC, Finished the prologue but some online things should work anyway but there's no error showing up, any solution?
Rank: Driver's Permit
#10 Posted : Friday, September 28, 2018 4:48:54 PM(UTC)
I have the same Problem, it works for an Friend , and the xbox app is so slow and often down
Rank: Driver's Permit
#11 Posted : Friday, September 28, 2018 9:01:03 PM(UTC)
A Reinstall worked for me
Rank: Driver's Permit
 2 users liked this post.
#12 Posted : Friday, September 28, 2018 9:02:22 PM(UTC)
Likewise for me - unable to connect to Horizon Life. Completed prologue, playing on PC. The diagnostic shows attempts to ping a euro server, although I'm on the west coast of USA.
https://imgur.com/a/tHRBsxW
Rank: Racing Permit
#13 Posted : Friday, September 28, 2018 9:18:29 PM(UTC)
same level 40ish well though the campaign I can connect no issues on my 1X but my PC will not. Xbox W10 app says no issues with connection.
Rank: Racing Permit
#14 Posted : Friday, September 28, 2018 10:59:56 PM(UTC)
I don't get any diagnostic error message that comes up for me, but am also getting disconnected constantly. When I am able to connect, it's only for 2-3 minutes before I receive a disconnected from session message. Sometimes I can't even connection at all, it just sits on the spinning wheel saying connecting to session. Extremely frustrating since this is day two of me not being able to play online. It seems to work fine on Xbox one but why would I want to play on it when I can get 144hz on PC. I hope someone is actually monitoring these complaints and can help us. I have NAT and upnp enabled, and have gone through all the troubleshooting that supposedly worked on for a 7, including automatically starting peer to peer network services.
Rank: Driver's License
#15 Posted : Saturday, September 29, 2018 1:58:10 AM(UTC)
I am also unable to connect to horizon life. i have already completed the prologue. I am on a open nat and had no problems playing online in horizon 3 previously. i am in asia but strangely the error message showed it trying to connect to euro server. not sure how to fix this.
Rank: Driver's Permit
#16 Posted : Saturday, September 29, 2018 2:46:37 AM(UTC)
Can't connect to online either on PC, works with FH3, just not FH4, any Ideas anyone? can I get a refund?
Rank: Driver's Permit
#17 Posted : Saturday, September 29, 2018 7:21:26 AM(UTC)
I'm having the same issue, can't connect to live. I never get an error message though. I was thinking about reinstalling has anyone else had success with that? Also does anyone know if I reinstall do I lose my progress?
Rank: Driver's Permit
 1 user liked this post.
#18 Posted : Saturday, September 29, 2018 8:37:23 AM(UTC)
I have the same issue, no connetion to the FH4-Live-Servers possible. Just want to race with my buddie.
i have tried reinstall the game. Not fixing the problem.

I've opend an support ticket, will be back if i got an answer. Waiting for 22h now.
Rank: Driver's Permit
#19 Posted : Saturday, September 29, 2018 8:50:07 AM(UTC)
Originally Posted by: sylent96 Go to Quoted Post
I'm having the same issue, can't connect to live. I never get an error message though. I was thinking about reinstalling has anyone else had success with that? Also does anyone know if I reinstall do I lose my progress?


If everything works correctly you won't lose your progress, it is backed up by the game and it will download it when you open it again.
Rank: Driver's Permit
#20 Posted : Saturday, September 29, 2018 9:16:40 AM(UTC)
Same for me.
Rank: Driver's Permit
#21 Posted : Saturday, September 29, 2018 9:21:50 AM(UTC)
same here, on PC and cant connect to any session. HALP
Rank: Racing Permit
 3 users liked this post.
#22 Posted : Saturday, September 29, 2018 9:32:22 AM(UTC)
found this on another post. it worked for me and other peoples, try it out :)

1. Click Start , type services.msc in Start search box and hit Enter.
2. Right-click the Peer Networking Grouping service and select Properties .
3. Check if the service is started; if not, right-click and select Start .
4. You may also set the Startup type to Automatic under Properties .
5. Click OK .
and restart the computer.
if that dosent work. do this to.

. Run command Prompt as administrator
2. Type "netsh" and press enter
3. Type "int teredo" and press enter
4. Type "set state disabled" and press enter
5. Type "int ipv6" and press enter
6. Type "set teredo client" and press enter

i did both steps just to be sure before restarting my pc
it seems to be a teredo issue.

it still needs to be fully fixed by Devs

Advice do not spend long times looking thru Car sections or you might lose connection to server.

Enjoy
Rank: Driver's Permit
#23 Posted : Saturday, September 29, 2018 10:27:46 AM(UTC)
Originally Posted by: iM Skruffy Go to Quoted Post
found this on another post. it worked for me and other peoples, try it out :)

1. Click Start , type services.msc in Start search box and hit Enter.
2. Right-click the Peer Networking Grouping service and select Properties .
3. Check if the service is started; if not, right-click and select Start .
4. You may also set the Startup type to Automatic under Properties .
5. Click OK .
and restart the computer.
if that dosent work. do this to.

. Run command Prompt as administrator
2. Type "netsh" and press enter
3. Type "int teredo" and press enter
4. Type "set state disabled" and press enter
5. Type "int ipv6" and press enter
6. Type "set teredo client" and press enter

i did both steps just to be sure before restarting my pc
it seems to be a teredo issue.

it still needs to be fully fixed by Devs


Advice do not spend long times looking thru Car sections or you might lose connection to server.

Enjoy


^ This, the teredo issue is 100% the problem, upon doing this I can now connect to Horizon Life, you're a life saver.
Rank: Driver's Permit
#24 Posted : Saturday, September 29, 2018 11:05:13 AM(UTC)
both steps dont work for me. Teredo is rdy to go ( have looked under netsh interface teredo show state, the adapter don't appear in my device-center, but it works ), my NAT-Type is open and everything looks okay. FH3 works well too.
Only in FH4 i get the massage that i cant connect to the live-servers. Just want to play online with ma buddie :D Damit.
Rank: Driver's Permit
 1 user liked this post.
#25 Posted : Saturday, September 29, 2018 4:29:32 PM(UTC)
Xbox App -> Settings -> Network
If some errors - follow the link to fix it.

In my case i had strict NAT and missed teredo drivers.
5 Pages123>>Next

Notification

Icon
Error