This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
Rank: Driver's License
#1 Posted : Wednesday, September 26, 2018 5:05:37 AM(UTC)
wonder if anyone else with a G920 gets that "grinding gears" annoying sound (kinda when changing gear without pressing the clutch grinding sound). This happens with the FH4 demo, manual+clutch.

Never had this problem on any other Forza title, but noticed that on the telemetry, whenever i press the clutch in a quick manner like you do when going fast ofc, the telemetry registers the fully pressed clutch at 97-98% which should in theory register as if it was at 100% thus eliminating the griding noise when shifting gears, (it does this in all other forza games without issue)
Annoying i have to hammer my clutch everytime so the game registers the full 100% press, that is the only way to avoid the griding sound.
I've so tried adjusting deadzone settings with no luck.
Wonder if anyone else had this issue :/
Rank: Driver's Permit
#2 Posted : Wednesday, September 26, 2018 5:36:03 AM(UTC)
Same thing on PC with a G29. It was so annoying that i started driving with the hood-cam, can't hear it there.
Rank: C-Class Racing License
#3 Posted : Wednesday, September 26, 2018 4:05:14 PM(UTC)
Same. Opened a thread myself. Everyone is experiencing the same problem with manual/clutch.

G920 on PC here.
PC: i5 8600k OC'd @4.5ghz|Asus Rog Strix z370-E|MSi 1080Ti Gaming X|G.Skill Trident Z 16gb 3000mhz|500gb SSD|1TB HDD|Corsair H100i V2|Corsair Crystal 480x RGB|Dell 165hz Gsync 1440p

Notification

Icon
Error