This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
Rank: A-Class Racing License
#1 Posted : Tuesday, May 29, 2018 10:28:29 AM(UTC)
I noticed my counter has zero for achievements in the rewards hub when I clearly have achievements. Every other stat is working but this one. Did they stop giving them? I highly doubt it but it's strange this is the only thing not working correctly, achievements were spot on in every other game.
Rank: A-Class Racing License
#2 Posted : Friday, June 1, 2018 7:11:30 AM(UTC)
There's a thread about this here:

https://forums.forzamoto...ating-on-Forza-hub.aspx

but it's better if it's reported here in the support section.

As far as I can tell, the achievements are registering, and can be seen in the hub app, but gamerscore isn't updating in the rewards system. This is also the case for other games, I've been getting achievements in FM7 and FH3 without the points for gamerscore updating in the rewards system.
Rank: A-Class Racing License
#3 Posted : Friday, June 1, 2018 6:34:42 PM(UTC)
Honestly I saw that post after I made this one. I'm normally good about making sure i don't post something similar but not this time apparently. That's interesting about your issues. I've had achievements bugged for sure but for rewards it's probably the only thing that hasn't given me a problem is the tracking of them, until today haha. I sure hope they can fix the achievement counters, and you get it all working.
Rank: On the Podium
#4 Posted : Thursday, August 30, 2018 2:54:57 AM(UTC)
This issue is also affecting me; I've had 1000 Gamerscore for a few days now but Rewards isn't displaying this.

Notification

Icon
Error