2 Pages12Next
Rank: Driver's Permit
 1 user liked this post.
#1 Posted : Wednesday, October 18, 2017 8:04:06 AM(UTC)
I did the Windows Update this morning (Windows 10 Fall Update 1709)

Before the update everything was running fine. Since the update the game is locked at 30FPS no matter what the settings I'm using. I restarted my PC, reset my NVIDIA Control Panel and it's still Locked to 30FPS. I'm using the latest NVIDIA Driver on a 980TI.

I double checked my Windows "Game DVR" Settings and it's Disabled so is "Game Mode".

Edit 1:After some more testing it appears running in Fullscreen Mode lock the game at 30FPS. Running Windowed mode unlock the framerate.

FPS

Edit 2: More testing revealed that placing the mouse on top of the Title Bar and leaving it there unlocked FPS. As soon as the mouse is moved away from the bar, FPS lock's again to 30.

Edit 3: Here's a video I uploaded showing the problem: https://www.youtube.com/...utu.be&v=Ucjnu3JZQpI

Edit 4: Look's like we've found the problem of 30FPS Lock. My PC is connected to 1x Display Port Monitor & also connected to 1x HDMI 1080p TV. In Windows 10, when going in Display Settings / Multiple Display menu, when using "Duplicate these Displays" my FPS will always be locked at 30. As soon as I change this option to "Extend these Displays" FPS is unlocked.

Edited by user Friday, October 20, 2017 7:39:32 AM(UTC)  | Reason: Not specified

Rank: Forza Staff
 1 user liked this post.
#2 Posted : Wednesday, October 18, 2017 10:38:39 AM(UTC)
Thanks for the information. I'll send this over to the team and let you know when I have some information.

Thank you again,
| GT: ZeroD4RK 30#3892 | Forza Support & Safety Engineer |
Rank: Driver's Permit
#3 Posted : Thursday, October 19, 2017 8:10:27 AM(UTC)
Originally Posted by: Nitro Glitter Go to Quoted Post
Thanks for the information. I'll send this over to the team and let you know when I have some information.

Thank you again,


Just an update regarding this bug,

Today I was testing a bit more the problem I'm getting as described above,

I removed my Nvidia Display Driver and used Display Driver Uninstall to completely remove files and then reinstalled the latest version from their website... I tried the game again and it's still locked to 30FPS in Fullscreen Mode.

However, if I drag my mouse over the Windows Title Bar (The top bar that drop down which has the Forza Motorsport 7 name along with the Minimize/Maximize/Close Icons) my FPS automatically jump back to Unlocked as long as my mouse is on top of the bar so I can see it.

As soon as I move my mouse away from the Title Bar, FPS drop back to 30 and lock there.

Edited by user Thursday, October 19, 2017 8:11:51 AM(UTC)  | Reason: Not specified

Rank: Forza Staff
 2 users liked this post.
#4 Posted : Thursday, October 19, 2017 8:19:22 AM(UTC)
hmm, Thanks for that update. We are trying to repro this in house so we can further investigate. Would you mind recording a video and emailing it to us? forzafb@microsoft.com

Thanks,
| GT: ZeroD4RK 30#3892 | Forza Support & Safety Engineer |
Rank: Driver's Permit
#5 Posted : Thursday, October 19, 2017 9:12:25 AM(UTC)
Originally Posted by: Nitro Glitter Go to Quoted Post
hmm, Thanks for that update. We are trying to repro this in house so we can further investigate. Would you mind recording a video and emailing it to us? forzafb@microsoft.com

Thanks,


Hey,

I sent an e-mail regarding this issue with a link to my video that I've just updated.

https://www.youtube.com/...QpI&feature=youtu.be

Also, the FPS in the video I posted drops to 20 instead of 30FPS as mentioned before. That's due to the recording software I'm using (Tried with OBS & Game DVR) Still the same problem though, as soon as I move the mouse on top of the Title Bar, FPS Is unlocked again...

Edited by user Thursday, October 19, 2017 9:24:29 AM(UTC)  | Reason: Not specified

Rank: Driver's License
#6 Posted : Thursday, October 19, 2017 10:07:22 AM(UTC)
Hey just like to report i'm seeing the same problem. I have nvidea 1070 gtx with intel i7 6700 (non k) did the windows 10 fall creators update yesterday and installed fine. Running benchmark even when selecting low in presets and selecting unlocked or 60 fps or 60 fps vsync always gives me a max benchmark result 30 fps nomatter what i try. On low resolutions on the low preset i should definatly get more than 30 fps so it seems i'm experiancing the same 30 fps lock. I'll try the trick with mouse cursor as i had not tried that. I also notice that my start menu & taskbar appear when i move my mouse curosor to the complete bottom not certain if it was doing this before. But it seems the game is not actually running in an exclusive full screen mode but rather just take the dimensions the screens to maximize the window.

edit: placing the mouse all the way on the top so the little bar comes visible also unlocks the fps with me so i'm having the exact same problem
edit2: just found out that UWP (universal windows platform) games are not able well at least not used to be able to get an exclusive screen lock so it's always running in full screen windowed mode. I'm not certain if the fall creators update that gives full access to the gpu might be able to change that

Edited by user Thursday, October 19, 2017 11:36:08 AM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#7 Posted : Thursday, October 19, 2017 7:47:03 PM(UTC)
Thanks for the info mate i'm having the exact same problem since the Fall update, it was puzzling me to why my FPS were locked to 30 no matter what i tried.
Hopefully this gets fixed ASAP as it's unplayable for me compared to how smooth it ran before.

Rank: Driver's Permit
#8 Posted : Thursday, October 19, 2017 8:47:19 PM(UTC)
i got the same thing after i updated to 1709, i remember having this with horizon 3 around the first creative update but i for the life of me don't remember how i fixed it or if i even fixed it (i know i clean installed windows 10 with the CU cause of some other issue's i was having) but could have just been fixed by a windows update.

i already tried to contact microsoft support about this (as the windows update caused it) but the app they made me download needed to run as a windows service and windows was having none of that. and then after a reboot the rejoin link they gave me ended up not working (i've had that every time i contact support and they ask me to reboot, i tend to just give up cause i dont want to explain whats wrong again, go through the paces again and then have to reboot again to end up with some link that tries to load something but then comes back with try again later >.>

also for spec's sake cause i've spotted a patern in those that are atleast talking about it on the forums ( nvidia only? )

cpu : intel core i5 4670k
ram : 16gb 2400Mhz ddr3
Gpu : nvidia geforce 980 TI
windows version : windows 10 x64 version 1709

Edited by user Thursday, October 19, 2017 8:49:55 PM(UTC)  | Reason: Not specified

Rank: Driver's License
#9 Posted : Friday, October 20, 2017 2:33:14 AM(UTC)
guys i found the culprit in my case.

I have my pc screen hooked up using dvi and i have a tv hooked up using hdmi in windows settings the displays are mirrored so i see the same thing on both screens. As soon as i unhook my tv screen from my pc the problem went away and my fps is unlocked again and not 30 fps locked. This might be a windows specific problem with multiple monitors being attached to the pc.

Do any of you having the problem have multiple monitors attached ? if so try it again with just one monitor attached
Rank: Driver's Permit
 1 user liked this post.
#10 Posted : Friday, October 20, 2017 3:59:36 AM(UTC)
Look's like we've found the problem of 30FPS Lock.

My PC is connected to 1x Display Port Monitor & also connected to 1x HDMI 1080p TV. In Windows 10, when going in Display Settings / Multiple Display menu, when using "Duplicate these Displays" my FPS will always be locked at 30. As soon as I change this option to "Extend these Displays" FPS is unlocked.

Still remains a problem, hopefully T10 will fix this issue. As I said, this problem didn't exist prior the Windows 10 Fall Update 1709

Edited by user Friday, October 20, 2017 7:18:55 AM(UTC)  | Reason: Not specified

Rank: Racing Permit
#11 Posted : Friday, October 20, 2017 6:31:59 AM(UTC)
Originally Posted by: DuckZilla85 Go to Quoted Post
Look's like we've found the problem of 30FPS Lock.

My PC is connected to 1x Display Port Monitor & also connected to 1x HDMI 1080p TV. In Windows 10, when going in Display Settings / Multiple Display menu, when using "Duplicate these Displays" my FPS will always be locked at 30. As soon as I change this option to "Extend these Displays" FPS is unlocked.

Still remains a problem, hopefully T10 will fix this issue. As I said, this problem didn't existed prior WIndows 10 Fall Update 1709


oe nice find, same cause here.
Rank: Driver's Permit
#12 Posted : Saturday, October 21, 2017 2:50:16 AM(UTC)
Same here, hdmi + dvi = 30FPS. Only one display = 60 FPS.
No issue BEFORE the W10 fall update.
Rank: Driver's Permit
#13 Posted : Friday, October 27, 2017 5:44:54 AM(UTC)
Just noticed I'm having this problem as well.

FPS is fine when I set the game to Windowed, but if I go Full Screen I'm locked to 30 fps.

I don't use multiple displays, but I do have a Elgato HD60S which acts as a second display to port to another computer to stream from.

Was working fine(no fps lock) previously, sounds like the 1709 update broke it.
Rank: Forza Staff
#14 Posted : Friday, October 27, 2017 7:28:16 AM(UTC)
Hey guys,

Make sure you are checking the way your monitors are set up. Are you duplicating or extending the display?
| GT: ZeroD4RK 30#3892 | Forza Support & Safety Engineer |
Rank: C-Class Racing License
#15 Posted : Friday, October 27, 2017 8:01:55 AM(UTC)
Just for reference I have a similar dual screen setup (HDMI > HDTV / VGA > Monitor) and do not have frame locking. I use extended display options in windows and have each screen set to its own native res and refresh rates.
Rank: Driver's Permit
#16 Posted : Friday, October 27, 2017 8:19:20 AM(UTC)
Originally Posted by: Nitro Glitter Go to Quoted Post
Hey guys,

Make sure you are checking the way your monitors are set up. Are you duplicating or extending the display?


Mine is set to duplicate. Have to in order for the capture card to work to send the signal to my second PC.
Rank: Driver's License
#17 Posted : Friday, October 27, 2017 8:21:40 AM(UTC)
the oroblem (as is said in the topic) only happens when duplicating not extending
Rank: Forza Staff
#18 Posted : Friday, October 27, 2017 8:39:35 AM(UTC)
What capture card are you using? Do you use a 2nd PC for streaming purposes? What software are you using?

You dont need to send the monitor signal to the second PC if this is a streaming set up. Which is why I am asking all these questions :)

Let me know.
| GT: ZeroD4RK 30#3892 | Forza Support & Safety Engineer |
Rank: Driver's Permit
#19 Posted : Friday, October 27, 2017 8:49:25 AM(UTC)
Originally Posted by: Nitro Glitter Go to Quoted Post
What capture card are you using? Do you use a 2nd PC for streaming purposes? What software are you using?

You dont need to send the monitor signal to the second PC if this is a streaming set up. Which is why I am asking all these questions :)

Let me know.


Elgato HD60S. Yes, using a second PC. Using OBS.

The signal goes though the capture card, which goes to the second PC. Not sure how you mean I don't need to send the signal to the second PC... cause then there would be no video there.

Doesn't really matter. This FPS lock shouldn't be happening, as it wasn't happening before the update. Can just add it to the list of [Mod Edit - Abbreviated profanity, profanity and profanity that is disguised but still alludes to the words are not permitted - D] things this game does that it shouldn't ><

Edited by user Friday, October 27, 2017 10:47:15 PM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#20 Posted : Friday, October 27, 2017 9:14:31 AM(UTC)
Can confirm the same is happening for me after the update.

Stream PC has an Elgato HD60S in it.

Game PC has 3 outputs :

Screen 1 for main screen / gam
Screen 2 for other bits on the pc.
Screen 3 is a direct duplication of Screen 1 - this goes into the Input on the Elgato
Rank: Driver's Permit
#21 Posted : Friday, October 27, 2017 10:28:08 AM(UTC)
Hi all,

I'm also locked at 30 FPS, it's unplayable !
In the Win update menu, Windows message is : This update is ready to install! We need your help deciding when to restart so we can finish up.
So if I believe what I see, it's not already installed, but the problem is present.
I only have 1 monitor connected with DisplayPort to my Asus Rog PG279Q.
System :
CPU : I77820X
MB : ROG STRIX X299-E GAMING
GC : Zotac GTX 1080 Ti Amp Extrem
RAM : 4 x 8 DDR4 3200
SSD System : Samsung 850 Pro 1To
HDD storage and games off-line : WD Red 4To
Fanatec CSW2.5 FFB Wheel + CSL Elite LC pedals

Edit : I wanted to try the mouse tips to see if I could unlock the FPS here, but impossible to launch the game, infinite time to wait at the GT2RS loading menu :(
Just incredible...

Edited by user Friday, October 27, 2017 10:37:12 AM(UTC)  | Reason: Not specified

Rank: C-Class Racing License
#22 Posted : Friday, October 27, 2017 2:45:10 PM(UTC)
Same problem with pretty much the exact same setup like the OP described here.
However, I can`t just not duplicate screens, so I hope it can be fixed soon.
Rank: Driver's Permit
#23 Posted : Saturday, October 28, 2017 1:35:59 AM(UTC)
Quick fix for people that use duplicated screen for streaming,
Run in windowed mode,
In obs, increase the Source about 5%

looks full screen now :)
Rank: Driver's Permit
#24 Posted : Saturday, October 28, 2017 2:48:31 AM(UTC)
Ok,

I believe this might have something to do with the Fall Creators update.

I loaded PUBG and I was having the same issue, although FPS was capped to 60 rather than 30.

On reading up, it seems there was an issue before to do with Game Bar/GameDVR

Disabling both of those and also this :

Find the exe-file to the game you are having trouble with. In this case csgo.exe
Right click the exe-file and click properties
Click on the compability tab
Click on Disable fullscreen optimizations
Click apply and ok

The problem is, The Forza .exe is locked so you can't do this for forza.
Rank: Driver's Permit
#25 Posted : Friday, November 3, 2017 4:53:15 PM(UTC)
I use a huge TV and a computer monitor here's what I do to get 60fps on the large TV.

In windows 10 search, type display
Click display settings
scroll down, at multiple displays select to show only on one display.

This will disable your computer monitor but 60fps + on your large one.
2 Pages12Next

Notification

Icon
Error