This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
7 Pages<<567Prev
Rank: Driver's Permit
#151 Posted : Tuesday, October 3, 2017 6:31:58 PM(UTC)
Feels like Forza Horizon 3 all over again...

System Specs

I7-7820X
32GB DDR4 RAM
PNY GTX 1080
Game installed Raid 0 SSD Array (2x250GB SSD)

Latest GeForce Driver 385.69

Micro Studders in every race.

Limo Bowling unplayable... Collisions with pins cause frame rates to literally drop to 1FPS
Ken Block Challenge... Micro Studders... Colliding with a wall causes FPS to drop to 1 FPS .. Extreme slow motion.

Colliding with any tire wall in any race causes drop to 1 FPS.

All menus studder

Graphics Settings
Dynamic Render Quality -- Ultra (this is what the game seems to keep setting itself to)
Resolution 1920x1080 .. game defaulted to 4k, even though I have 1080p monitors
Dynamic Optimization .. Default.

Under Advanced I set Performance Target to "60 FPS (V-SYNC)"

Everything else set to Dynamic.

Seems the game, just like FH3, LOADS UP ONE CORE on my CPU. This was a huge issue on FH3 and once fixed made the game much better.

Truly enjoyable to have an 8C/16T system and watch one and only one core get blown through the roof.

Game need to be fixed NOW on PC. Just like with FH3 ... Xbox is stable, but PC is full of issues. Doesnt bode well for the Xbox Everywhere line if the PC side of things isnt going to be optimized.









Rank: Driver's Permit
#152 Posted : Tuesday, October 3, 2017 7:09:07 PM(UTC)
Just shining in after 4 hours of gameplay, I decided to wait for improvement / patches to play more. The stuttering is really an issue, whether or not it is related to the pinned 1 core. It's such a bummer because other than this stuttering, the optimization is amazing. It runs really well and look really nice. But alas, stuttering in a racing game really deteriorate from the experience to the point where it ruins it. I will not ask for a refund for now as I am confident it could be fixed, but since it was never fixed in Apex and took 6 months for Horizon 3, I don't know if I might regret that. The fact that this topic keeps coming back again after the issue with Apex and Horizon 3 is makes it even more a bummer. I'm really curious if people who QA this game didn't notice anything? That's almost impossible...

EDIT : Also, as in Apex, restarting the game fixes the issue with stuttering.... Until it comes back a few race later. So if it can run as good as the first race upon loading for every races, it probably means it can be fixed (can it?)!

Edited by user Tuesday, October 3, 2017 7:25:16 PM(UTC)  | Reason: Not specified

Rank: D-Class Racing License
#153 Posted : Wednesday, October 18, 2017 1:34:55 PM(UTC)
Has anyone heard from T10 if a couple optimization option will come to PC in near future?
Rank: Driver's License
 1 user liked this post.
#154 Posted : Wednesday, October 18, 2017 5:30:14 PM(UTC)

2.0 ghz, 5 minute race, ultra

Edited by user Wednesday, October 18, 2017 5:30:49 PM(UTC)  | Reason: Not specified

Rank: Racing Permit
#155 Posted : Thursday, October 19, 2017 6:36:30 AM(UTC)
Originally Posted by: StockTundra Go to Quoted Post

2.0 ghz, 5 minute race, ultra


go to Set Affinity and uncheck Core 0. You will see better multithreading utilization without impacting the game.
Rank: Driver's Permit
#156 Posted : Thursday, October 19, 2017 7:25:15 AM(UTC)
Originally Posted by: Symtex Go to Quoted Post
Originally Posted by: StockTundra Go to Quoted Post

2.0 ghz, 5 minute race, ultra


go to Set Affinity and uncheck Core 0. You will see better multithreading utilization without impacting the game.


Please don't do that. In many cases, it will make it way worse as that puts an additional strain on the CPU to redistribute resources. It might help in some specific cases, but usually will make things worse.
7 Pages<<567Prev

Notification

Icon
Error