This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
Rank: Driver's Permit
#1 Posted : Tuesday, October 2, 2018 12:06:46 PM(UTC)
I launched the game for the first time, it pestered me about my graphics drivers needing to be updated. I pressed on ignore and played anyway while i updated my drivers, tweaked my ingame settings, and played through the intro to see how much performance i can get out of the game with my hardware. Everything was set up perfectly fine, i was running a smooth silky 60FPS, not breaking a sweat while the ingame GPU monitor was reading a good 80-90 percent.

The game then hardlocked and crashed during the spring sequence of the intro, I had figured it was because of my drivers so i tried to play past that part a couple more times to make sure whilest i was still downloading my drivers, lo and behold it kept crashing during the same part. So i installed my drivers and rebooted my PC, and now im here. The game is giving me 60FPS windowed at a healthy GPU percentage of 70-80, and in fullscreen a 20FPS at an odd 5-10 GPU percentage. My system can obviously run this game without breaking a sweat at 60 FPS, with most settings moderately high. So what gives?
Rank: Driver's Permit
#2 Posted : Tuesday, October 2, 2018 12:26:21 PM(UTC)
Update: In fullscreen if i hover my cursor over the task bar or the top bar (idk what its called) the game goes back to 60FPS again

Update: Setting my monitor to 75hertz in the Nvidia control panel pushes the fullscreen FPS lock from 20, to 25

Edited by user Tuesday, October 2, 2018 5:08:53 PM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#3 Posted : Tuesday, October 2, 2018 12:46:17 PM(UTC)
[img=https://imgur.com/a/eOymOc5]My benchmark for posterity sake[/img]
Rank: Driver's Permit
#4 Posted : Tuesday, October 2, 2018 2:05:37 PM(UTC)
I get the same thing. Do you have a G-sync monitor?
Rank: Driver's Permit
#5 Posted : Tuesday, October 2, 2018 5:06:33 PM(UTC)
Oddly enough, i do use a monitor that has freesync, i got the panel at a really great price however since im using an Nvidia GPU i have never used that feature.
Rank: Driver's Permit
#6 Posted : Wednesday, October 3, 2018 11:49:02 AM(UTC)
i have same issue so annyoing:(
my spec:
4690k
gtx960 4gb
and an old 21" fuji display

only solution what i foudn is this program but i have to activate every time when i minimize the game: https://www.youtube.com/watch?v=38HK8aiIXzc
Rank: Driver's Permit
#7 Posted : Wednesday, October 3, 2018 12:01:53 PM(UTC)
I FOUND THE SOLUTION I THINK

so i use 2 display monitor one is main for gaming other is duplicated for watching moovies, so i went to windowds display settings and turned off the other display just use my main monitor and voala get abck in the game fram limiter now unlocked real 60!

spec:
i5 4690k
gtx 9604gb

Notification

Icon
Error