This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
Rank: Driver's Permit
#1 Posted : Saturday, June 16, 2018 11:20:28 PM(UTC)
When I downloaded it from the store It said that my pc met the standards needed for the game. I installed it and then opened it (skipping the AP501 error) and yet I still had severe lag. I ran it on my friend's pc ,who's is only better due to it having 100GB more storage but that was the only difference, and it ran smoothly for him. Does anyone know how I could fix this? And are there any ways to change the settings from the load screen?

Also when I say lag I mean LAG It took me 2 hours to get passed the loading screens and to the actual tutorial even then I couldn't move anything...
Rank: C-Class Racing License
#2 Posted : Saturday, July 14, 2018 1:30:55 AM(UTC)
Originally Posted by: KilldEmTwice Go to Quoted Post
When I downloaded it from the store It said that my pc met the standards needed for the game. I installed it and then opened it (skipping the AP501 error) and yet I still had severe lag. I ran it on my friend's pc ,who's is only better due to it having 100GB more storage but that was the only difference, and it ran smoothly for him. Does anyone know how I could fix this? And are there any ways to change the settings from the load screen?

Also when I say lag I mean LAG It took me 2 hours to get passed the loading screens and to the actual tutorial even then I couldn't move anything...


https://support.xbox.com...ooting/error-code-ap501

Notification

Icon
Error