This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
Rank: Driver's Permit
#1 Posted : Wednesday, October 4, 2017 3:19:07 AM(UTC)
I just purchased Forza 7 through the Microsoft store today. After roughly two hours of game play, I experienced a game breaking bug. I realize that the game just came out and this is bound to happen, hopefully it can be resolved asap. During the selection of the dune buggy type car race in the first sector of the campaign, I purchased the car and it bugged out during the save process. So I was forced to close the game and restart. After restarting the game I am no longer allowed to scroll to different cars, in the campaign, as well as the multiplayer. I am able to play free play mode because my car is automatically selected, but every other mode I can not scroll down at all, it just glitches me constantly to the top choice to purchase a car, of which I don't want to do and or couldn't do if I didn't have enough money. It makes the game unplayable for me and needs to be fixed as soon as possible. I tried restarting the game multiple times and even restarting my computer. I would re-install the game but the fact it is 95gb and internet companies suck with data caps, It would kill my data that is already low. Please fix this asap!
Rank: Driver's Permit
#2 Posted : Wednesday, October 4, 2017 5:36:30 AM(UTC)
Sounds like a corrupted savegame. I dont think reinstalling the game would fix this. Could you try to start over on a different microsoft/xbox one account and see if it works?
Rank: Driver's Permit
#3 Posted : Wednesday, October 4, 2017 10:01:07 AM(UTC)
So, I have to re buy the game? because wont I not have the game on a new xbox accountt.
Rank: Driver's Permit
#4 Posted : Wednesday, October 4, 2017 10:26:46 AM(UTC)
Nope, even using a new xbox live account does not fix the problem :(
Rank: Driver's Permit
#5 Posted : Wednesday, October 4, 2017 3:41:10 PM(UTC)
At this point I have no clue what the hell to do other than try to refund the game. I un-installed the game and re-installed it, updated drivers, messed with the video options, and the same problem occurs. What the hell.
Rank: Driver's Permit
#6 Posted : Wednesday, October 4, 2017 4:25:32 PM(UTC)
I made a video of the glitch, so that it can hopefully be resolved. https://youtu.be/fVxfN4Rp7wM
Rank: Driver's Permit
#7 Posted : Wednesday, October 4, 2017 10:07:01 PM(UTC)
Oh did not think about that....but im sure there is a way to use the license on another account....somehow^^ Well bad to hear...so not sure whats causing ur gamebreaking bug then X.x
Rank: Driver's Permit
#8 Posted : Thursday, October 5, 2017 2:12:04 AM(UTC)
I want to post an update. Completely reformatted my computer and the problem still exists. Must be a hardware issue of some kind, going to return the brand new controller I bought just for this game and see if a new one works, if that doesn't work then it is a piece of hardware in my computer. I just built this computer with top of the line parts, so i doubt that is the issue.
Rank: Driver's Permit
#9 Posted : Thursday, October 5, 2017 12:38:43 PM(UTC)
Final Update: Went back to Gamestop to return the controller I had just bought 2 days ago for another new one and the issue is fixed. Going to alter my 4 star rating to 5 stars in the reviews, because the team at Forza replied within 10 hours of my e-mail and they seemed to really care about my issue and wanting to help me.
Rank: Driver's Permit
#10 Posted : Friday, October 6, 2017 9:58:52 PM(UTC)
Oh nice to hear you could solve it. A controller issue? strange x.x
Rank: Driver's Permit
#11 Posted : Saturday, October 7, 2017 12:40:18 AM(UTC)
Un-expected update: So I bought a second brand new controller and played this amazing game for about 24 hours in two days, way to much, yes, haha. After ending my stream tonight, after the last race, I went to adjust my tune on my cars and the same bug arose... I decided maybe there is an issue with the drivers for brand new controllers? I have no idea. So I un-installed and re-installed the drivers for my controller and it started working again. Hope this helps anyone with the same issue, because I feel like it can't be happening to just me.

Notification

Icon
Error