6 Pages123>>Next
Rank: Forza Community Team
#1 Posted : Thursday, September 22, 2016 9:26:53 PM(UTC)
In our recent Forza Horizon 3 Gone Gold post on FM.net, we posted the recommended specs for Forza Horizon 3 on Windows 10 PCs. Since then, we’ve heard from users wondering about the ideal PC specs, which you can find here:

[UPDATE: Note that these specs are meant to reflect locked 30fps performance in the game.]

Minimum Specification
CPU i3-4170 @ 3.7Ghz
GPU NVIDIA GT 740 | AMD R7 250x
VRAM 2GB GDDR5
RAM 8GB
Hard Drive Type HDD
Resolution 1280 x 720
Note: Game must be played on LOW settings if using the minimum specifications.

Here as a reminder are the recommended system requirements, which are also meant to reflect locked 30fps performance in the game.



Thanks,
Brian

Edited by user Monday, June 12, 2017 8:06:05 AM(UTC)  | Reason: Updated Minimum PC Requirements - must be played on LOW settings.


Brian Ekberg
Forza Community Manager
ForzaMotorsport.net
Rank: D-Class Racing License
 9 users liked this post.
#2 Posted : Thursday, September 22, 2016 11:09:35 PM(UTC)
Good post the only issue is, i have exactly those specs like you mentioned but at 1080p i get insane frame drops on ultra when i am in a place with alot of houses or buildings, so i have to disagree on this one
Rank: Driver's Permit
 4 users liked this post.
#3 Posted : Thursday, September 22, 2016 11:26:32 PM(UTC)
Yea, I try to run smooth on 1366x768 res on GTX 1070!, i5-6600k! and 16 gb ram and I got massive fps drops (from stable 60 to random 35-40 that feels like 10). Only two things on ultra, rest is set to high, despite v-sync or msxaa turned on/off. Oh and I got delay in the tuning menu :V
Rank: Driver's Permit
 1 user liked this post.
#4 Posted : Thursday, September 22, 2016 11:29:08 PM(UTC)
Originally Posted by: FirePhoenixx115 Go to Quoted Post
Good post the only issue is, i have exactly those specs like you mentioned but at 1080p i get insane frame drops on ultra when i am in a place with alot of houses or buildings, so i have to disagree on this one


Running a GTX980 at 1440p on ultra and vsync and I get a stable 60fps all the time.
Rank: Forza Community Team
#5 Posted : Thursday, September 22, 2016 11:31:48 PM(UTC)
Originally Posted by: FirePhoenixx115 Go to Quoted Post
Good post the only issue is, i have exactly those specs like you mentioned but at 1080p i get insane frame drops on ultra when i am in a place with alot of houses or buildings, so i have to disagree on this one


If you are running anisotropic filtering at 16 then try it at 8 and see if that helps things.
Forza EMEA Community Manager
Rank: D-Class Racing License
#6 Posted : Thursday, September 22, 2016 11:33:27 PM(UTC)
This would be great of those specs didnt incur crazy frame stuttering constantly.

Also, why would you have optimum Resolution set to 4K? that makes no sense.

Edited by user Thursday, September 22, 2016 11:34:31 PM(UTC)  | Reason: Not specified

Rank: Series Champion
 3 users liked this post.
#7 Posted : Thursday, September 22, 2016 11:35:53 PM(UTC)
Originally Posted by: HeliosT10 Go to Quoted Post
Originally Posted by: FirePhoenixx115 Go to Quoted Post
Good post the only issue is, i have exactly those specs like you mentioned but at 1080p i get insane frame drops on ultra when i am in a place with alot of houses or buildings, so i have to disagree on this one


If you are running anisotropic filtering at 16 then try it at 8 and see if that helps things.


That isnt a solution and you know it.
Talking to brick walls since 2007.
Motivational Poster. Praise Dragnet
Rank: D-Class Racing License
 5 users liked this post.
#8 Posted : Thursday, September 22, 2016 11:40:22 PM(UTC)
Also running it on an SSD and there are SEVERE game stalls when going through the upgrades menu, up to 3 seconds of just freezing when selecting different parts. This makes upgrading cars an Absolute Headache, both figuratively and literally.

This is the kind of stuff that is why I think They didnt even test the game AT ALL on anything because none of the recommended specs work to any sufficient degree. These specs are the top most consumer based hardware money can buy, and the game still chugs. This is all on the devs. Every bit of it.

Edited by user Friday, September 23, 2016 12:14:44 AM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#9 Posted : Friday, September 23, 2016 1:13:55 AM(UTC)
Hi,

Cán I run IT

I5-4440.
GTX 970
8gb

Ultra or high?

Edited by user Friday, September 23, 2016 1:28:09 AM(UTC)  | Reason: Not specified

Rank: D-Class Racing License
 1 user liked this post.
#10 Posted : Friday, September 23, 2016 2:45:23 AM(UTC)
Originally Posted by: BMWMPower94 Go to Quoted Post
Hi,

Cán I run IT

I5-4440.
GTX 970
8gb

Ultra or high?


medium
you wont get high

Rank: C-Class Racing License
#11 Posted : Friday, September 23, 2016 2:46:19 AM(UTC)
Originally Posted by: BMWMPower94 Go to Quoted Post
Hi,

Cán I run IT

I5-4440.
GTX 970
8gb

Ultra or high?


at 1080p Maybe Medium @ the moment :-(
MY Forza games



+ Digital Versions of Forza 6:Apex , Forza Horizon 3 , Forza Motorsport 7
Rank: D-Class Racing License
 3 users liked this post.
#12 Posted : Friday, September 23, 2016 2:48:50 AM(UTC)
its a sad state of affairs when my xbox one version runs better than my core i5 and gtx1060 @ medium settings.

Rank: C-Class Racing License
 3 users liked this post.
#13 Posted : Friday, September 23, 2016 2:58:28 AM(UTC)
Originally Posted by: DeadJericho Go to Quoted Post
its a sad state of affairs when my xbox one version runs better than my core i5 and gtx1060 @ medium settings.




yeah its ridiculous ... thx god that i dont preorder this game . Although i have waited for years to play a Forza game again . I have loved the serie .

Because MS decided that only NEW wheels work on XBone . I have not bought one . And now im a happy PC gamer :-) except FH 3 :-(


MY Forza games



+ Digital Versions of Forza 6:Apex , Forza Horizon 3 , Forza Motorsport 7
Rank: D-Class Racing License
 2 users liked this post.
#14 Posted : Friday, September 23, 2016 3:14:15 AM(UTC)
Originally Posted by: DeadJericho Go to Quoted Post
its a sad state of affairs when my xbox one version runs better than my core i5 and gtx1060 @ medium settings.



What's even sadder is that my Wife's Xbox One runs better than my I7 4790K, Pascal Titan X and 32GB's of Ram :) I'm running around 60 to 80 fps most of the time on Ultra @ 4K and I keep getting these annoying random dips down to 40 fps every few minutes.

Also slightly unrelated we just did a multiplayer free roam session and my wife on the Xbox was getting a lot of traffic whilst on the PC I wasn't getting any at all. Is this a known issue relating to cross platform multiplayer?
I9 9900K
32 GB Ram (4x8 DDR4)
RTX 2080 Ti
Windows 10 64bit
Asus Prime Z390-A
Rank: D-Class Racing License
#15 Posted : Friday, September 23, 2016 3:22:50 AM(UTC)
Originally Posted by: GLR NellyDRacer Go to Quoted Post
Originally Posted by: DeadJericho Go to Quoted Post
its a sad state of affairs when my xbox one version runs better than my core i5 and gtx1060 @ medium settings.



What's even sadder is that my Wife's Xbox One runs better than my I7 4790K, Pascal Titan X and 32GB's of Ram :) I'm running around 60 to 80 fps most of the time on Ultra @ 4K and I keep getting these annoying random dips down to 40 fps every few minutes.

Also slightly unrelated we just did a multiplayer free roam session and my wife on the Xbox was getting a lot of traffic whilst on the PC I wasn't getting any at all. Is this a known issue relating to cross platform multiplayer?


I was getting tons of traffic on my PC. Now im playing on Xbox.
Rank: D-Class Racing License
#16 Posted : Friday, September 23, 2016 3:31:55 AM(UTC)
Originally Posted by: Harawanagangsta Go to Quoted Post
Originally Posted by: GLR NellyDRacer Go to Quoted Post
Originally Posted by: DeadJericho Go to Quoted Post
its a sad state of affairs when my xbox one version runs better than my core i5 and gtx1060 @ medium settings.



What's even sadder is that my Wife's Xbox One runs better than my I7 4790K, Pascal Titan X and 32GB's of Ram :) I'm running around 60 to 80 fps most of the time on Ultra @ 4K and I keep getting these annoying random dips down to 40 fps every few minutes.

Also slightly unrelated we just did a multiplayer free roam session and my wife on the Xbox was getting a lot of traffic whilst on the PC I wasn't getting any at all. Is this a known issue relating to cross platform multiplayer?


I was getting tons of traffic on my PC. Now im playing on Xbox.


Yep on single player I was getting plenty of traffic but it was while I was in multiplayer I was having the issues with not seeing traffic. Whereas the other person in the lobby, my wife was getting lots of traffic. It may just be a random occurrence rather than a bug.
I9 9900K
32 GB Ram (4x8 DDR4)
RTX 2080 Ti
Windows 10 64bit
Asus Prime Z390-A
Rank: Racing Permit
 11 users liked this post.
#17 Posted : Friday, September 23, 2016 4:34:26 AM(UTC)
Recommended Specs: About as high end as you can get.

Or in other words: Sorry, we didn't get around to any PC optimisations so throw faster hardware at it...
Rank: Driver's Permit
#18 Posted : Friday, September 23, 2016 6:51:19 AM(UTC)
Originally Posted by: Mechberg Go to Quoted Post
In our recent Forza Horizon 3 Gone Gold post on FM.net, we posted the recommended specs for Forza Horizon 3 on Windows 10 PCs. Since then, we’ve heard from users wondering about the ideal PC specs, which you can find here:

CPU - 7 6700 @ 4.0GHz
GPU - NVIDIA GTX 980Ti or GTX 1080 | AMD R9 Fury X
VRAM - 6GB
RAM - 16GB
Hard Drive Type - SSD
Hard Disk Space - 55 GB
Resolution - 3840 x 2160
Windows Version - Windows Anniversary Edition 64-bit 14393.102

Thanks,
Brian


I have these exact specs with a 980 Ti (well actually 2 in SLI). Are these the specs you recommend to target 30fps or 60fps? I'm playing on a 4k TV but I had to turn it down to 2560x1440 High settings to maintain 60fps. Any idea if SLI/CF or mGPU will be supported at some point?
Rank: Driver's Permit
 3 users liked this post.
#19 Posted : Friday, September 23, 2016 7:38:27 PM(UTC)
My Specs
i5-4690k @4.2ghz
Gtx 970
16gb Ram

I literally can not keep a stable 60fps on all low? and i paid 100$ on this game.
i have the drivers and everything up to date as well.
Rank: Driver's Permit
 5 users liked this post.
#20 Posted : Friday, September 23, 2016 7:45:09 PM(UTC)
Originally Posted by: SledgeNZ Go to Quoted Post
Recommended Specs: About as high end as you can get.

Or in other words: Sorry, we didn't get around to any PC optimisations so throw faster hardware at it...


This is basically what they're saying, disgusting really im not just going to go out and buy a new 1080 when my 970 does the job just fine (If it aint broke, don't fix it, yes these cards are 2 years old but thats not the point) i don't think the 970 (Usually im using SLI) should be playing medium settings anytime either i play most of my games at max settings @ 2560x1440 @60fps without a sweat so i don't see why this game can't all i can think is that their focus is console and if you want a smooth framerate chuck money around, a console is more smooth than my PC what gives? £250 consoles vs £1500 PCs or even people with £4000 PCs?


Optimization and SLI/Crossfire is the only way for everyone to have an enjoyable experience, don't rush the game if its not going to have an optimal experience just let the game come out when its fully optimized for most hardware configurations and the 970 is a card most people have in the PC community or so i see everywhere. Listen to your fans microsoft, turn10, playground, developers around the world.

This is not a rage or anything i just think its about time developers focus on optimizing their games before thinking about release dates and revenue.
Rank: Driver's License
#21 Posted : Friday, September 23, 2016 8:56:51 PM(UTC)
My framerates average around 40-55 fps.

My specs:
Xeon x5680 @ 4GHz
MSI GTX 970 4G @ 1526/8000
12GB DDR3-1600
Samsung 850 EVO SSD

Settings:
1920x1080
Ultra.
V-Sync Off
16x AF
2x FXAA
FrameRate Smoothing On

Intel Xeon X5680 @ 4GHz
Asus P6T
12GB G.Skill Sniper DDR3-1600 99924
MSI GTX1070 Ti Titanium
4K w/16x AS 8xAA 100% sampling.
Rank: Racing Permit
 2 users liked this post.
#22 Posted : Friday, September 23, 2016 9:09:32 PM(UTC)
Apparently a 980 Ti oc'd to 1500Mhz and a 4690K at 4.0Ghz isn't good enough to max this game out.. At first. yesterday, on launch day for early access, id get around 50-60fps with frequent stuttering in the outback and especially jungle.. Then in Byron bay and Surfers the fps would TANK to low 30s... This was at 1080P maxed out. with 8x msaa

Now today after a reboot all of sudden, HORRENDOUS fps at ANY setting and ANY res. Hell even dipped it into the lowest available, 1024x768. with every turned off. 34fps was like my max, with outrageous stuttering.

If i paid $100 for this im killing myself. i want a patch, right now.

EVGA 980 Ti superclocked ACX 2.0
i5 4690K at 4.0
Z97S Sli Krait edition
8GB of ram at 1600mhz
installed on a Trion 150 SSD (240gb)
and main storage drive (which isnt used for this game) WD blue 1tb

Edited by user Friday, September 23, 2016 9:11:05 PM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#23 Posted : Saturday, September 24, 2016 12:53:58 AM(UTC)
Hey guys.

I am new to the forums and of course I have a problem with the preload as well. The problem is, I can't download the game. I do only have a 'manage' field on the Ultimate Edition. I have already updated to Win 10 Anniversary but still there's an [X] under the reccommandations :O

My specs:

Win 10 Anniversary 14393.0 (Version 1607)
Nvidia GTX950M (2 GB)
8GB RAM

What I have noticed is, that I have according to winver 14393.0 but the game requires 14393.102

How can I get to that version???
Rank: Driver's Permit
 3 users liked this post.
#24 Posted : Saturday, September 24, 2016 6:42:59 AM(UTC)
Running a 3930k @ 4.5 with 32gb ram and 2 GTX 1080s

I am getting stuttering and rubber banding all over at 2560x1440 with G-Sync On!
Rank: Driver's Permit
#25 Posted : Saturday, September 24, 2016 10:13:39 AM(UTC)
Originally Posted by: RichardH754 Go to Quoted Post
Running a 3930k @ 4.5 with 32gb ram and 2 GTX 1080s

I am getting stuttering and rubber banding all over at 2560x1440 with G-Sync On!


if i remember correctly they had stated that originally at launch they wouldnt be supporting SLI, but you having issues with a 1080 is funny, i have no issues on one of my 970m's

_______________________________________________________________________________________________________________________

Been getting 50-60 fps on my laptop considering the lack of SLI support at the time and not on my G-Sync screen

My specs
Win10 anniversary edition
2x 1080p 1x 900p
i7- 6820HK @2.70 GHz (oc to 3.7)
2x GTX 970m's in SLI
16GB DDR4 @ 2133Mhz

Edited by user Thursday, September 29, 2016 1:39:25 AM(UTC)  | Reason: Not specified

OS: Windows 10 Home
CPU: i7-6820HK 2.70GHz(OC 3.7)
GPU: NVIDIA GTX 970M x2(in SLI)
RAM: 16GB DDR4 @2133 MHz
XBL: CrimsonW0lf11
6 Pages123>>Next

Notification

Icon
Error