Rank: X-Class Racing License
#1 Posted : Thursday, September 17, 2015 4:37:55 PM(UTC)
Ok, so I just got the game and enjoying it so far. However, I was expecting a few cheevos to pop up right at the start.

I'm getting badges, but no cheevos at all.

I had a few from playing GTAV a couple of hours ago but nothing at all in FM6.

I have the deluxe edition and I'm on the preview dashboard (but not the latest Windows 10 one).

Edited by user Thursday, September 17, 2015 4:51:36 PM(UTC)  | Reason: Not specified

Formerly known as 'o Aperture o'
Rank: Driver's Permit
#2 Posted : Thursday, September 17, 2015 4:42:45 PM(UTC)
Having the same issue, nothing yet and definately met the criteria for a handful :(
Rank: X-Class Racing License
#3 Posted : Thursday, September 17, 2015 5:03:45 PM(UTC)
Glad it's not just me. It occurred to me that I changed my gamertag since downloading the game, but I don't think that will be a problem at all. I just removed my account from the console and added it back, in case that was the problem.
Formerly known as 'o Aperture o'
Rank: A-Class Racing License
#4 Posted : Thursday, September 17, 2015 5:17:06 PM(UTC)
Europe broke the game.....<Points and laughs>

Mine are not unlocking in the U.S. either, so it's not just you guys. Just spent money on the GT for that cheevo to. (grrrrrrr)
I would race you, but a dog ate my station wagon.
Who's on first?
Rank: X-Class Racing License
#5 Posted : Thursday, September 17, 2015 5:23:02 PM(UTC)
It looks as though the cloud sync is broken. "Syncing data for Forza Motorsport 6" takes a long time for me and at the end I get an error message and code:

"We were unable to sync your data with the cloud right now"

Error 8083201d

This would explain why the cheevos aren't popping I guess.

I've cleared my local saved game cache, but still getting this error. I'll try again tomorrow (past 2am here in the uk now).
Formerly known as 'o Aperture o'

Notification

Icon
Error