Rank: Racing Permit
#1 Posted : Tuesday, September 15, 2015 3:36:40 AM(UTC)
I know I'm not the only one but how do I get to race online, all I ever get is the same error message stating error connecting to server data or something like that. Is there a fix coming, have turn 10 said anything about it?

Edited by user Tuesday, September 15, 2015 1:31:35 PM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#2 Posted : Tuesday, September 15, 2015 5:00:03 AM(UTC)
Same problem here not been able to connect to any multiplayer since early release. Get the msg online servers not up and running yet try again later. I'm in Norway have 10 megabit up 30 down. This is frustrating can connect fine to the other forza games.

Edited by user Tuesday, September 15, 2015 5:02:05 AM(UTC)  | Reason: typo

Rank: Driver's Permit
#3 Posted : Tuesday, September 15, 2015 5:24:19 AM(UTC)
I cannot get online either. I havent been able to get online with Horizon 2 either. I have invested a lot of money on the premium versions of the game. Please can anyone be of service? Kansas City, MO
Rank: Driver's Permit
#4 Posted : Tuesday, September 15, 2015 7:33:30 AM(UTC)
Yes, same problem here! So frustrating.
Rank: Racing Permit
 2 users liked this post.
#5 Posted : Tuesday, September 15, 2015 8:28:53 AM(UTC)
Glad I paid £81..... I was looking forward to some good online racing before all the idiots got on.....
Rank: Driver's Permit
#6 Posted : Tuesday, September 15, 2015 12:05:01 PM(UTC)
I've been having this same problem since pre-release Wednesday morning. I've tried to get a response here and on twitter, and *shockingly* I've heard nothing at all back. Seems pretty on par for turn10.
Rank: Forza Community Team
 6 users liked this post.
#7 Posted : Tuesday, September 15, 2015 12:40:26 PM(UTC)
Hi folks,

We are aware of the issue that some players are running into with MP matchmaking and are investigating. I don't have anything new to report but I wanted to let you know we are looking into it.

Thanks,
Brian

Brian Ekberg
Forza Community Manager
ForzaMotorsport.net
Rank: Racing Permit
#8 Posted : Tuesday, September 15, 2015 1:30:12 PM(UTC)
Thank you for acknowledging this cry for help 😊 can't wait to get online!
Rank: Driver's Permit
#9 Posted : Wednesday, September 16, 2015 1:20:12 PM(UTC)
Any news?
Rank: Racing Permit
#10 Posted : Wednesday, September 16, 2015 1:38:00 PM(UTC)
I can't even get single player to Load.

Hell I can't even get the game to get past the initial start up screen.


Don't understand why every time a game is released I spend my money just to be disappointed and not able to play
Rank: Driver's Permit
#11 Posted : Wednesday, September 16, 2015 1:43:10 PM(UTC)
Game was fine for me at launch but just seems to get worse over time.
Rank: Driver's Permit
#12 Posted : Wednesday, September 16, 2015 3:49:12 PM(UTC)
I really hope this gets fixed in hours, and not days. Missing out on friends hosting club races tonight.
Rank: A-Class Racing License
 1 user liked this post.
#13 Posted : Wednesday, September 16, 2015 6:26:02 PM(UTC)
Paid $100 for ultimate. Pretty lame guys. Can we play the game please?
Rank: Driver's Permit
#14 Posted : Wednesday, September 16, 2015 8:01:19 PM(UTC)
I found a workaround that worked for me and is working for others. On your xbox, go to setting > network > advanced network settings > DNS and then set it to googles dns servers (8.8.8.8 and 8.8.8.4).
Rank: D-Class Racing License
#15 Posted : Thursday, September 17, 2015 3:43:28 AM(UTC)
Same;
Failed to start Multiplayer

Multiplayer is currently unavailable. Please try again later.

Hardwired LAN

OPEN NAT

Edited by user Thursday, September 17, 2015 4:43:51 AM(UTC)  | Reason: Not specified

Rank: A-Class Racing License
 3 users liked this post.
#16 Posted : Thursday, September 17, 2015 6:13:30 AM(UTC)
This is becoming a joke. I paid $100 for the ultimate edition and Turn 10 doesn't care that I still can't play online. I've been playing forza games since the first one and this is just pathetic.
Rank: Racing Permit
#17 Posted : Friday, September 18, 2015 10:59:30 AM(UTC)
ive been able to get on. had to change my dns though
Rank: Driver's Permit
#18 Posted : Friday, September 18, 2015 11:15:11 AM(UTC)
Originally Posted by: Hepnotik Go to Quoted Post
I found a workaround that worked for me and is working for others. On your xbox, go to setting > network > advanced network settings > DNS and then set it to googles dns servers (8.8.8.8 and 8.8.8.4).


This doesn't do anything for me. I'm still waiting to try multiplayer for a week now.
Rank: Driver's Permit
#19 Posted : Friday, September 18, 2015 12:43:26 PM(UTC)
Originally Posted by: metalhoagie Go to Quoted Post
Originally Posted by: Hepnotik Go to Quoted Post
I found a workaround that worked for me and is working for others. On your xbox, go to setting > network > advanced network settings > DNS and then set it to googles dns servers (8.8.8.8 and 8.8.8.4).


This doesn't do anything for me. I'm still waiting to try multiplayer for a week now.


Same thing. Changing the dns did't do anything.
Rank: Racing Permit
#20 Posted : Friday, September 18, 2015 1:51:58 PM(UTC)
i did 8,8,8,8 & 8,8,8,7 and its worked

Notification

Icon
Error