78 Pages<<2526272829>>PrevNext
Rank: Driver's Permit
#651 Posted : Friday, October 3, 2014 6:01:08 PM(UTC)
Originally Posted by: Mechberg Go to Quoted Post
[UPDATE: 10/3/14 5:25 p.m.]

Finally, we have seen some complaints from players who are unable to connect to multiplayer services in Forza Horizon 2. We are investigating this issue within Forza Horizon 2 but I also want to remind players about issues regarding NAT errors on Xbox One. If you are unsure of how your home network is set up, or the state of your NAT settings, this is a good support article found over at the Xbox Support site to help you troubleshoot. Those of you who are still having issues with multiplayer should let us know in this thread so we can follow up.



That would be me. Have been trying since the mid-night launch with no luck. It finds the match, i join it, i'm in for anywhere ranging from 1 second to 45 seconds, then i'm dropped. I can see the player list load in, i can hear everyone chatting, i can get a nav point for the nearest event, ect. In every indication, I am in the game. But without fail, I will lose connection.

I read the support article you linked, NAT is open, couldn't find a IPsec setting in my belkin set-up page, but i did Disable/Enable UPnP, restarted router, hard rebooted console, ran network diagnostics and by all indications, I should be good to go.

I can chat, join parties and play MP in every title i've owned so far on XB1. But this has been a very disappointing experience. I don't care about the rewards and whatnot, i just want to play an online road trip. =/
Rank: Driver's Permit
#652 Posted : Friday, October 3, 2014 6:23:20 PM(UTC)
I got the cars and credits in my message center and when I accepted them the cars went into my garage but the 1.5 million credits disappeared. Tried restarting the game like what you said but nothing's there still.
Rank: D-Class Racing License
 2 users liked this post.
#653 Posted : Friday, October 3, 2014 6:40:21 PM(UTC)
Originally Posted by: JTeRms95x Go to Quoted Post
I got the cars and credits in my message center and when I accepted them the cars went into my garage but the 1.5 million credits disappeared. Tried restarting the game like what you said but nothing's there still.


Same for me.
Rank: Driver's Permit
#654 Posted : Friday, October 3, 2014 7:13:43 PM(UTC)
I am just sick of it I literally got nothing, no reward cars, no rewards money! Come on Turn 10 it is not like it is your first game!!!!!!!!! It is very upsetting to spend $90 and get part of the game!!!
Rank: Racing Permit
#655 Posted : Friday, October 3, 2014 7:14:31 PM(UTC)
Yay i finally got my gifts! :D
Rank: Driver's Permit
#656 Posted : Friday, October 3, 2014 7:44:25 PM(UTC)
Hey guys just reporting that I still haven't received credits or any of the cars. I redeemed a few days ago from the forza hub, im tier 7 so that's 2.1 mill I would love to have including the loyalty cars. On a really good note my vip has been working great since launch and I am really enjoying the game, up to lvl 92 so far. I see a handful have gotten their things so hopefully like many others I will receive my rewards/cars very soon!!
Rank: Driver's Permit
#657 Posted : Friday, October 3, 2014 7:44:49 PM(UTC)
Originally Posted by: HONUSDAN Go to Quoted Post
Originally Posted by: Genesis730 Go to Quoted Post
I have an issue. I created a design the other day and uploaded it to be shared. I wanted to make an adjustment to my car decals and when I go to edit, it tells me my own design is locked and will be erased if I try to edit it. My own design is locked and I can't do anything with it. Please fix!!! It shows I am the creator but cannot edit or change things once I leave the shop.


Did you try un-sharing it first?


I have tried unsharing it, even went to denture it but it says it'll delete my design off my car. Any ideas or do I need to start over? :( how can I possibly edit a design after creating or sharing it?
Rank: Driver's Permit
#658 Posted : Friday, October 3, 2014 7:47:13 PM(UTC)
I too am missing credits. I got the message, hit download, but they never appeared and the message is gone. Restarting didn't bring it back.
Rank: Driver's Permit
#659 Posted : Friday, October 3, 2014 7:49:10 PM(UTC)
Still waiting on gifts and cars here - hopefully my number will come up soon. Drive on!
Rank: Driver's License
#660 Posted : Friday, October 3, 2014 7:50:58 PM(UTC)
I haven't received my cars/credit rewards either. I redeemed the rewards from the Forza hub as soon as I got the game, that was 2 days ago.

Oh well guess I'll just have to keep waiting.
Rank: Driver's Permit
#661 Posted : Friday, October 3, 2014 7:54:24 PM(UTC)
Still waiting on my credits and cars as well. Hope it gets sorted soon.
Rank: B-Class Racing License
#662 Posted : Friday, October 3, 2014 7:58:04 PM(UTC)
Originally Posted by: johndandison Go to Quoted Post
I too am missing credits. I got the message, hit download, but they never appeared and the message is gone. Restarting didn't bring it back.
Did you try a hard-reset? Holding the xbox logo on the Xbox One until it turns off (around 5 seconds)

Rank: Racing Permit
 1 user liked this post.
#663 Posted : Friday, October 3, 2014 8:50:21 PM(UTC)
Originally Posted by: JetStarkiller Go to Quoted Post
I am just sick of it I literally got nothing, no reward cars, no rewards money! Come on Turn 10 it is not like it is your first game!!!!!!!!! It is very upsetting to spend $90 and get part of the game!!!


Play the damn game and stop whinging
Rank: Driver's Permit
#664 Posted : Friday, October 3, 2014 8:50:30 PM(UTC)
*Fixed* my missing VIP issue. Realised that it was only enabled for the xblive account that bought the game. Not my own account that I use to play the game. Even though it's the same home console. Sure it's not supposed to work that way.. but anyhoo. Just shelled out another $13 for VIP on my other account. All is now good. Sure they'll fix it eventually but I can't be bothered waiting.
Rank: Driver's Permit
#665 Posted : Friday, October 3, 2014 8:57:23 PM(UTC)
Im having an issue with the rewards. Per the frza hub, it says that I have recieved 2 payments of 1million but ive only gotten one payment in game ....comments ? Help ? I have recieved a few cars and some smaller cr payments but im still missing a million ....im not tryi g 2 be impatient, just an fyi.
Rank: Driver's Permit
#666 Posted : Friday, October 3, 2014 9:02:44 PM(UTC)
Originally Posted by: RescueDog Go to Quoted Post
Originally Posted by: JTeRms95x Go to Quoted Post
I got the cars and credits in my message center and when I accepted them the cars went into my garage but the 1.5 million credits disappeared. Tried restarting the game like what you said but nothing's there still.


Same for me.


Same thing for me as well. I was able to download 2 cars. The viper failed and the 1 million credits failed. Both disappeared from my messages and nothing was added to my balance or garage. Tried quitting the game and a hard restart nothing made the messages return.

Edited by user Friday, October 3, 2014 9:08:10 PM(UTC)  | Reason: Not specified

Rank: Driver's License
#667 Posted : Friday, October 3, 2014 9:02:47 PM(UTC)
I can also confirm that I redeemed my rewards on Wednesday (1.25 mil) and still no messages or anything hinting at me getting the credits in game. Hope this gets resolved soon, it's very frustrating to shell out over 80 dollars for a game and have this many issues..Still a good game non the less.
Rank: Racing Permit
#668 Posted : Friday, October 3, 2014 9:31:52 PM(UTC)
Well, got my money and all the cars
Thanks turn 10,
Good luck everyone!
Rank: Racing Permit
#669 Posted : Friday, October 3, 2014 9:32:45 PM(UTC)
They have fixed the rewards issue, and rolled them out as they said. I recieved my cars tonight and my 1.5 million horizon 2 creds with no issue on redeeming anything !!!!!
Rank: Driver's Permit
#670 Posted : Friday, October 3, 2014 9:57:20 PM(UTC)
Originally Posted by: H0VA v2 Go to Quoted Post
They have fixed the rewards issue, and rolled them out as they said. I recieved my cars tonight and my 1.5 million horizon 2 creds with no issue on redeeming anything !!!!!


No they have not, because I have not received a damn thing and it's been 4 days. No credits, no cars, and most intriguing of all not even a single message regarding them. I, starting to think I'll never get them, it's a good game but I was promised something when I bought it. That's called a bill of goods.
Rank: On the Podium
#671 Posted : Friday, October 3, 2014 10:06:42 PM(UTC)
I got my rewards today , I just got home from work, fired up the game and there they were, thank you guys! :D

Verrückter Schakal | ­ ­ The Höllenhund
Rank: A-Class Racing License
 1 user liked this post.
#672 Posted : Friday, October 3, 2014 10:13:19 PM(UTC)
Just received all of the rewards I was supposed to get! Thanks Turn 10 for fixing this issue!
It's kind of funny that the same thing happened in Horizon 1 when it first came out.

Edited by user Friday, October 3, 2014 10:21:01 PM(UTC)  | Reason: Not specified

LCE VIP: FM3, FM4, FH, FM5


FM6 Designs | FH3 Designs | FM7 Designs
Rank: Driver's Permit
#673 Posted : Friday, October 3, 2014 10:21:02 PM(UTC)
Got mine, thanks I am relieved though it took longer than turn 10 made it sound like it would.
Rank: Racing Permit
#674 Posted : Friday, October 3, 2014 10:30:27 PM(UTC)
Still got no VIP, no Money, and no cars!

Edit: Just seen a comment slightly above, i have played Forza for X amount of years/hours i have my brother who bought the game this time round, but i bought Forza 5 and he had VIP, though he had to buy the cars as they were not free. I budged in for the Ultimate edition, if not he would have bought the normal edition! Still waiting on VIP. Can someone clarify on this?

Edited by user Friday, October 3, 2014 10:36:01 PM(UTC)  | Reason: Not specified

Rank: A-Class Racing License
#675 Posted : Friday, October 3, 2014 10:31:17 PM(UTC)
Does anyone know if the dev team has heard about the audio issues that some of us are experiencing? I've heard nothing from any official source that this is being looked into.
78 Pages<<2526272829>>PrevNext

Notification

Icon
Error