Rank: Driver's Permit
#1 Posted : Friday, January 15, 2021 7:07:16 AM(UTC)
I recently upgraded my PC with a clean Windows 10 Pro install. Forza Horizon 4 works fine, but Forza Motorsport 7 freezes whenever I enter the Video Settings or Messages tabs.
I noticed that the resolution is set to 4k (3840 x 2160) although my gaming monitor only supports 1440p (2560 x 1440). Since the game freezes, I can not change any of these video settings. Still, you can enter races and everything run smooth. Is there a config file you can edit manually? Or what could cause this freezing?

I've disabled Xbox, Captures, Game Mode, etc. in Windows Settings.

Running on MSI MEG Z490 Ace with an Intel Core i9 10900K
64 GB RAM
Gigabyte GeForce RTX 3080 OC
Xbox Series X controller
Windows 10 Pro
nVidia 461.09 Drivers (2021.01.07)
Rank: Driver's Permit
#2 Posted : Wednesday, February 10, 2021 3:27:57 PM(UTC)
I have the same problem as of today, Feb. 10th 2021. I noticed a Windows 10 update yesterday... sigh.

Have you found a solution to this problem? It's odd and I've tried lots of things that haven't worked.

TY
Rank: Driver's Permit
#3 Posted : Thursday, February 11, 2021 3:21:47 AM(UTC)
Completely reinstalling the game worked for me and the game is working 100%!

Yes the 100GB download wasn't fun but it happens.

Rank: Driver's Permit
#4 Posted : Tuesday, April 20, 2021 4:11:20 PM(UTC)
This happened to me, and I found a better solution than reinstalling the entire game.

Go to my pc (formerly my computer) > uninstall or change a program > Forza Motorsport 7 > Advanced Options > Reset

Give it some time to remove your temporary data, and relaunch the game. Should be fixed!
Rank: Driver's Permit
#5 Posted : Wednesday, May 5, 2021 8:31:06 AM(UTC)
I too just installed the game today and tried all of the above. Nothing working. Also when playing career mode. When finished the first few races and then you pick a car. It then locks up there.
Rank: D-Class Racing License
#6 Posted : Saturday, May 15, 2021 4:57:56 PM(UTC)
T10 insists on setting video options to default every time they release a micro-update, which is annoying enough. But when I goto video settings to fix this ineptitude, it soft locks and can't do anything other than exit the game.

Bravo
Rank: Driver's Permit
#7 Posted : Monday, May 17, 2021 12:23:12 AM(UTC)
I might have figured out a workaround that works at least for me:



start FM7 and as soon as the window goes black for loading, click on any other window to defocus FM7

once the loading is done and the splash screen appears (the one with the background rain) click somewhere into the FM7 window



I can not explain from a technical view why this should change anything, but for me it works

Edited by user Monday, May 17, 2021 12:23:54 AM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#8 Posted : Sunday, June 6, 2021 8:32:47 AM(UTC)
First time user, I have the same issue, and reset the app which work the first time then subsequent startups face the same issue.
Rank: Driver's Permit
#9 Posted : Wednesday, June 9, 2021 4:48:15 PM(UTC)
Yes,it's pretty much unplayable on PC.

Stutters all the time,no matter what settings.

I am about to uninstall and save my hd 100 gigabytes.

I tried the rest option too,it worked great first time but when launching the game again,it went back to it's old habits.

Thinking it might be an Nvidia driver issue but I have been told that you should always update t o the latest driverfor the fastest experience.

I don't know also whether to vsync or no vsync.

I have a gsync monitor so usually leave it off.

A bit of a drag because when working,the game is amazing.
Rank: Driver's Permit
#10 Posted : Sunday, June 20, 2021 3:10:16 PM(UTC)
I got the stuttering fixed for good and it aint the Nvidia drivers,I am using the latest drivers.

I don't even know what fixed it but I

Changed my Power settings to High Performance.
Removed Synapse ,A Razer software that hangs in the background.
I removed anything in Task Manager that started up with the PC that I did not need.

I removed a bunch of stuff,I saw the Chrome Browser leaves alot of stuff in the background,so I uninstalled Chrome from my PC.

Anything that starts up in Task Manager and sits in your tray at the bottom right of the screen,think about uninstalling those.

I had Gog Galaxy and EA stuff starting up in the background.

In the Game,I set the res to my native monitor res and I have Unlocked (vsync) set.

Before ,I was getting an average frame rate of 90 but it fluctuated between 90 and 50 and 110 and stutters galore.
Now,I am getting frames from 99.5 to 100,butter smooth.

I never changed my Cpu cores or went back to older drivers.

I wish i knew what setting fixed it lol.

I also have 4 sticks of ram in my PC ,so I bumped up the voltage from 1.36 to 1.37 up .2 from rated voltage in the bios.

I also bumped my SOC Voltage up by 0.05. from 1.01 to 1.06.

i was amazed when the game finally run as it should.

Try setting your power to High Performance and see if that works.

I reckon it may have been the Chrome Browser.

I know my Synapse software was flaky.

But look at anything running at start up in task manager,be careful not to remove anything required by Windows 10.






Notification

Icon
Error