Rank: Driver's Permit
#1 Posted : Monday, January 18, 2021 3:11:35 PM(UTC)
I just downloaded forza 7 for windows 10. i am trying to get my wheel to bind with the settings. i have a T150 which works with all other racing games. i have tried to set up the bindings and everytime i click on a binding it auto saves to something i didnt set and then it automatically changes the input to something other than thrustmaster T150. when i first downloaded the game i was able to briefly save the bindings. then when i went to play nothing worked correctly. the only things that worked were the steering, gas and break, as well as the shifting but no clutch or any other settings worked. i am at a loss. if any of this doesn't make sense then please ask me to elaborate. Has this happened to anyone else? any help would be greatly appreciated.

Edited by user Wednesday, January 20, 2021 9:25:18 AM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#2 Posted : Saturday, January 23, 2021 11:42:29 PM(UTC)
umm. check and see if you have anything else connected to your pc.. try disconnecting any usbs not needed.. if that doesnt work. try grabbing forza emuwheel.. but id make a video toss it up on youtube. and link to it so we can see only issue i have wit contoller on pc forza motorsport 7 is it feels like steering from left to right or right to left while drifting is incredibly slow causing for weird handling. but not sure if thats normal/
Rank: Driver's Permit
#3 Posted : Tuesday, January 26, 2021 3:19:53 PM(UTC)
thank you i'll try that. i was also thinking that maybe its because im using a Play station made wheel. it works on all other games i play though with out issues. i'll let you know if it works i'll post back soon.