Rank: Driver's Permit
#1 Posted : Wednesday, July 29, 2020 3:05:37 PM(UTC)
I just bought Forza Horizon 4 and I'm loving it but around an hour or so of playing it it starts to lag really bad no matter what setting i use it just lags, my specs are, i7 9700, RTX 2070 Super, and 32 gigs of ram. I'm pretty sure those specs are just fine for Forza is there any way to fix this please and thank you
Rank: Driver's Permit
#2 Posted : Sunday, October 11, 2020 10:31:38 PM(UTC)
Hello, I bought a new Xbox game pass and downloaded Forza Horizon 4. After a few races, I realized some serious lag. Lag makes the game unplayable when I press a or d ıt shown on my screen like 1 or 2 seconds later. How can I solve this problem?

My System:
Gtz 1060 3G
2x8g 2400 MHz ram
Intel i5 7600 overclocked to 3.9ghz
and a Sandisk M2 SSD.
Rank: Driver's Permit
#3 Posted : Thursday, October 15, 2020 2:09:15 PM(UTC)
Had this problem on my Xbox One X last night. Thought it was just poor traction in the snow or something but then I noticed the camera controls were doing it too. And then it started doing it in menus. Had to fully uninstall and reinstall today but it's working fine now.
Rank: S-Class Racing License
#4 Posted : Thursday, October 15, 2020 2:35:11 PM(UTC)
Originally Posted by: RakkSelim Go to Quoted Post
Hello, I bought a new Xbox game pass and downloaded Forza Horizon 4. After a few races, I realized some serious lag. Lag makes the game unplayable when I press a or d ıt shown on my screen like 1 or 2 seconds later. How can I solve this problem?

My System:
Gtz 1060 3G
2x8g 2400 MHz ram
Intel i5 7600 overclocked to 3.9ghz
and a Sandisk M2 SSD.


Not sure, but I would suspect that video RAM usage might be a problem with that card, 3GB is lower than ideal, even though I believe 2GB is quoted as the minimum, anything under 4GB is pushing it. This might have nothing to do with your issue but I would have a look at that just in case. The in-game benchmark is very comprehensive and will tell you VRAM usage, and the video settings has info on which things you can turn down or off to lower VRAM requirements.
Rank: Driver's Permit
#5 Posted : Saturday, October 17, 2020 4:22:38 AM(UTC)
Originally Posted by: koolkong94 Go to Quoted Post
Had this problem on my Xbox One X last night. Thought it was just poor traction in the snow or something but then I noticed the camera controls were doing it too. And then it started doing it in menus. Had to fully uninstall and reinstall today but it's working fine now.


I take it back, I noticed the reinstall had reset my graphics options to quality. I changed it back to performance and it was fine for that session but the next time I got on the game it was doing it again. Changed back to quality and it's been fine ever since. Just started doing this with the Series 28 update.
Rank: Driver's Permit
#6 Posted : Saturday, October 17, 2020 4:04:23 PM(UTC)
Hi.Somebody help me pls.I cant play forza horizon 4 online because i have incredible lag.I try everything changed isp, telephone cable , ethernet cable i cant solve this problem.Sometimes other players teleporting and sometimes my games slowing 2 second after speeding up.I have 100/8 internet speed.And i sharing now ping and speed test.


I have gtx 1060 6gb i5 7600 and 16gb ram and using 7200rpm hdd for games.


Link








Rank: A-Class Racing License
#7 Posted : Sunday, October 18, 2020 1:51:45 AM(UTC)
I would recommend to test your PC on a fiber internet connection to confirm it comes from your PC or not. You could also have a look at the posts about connection issues, I remember of some Toredo thing that may help you.
Goo luck
Rank: Driver's Permit
#8 Posted : Wednesday, November 18, 2020 3:25:10 AM(UTC)
Hi everyone,
I'm not the one that propably did this thread.
my problem is a fact that this game after 2 years got no fixes for memory holes and lag spikes.
"Just" random frametime spikes causing lag, very annoying, its okay to just reset the game but I feel disgusted with the game experience.
R5 3600x (not cpu problem, cpu is very decent)
b550 aurous pro (good mobo with great power section)
2060 gaming Z (decent gpu) drivers are 452.06 since nvidia is bad at doing compatible drivers, and i know ill get more issues when i update driver that supports ampere, same happened to COD Wazrone, less fps, more crashes ect.
32 GB DDR4 3000 8GB per 4 sticks (not memory-"too small capicity"- issue game uses 3,7-3,8 thousand MB compresed and uncompressed ram with 16 and 32 gigs of ram) max ram usage with chrome (youtube music) and discord is 10 Gigs.
750watt psu silentumpc supremo fm2 gold 80 and 550w supremo m2 gold 80 (this isnt a power issue)
page file is set a 30 Gigs on a ssd. (not a issue with a too small paging file size, and without it same thing appears)
Rank: S-Class Racing License
#9 Posted : Wednesday, November 18, 2020 4:31:13 AM(UTC)
This has been an issue in Forza Motorsport 7 at times (different developer) but I wasn't aware it was also an issue in FH4.
Rank: A-Class Racing License
#10 Posted : Wednesday, November 18, 2020 9:06:40 AM(UTC)
Originally Posted by: MATEO POPLAWSKI Go to Quoted Post
my problem is a fact that this game after 2 years got no fixes for memory holes and lag spikes.
"Just" random frametime spikes causing lag, very annoying, its okay to just reset the game but I feel disgusted with the game experience.
drivers are 452.06

I would try updating the graphics driver. I had this a problem a bit ago, and it was around the time of that driver version. I can't remember if that was the exact version, but the problem was fixed by updating to a newer graphics driver.
Rank: Driver's Permit
#11 Posted : Saturday, November 21, 2020 3:31:31 AM(UTC)
When i buy a new car, and i tune it for like 15 mins, and then go out to test it, i start lagging when above 160 km/h. This happens with every car i tuned for more then 15+ mins. After restart, everything goes back to normal. My specs are: i5 4690 (non K), EVGA GTX 970 SC (With +200 MHz memory- and +25 MHz core clock put on by manual as well), 12GB RAM. Also i noticed, when i started monitoring my usage, temp, etc, when i started lagging, and i spotted, that my GPU usage is jumping down to 0% and back to 65-75%. https://i.imgur.com/S20iGOO.png.
Rank: Driver's Permit
#12 Posted : Monday, November 23, 2020 11:58:06 PM(UTC)
Hello everyone,

I have exactly the same issue as Terkariki and others stated above.
Forza is running fine with NVIDIA recommended settings (GeForce Experience) with framerates around 100.
But all of a sudden the framerate goes down to 0 and after a second goes up again. Is this called a "spike"? This is weird since usually my PC seems to handle the game (and others) in WQHD fine.
This makes the game unplayable for me. This behaviour ist quite new, it did not appear one or two years ago.
I also asked via the official form, but so far no answer.

My PC specs:
Intel i5-4670k
MSI Geforce 1070 - 8 GB Ram
16 GB Ram
Game is on a SSD.

regards
gvn

Notification

Icon
Error