5 Pages<<345Prev
Rank: Driver's Permit
#101 Posted : Sunday, January 26, 2020 5:13:27 AM(UTC)
I am always getting dc when i am playing online races ,all the rest of the games i can play good ,but this one i cant lattelly in like 30 races i tryed to do i only finish like 2 events ,is kinda boring because i like this game
Rank: Driver's License
#102 Posted : Saturday, February 15, 2020 2:26:28 PM(UTC)
Has anyone managed to solve this problem? Here the same thing continues. Always disconnect in the middle of the races. Since updating this crappy Terminator.
Rank: D-Class Racing License
#103 Posted : Saturday, February 15, 2020 3:22:30 PM(UTC)
i notice last week pg. we won due to some how being hosted in the uk and are team was us. so the other team lag out.
Rank: Racing Permit
 2 users liked this post.
#104 Posted : Saturday, February 15, 2020 5:51:04 PM(UTC)
it's already normal for me to be disconnected ever since that .... update! but today I decided to play ffa ranked and at the last race of a CC event I got disconnected... this is the worst!!
Rank: Driver's License
#105 Posted : Wednesday, June 17, 2020 11:49:22 AM(UTC)
the online experience from horizon 4 is bad as possible!

every 2nd game im disconnect.. loading times like hell, etc....

Rank: A-Class Racing License
#106 Posted : Wednesday, June 17, 2020 12:53:12 PM(UTC)
Fix your connection, servers are OK.
Rank: Driver's License
#107 Posted : Thursday, June 18, 2020 1:11:30 AM(UTC)
Originally Posted by: turtleCZ Go to Quoted Post
Fix your connection, servers are OK.


my connection is fine!

yesterday i played 5 different mp games and not a single game disconnect me!
i play horizon 4 and search for online adventure and every 2nd search is a disonnect! streams i have running by the way are fine, no lag,.... nothing. only horizon 4 disconnect me!
Rank: A-Class Racing License
#108 Posted : Thursday, June 18, 2020 2:04:44 AM(UTC)
Originally Posted by: GlumpArt8625 Go to Quoted Post
Originally Posted by: turtleCZ Go to Quoted Post
Fix your connection, servers are OK.


my connection is fine!

yesterday i played 5 different mp games and not a single game disconnect me!
i play horizon 4 and search for online adventure and every 2nd search is a disonnect! streams i have running by the way are fine, no lag,.... nothing. only horizon 4 disconnect me!

Sure, but it works with a good connection. What is your NAT type on a console?
Rank: Driver's Permit
#109 Posted : Friday, June 19, 2020 12:06:19 PM(UTC)
I start to play eliminator but after 1 min the server disconnect every time
5 Pages<<345Prev

Notification

Icon
Error