This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
Rank: Driver's Permit
User is suspended until 5/29/2020 9:38:18 PM(UTC)
#1 Posted : Wednesday, May 20, 2020 5:55:53 PM(UTC)
So I'm running a pretty powerful system, MSI 2080ti gaming x trio, ryzen 7 2700x, 16gb ram, x470 mobo, windows 10 64bit pro, yet after about 30 minutes of play I get fps drops to down in the 30's. All of my other titles run buttery smooth yet this one dips really bad after a half an hour. I played with the settings and it even did it on low settings at 1080 exactly the same as 4k ultra..... Anyone figure out a workaround? Other than resetting the game that is....
Rank: Driver's Permit
#2 Posted : Friday, May 22, 2020 10:34:18 PM(UTC)
I just came to this Forum with the similar problem/question. Played Horizon 4 for weeks, months now and decided to try Horizon 3. I LOVE THE GAME, but just can't make it run smooth and stable like 4. My setup is 2080 Super, i7 8700k, 32gb RAM, SSD, etc. Horizon 4 runs perfectly! What can I do to make 3 run as good? When I start the game, It runs fine, but after 15-30 mins something clicks and stuttering begins. Wierd.

Edited by user Friday, May 22, 2020 10:35:02 PM(UTC)  | Reason: javascript:__doPostBack('forum$ctl03$PostReply','')

Rank: Driver's Permit
#3 Posted : Saturday, May 23, 2020 10:03:25 AM(UTC)
I’m having very similar problems and after trying every trick in the book I still can’t fix.

I gave an Intel Core i5 9400f, GTX 1660 and 16 GB of RAM.

Nothing is overheating and I don’t see any changes in MSI Afterburner between when the game was running smoothly and when it’s stuttering.

Notification

Icon
Error