Rank: Driver's Permit
#1 Posted : Tuesday, January 21, 2020 8:58:50 AM(UTC)
Hi, I'm playing FH4 on a Windows 10 pro 64 bits laptop. i5 8300h 16GB of RAM and GTX1050.
I have and SSD but it is small, so I just keep the OS and drivers there. So, the game is on a 1TB HD.

The RAM usage during game is not above 7,5/8GB, and I have double that amount.

Is the stuttering problem related to textures and getting data from the HD?

I get 85 FPS on 99% of the time but at 1% it drops to 30 FPS.

I checked and my drivers are UpToDate. Does anyone know a possible solution?
Rank: Moderator
#2 Posted : Tuesday, January 21, 2020 9:03:28 AM(UTC)
Originally Posted by: Nitro Glitter Go to Quoted Post
Hello everyone,

For Support, please visit https://support.forzamotorsport.net
Our current hours of operation are Monday - Friday from 6:00am-3:00pm PST / 9am-6pm EST
Posting in the Forums is not submitting a ticket.
Rank: Driver's Permit
#3 Posted : Tuesday, January 21, 2020 9:43:52 AM(UTC)
Originally Posted by: ManteoMax Go to Quoted Post
Originally Posted by: Nitro Glitter Go to Quoted Post
Hello everyone,

For Support, please visit https://support.forzamotorsport.net
Our current hours of operation are Monday - Friday from 6:00am-3:00pm PST / 9am-6pm EST
Posting in the Forums is not submitting a ticket.



According to the support page my hardware is better than recommended so I'd like to start a discussion about this. Probably someone else had the same issue.
Rank: Moderator
#4 Posted : Tuesday, January 21, 2020 10:22:58 AM(UTC)
If you have not already done so, submit a ticket at the site so the community support team can investigate. They'll have the best insight into what's going on.
Rank: S-Class Racing License
#5 Posted : Tuesday, January 21, 2020 10:48:39 AM(UTC)
Originally Posted by: PedroAguiarBRA Go to Quoted Post

Is the stuttering problem related to textures and getting data from the HD?



I would open task manager, performance tab, select the HDD the game is installed on and see if it spikes to 100% in the graph. You could have task manager running in the background and then alt-tab afterwards, or you could run the game in a window side-by-side, whichever. But it should answer your question.

Do you get any stutter count running the in-game benchmark? Does lowering settings help?
Rank: A-Class Racing License
#6 Posted : Tuesday, January 21, 2020 1:18:18 PM(UTC)
I've found that

a) getting a freesync monitor helped with stuttering

b) settings that give a higher frame rate don't necessarily reduce stuttering, I can have settings that give me around 110fps that stutter worse than settings that give around 70fps. So try changing individual settings one at a time to see if you can figure out what makes it worse.

The only drive in my PC is a SSD and I still get some stuttering. It seems to often happen in the same place on a track, so it might be due to some swapping of data somewhere. My graphics card only has 4GB VRAM, which probably doesn't help, as most more recent cards have 8GB, and it stands to reason that the less VRAM, the more likely it is that data will need swapping in and out of the VRAM.
Rank: S-Class Racing License
#7 Posted : Tuesday, January 21, 2020 1:43:42 PM(UTC)
4GB is adequate to play without any stuttering, depending on what settings you use of course. I had a GTX 1050 Ti (desktop) 4GB previously and the game ran great with that.

I'm currently using a 6GB card and running with everything maxed (ie. beyond ultra) and there is never any stuttering when locked to 60Hz vsync. I have Windows on SSD and the game on another SSD.

Basically the game does run superbly if your machine is up to it, and it scales down to more modest hardware too, like the 1050. So the OP's specs should be fine, depending on how cut down the mobile 1050 is anyway, I'm not sure.
Rank: A-Class Racing License
#8 Posted : Tuesday, January 21, 2020 2:27:43 PM(UTC)
Hmm, my card is an old R9 290, which seems to be a fair bit faster than a 1050 Ti from looking up some benchmarks. But as I said, I actually get more stuttering when it's running at higher framerates, so it's not really the ability to deliver framerate that's the issue. E.g. if I go to 8x MSAA, it lowers the framerate quite a bit, but seems to eliminate stuttering. But wanting to get 120+fps was a reason why I started playing on a PC, so I don't really want to lock it to 60fps.
Rank: S-Class Racing License
#9 Posted : Tuesday, January 21, 2020 2:30:45 PM(UTC)
My impression is there is something about the game engine which makes it run perfectly at 60fps, as you say, regardless of how fast your PC is. Probably a legacy of being designed for consoles.
Rank: A-Class Racing License
#10 Posted : Monday, February 10, 2020 10:52:46 AM(UTC)
I bought a new graphics card, a 5700 XT, and my stuttering is gone. With my old R9 290, even when it was delivering over 100fps basically all the time, there were still noticeable brief pauses. With the 5700 XT, not only am I getting 130fps or so at 1080p with all quality settings maxed out (not the Ultra preset, that doesn't max everything out, I mean going through each individual setting and maxing it out), but there are none of those brief pauses. So a graphics card can certainly be a cause of stuttering, even if it appears to be giving a comfortably high frame rate. Maybe the drivers just aren't well optimised for such an old card any more.

Notification

Icon
Error