28 Pages12345>>PrevNext
Rank: Driver's Permit
#51 Posted : Friday, December 27, 2019 2:16:58 PM(UTC)
Found this thread on Microsoft Answers today. Looks like a bunch of people have been reporting the issue and apparently those that have been in touch with MS support say that they are aware and are working on a fix.

Seems like it's a licencing issue, something about the ultimate edition doesn't get on well with the MS store. Someone else also posted a reported fix for their copy today (the 27th) on the last page as well. I personally wouldn't recommend following the steps because they are quite drastic and carry the potential of borking your MS Store and built in apps. Involves taking control of the WindowsApps folder, manually deleting anything to do with the game, and doing the same for the registry too.

Here's the thread:
https://answers.microsof...-1d6f1c00bcea&page=4


If anyone does go through with that drastic solution, report back with results and hopefully it'll shed some light on the issue for both us and the devs/MS!
Rank: R-Class Racing License
 1 user liked this post.
#52 Posted : Friday, December 27, 2019 4:45:54 PM(UTC)
Sounds like those of us who didn't get the ultimate edition dodged a bullet then.

Reading that thread I am struck by the typically pathetic response of the Microsoft 'experts' who seem to be working from a script and work on the assumption that the problem must be with your computer rather than there being any flaw with the notoriously flaky Microsoft Store.
Rank: Driver's Permit
#53 Posted : Saturday, December 28, 2019 4:19:12 AM(UTC)
No wonder, especially now they're starting to put new MS games on Steam. The dismissal of the issue is exactly why I started collecting every thread with the same issue I could find, I even mentioned in my Forza support ticket that the game worked perfectly fine UNTIL I picked up the ultimate add-ons in the Cyber Monday sale.

I would appreciate some more communication on the issue, either from MS or the devs, I can't believe I had to go digging to find that thread to even know that they were aware of the issue and looking into it. I understand they probably see this issue a lot but surely they should have started to look into things when multiple reports of the same issue with the add-ons started coming in.

I understand it's a bad time of year and we probably won't see a fix until 2020, but even an quick official announcement acknowledging the issue would go a long way.

Here's my collection of threads reporting the exact same issue for what it's worth:
https://www.reddit.com/r...e7l8h2/crash_on_startup/
https://www.reddit.com/r...pc_after_installing_dlc/
https://www.reddit.com/r...ing_during_game_startup/
https://www.reddit.com/r...4_game_pass_pc_problems/

https://forums.forzamoto...game-can-t-open-now.aspx (taken down, merged with this thread: https://forums.forzamoto...upport-site-article.aspx)
https://forums.forzamoto...to-ultimate-add-ons.aspx
https://forums.forzamoto...--Windows-10---1809.aspx

Rank: Driver's Permit
#54 Posted : Saturday, December 28, 2019 11:28:02 AM(UTC)
After one minute of waiting, Forza is closing. Can someone help me?

PROBLEM
Stopped responding and was closed

Package Full Name: Microsoft.SunriseBaseGame_1.380.112.2_x64__8wekyb3d8bbwe
Application Name: praid:SunriseReleaseFinal
Application Version: 0.0.0.0
Application Timestamp: 00000000
Hang Signature: 07c1
Hang Type: 4194304
Wersja systemu operacyjnego: 10.0.18363.2.0.0.768.101
Identyfikator ustawień regionalnych: 1045
Additional Hang Signature 1: 07c119e4c87ab1d6b6b9dbf735e96c51
Additional Hang Signature 2: 9e26
Additional Hang Signature 3: 9e2619dadd6783872843101b82925b0a
Additional Hang Signature 4: 07c1
Additional Hang Signature 5: 07c119e4c87ab1d6b6b9dbf735e96c51
Additional Hang Signature 6: 9e26
Additional Hang Signature 7: 9e2619dadd6783872843101b82925b0a
Rank: Racing Permit
#55 Posted : Saturday, December 28, 2019 2:59:19 PM(UTC)
Wouldn't surprise me if it's connected to the infinite loading/syncing issue:
https://forums.forzamoto...Loading-on-start-up.aspx
Rank: Driver's Permit
#56 Posted : Saturday, December 28, 2019 3:16:51 PM(UTC)
Are you running the Ultimate Edition? If so you're in the same boat as us and will have to wait for an official fix.

If not, follow the steps in on the support page, some of the threads I found had their issues solved by at least one of the recommended fixes: https://support.forzamot...ing-or-is-Crashing-on-PC

The most common fix I saw was turning off any overlay software if you have it, particularly GPU monitoring/tweaking software like Logitech G Hub, MSI Afterburner / Riva Tuner Statistics Server or
EVGA Precision. there's a full list of software known to interfere with the game in that article too
Rank: Driver's Permit
 2 users liked this post.
#57 Posted : Monday, December 30, 2019 8:05:42 AM(UTC)
More confirmations from the MS Answers thread that deleting the registry keys and reinstalling works on page 6: https://answers.microsof...-1d6f1c00bcea&page=6

Seems that it did break a thing or two and they might've had to do a repair install or something along those lines (EDIT: They clarified, it was just a Startup Repair. Also they re-downloaded the add-ons and they work). Something I'd like to point out that's mentioned in that thread is this playing hot potato with the issue; MS saying it's a Forza issue and vice-versa. We have clear evidence now that it's the MS store that's causing this by doing something to the registry keys.

Once again I am incredibly disappointed at the lack of acknowledgement by either party that this is an issue (and more to the point IF there will be a fix from either). I know it's the holiday season and all but come on.

Edited by user Monday, December 30, 2019 2:31:46 PM(UTC)  | Reason: MS Answers thread updated. added extra info

Rank: Driver's Permit
#58 Posted : Tuesday, December 31, 2019 1:19:05 AM(UTC)
Had crash issues on one of my 3 computers. It's running gtx 1060, 8 GB ram. Was able to play for a bit then it quits to Windows. When trying to start up the game again it shuts down on intro screen. Had this problem for 4-5 days. Tried EVERYTHING suggested on the forums: Kill explorer, disable XMP, kill all background apps, allow mic, power shell solution, and so on. Nothing worked. Decided to try one last approach, reinstall. Did a completely fresh install of Windows. Did not update Windows. No install of new drivers for GPU. Installed the game using Microsoft store (did not launch xbox pass app). Then installed the wheel. Fired up the game. No crash and over 10 hours continues play since reinstall. Don't know what makes the game crash, but would recommend doing a fresh install of Windows and the game without updating either Windows or the GPU.

PS!
Noticed a spike to 100% GPU usage when the game used to quit. After that the computer acted funny until I restarted.

Rank: Driver's Permit
 1 user liked this post.
#59 Posted : Tuesday, December 31, 2019 6:35:48 AM(UTC)
I saw a bunch of people recommend that in various threads. Seems to be the go-to for any Windows 10 issues is to flatten it and start over. But with all due respect I am not completely re-installing my operating system for one game and one issue, and no-one else with the issue should be expected to either.

I'm completely baffled that they allowed this to happen on a first party title, let alone one they are actively using to promote the game pass! This is on Microsoft's head to fix and I will continue to post here until it is.

Edited by user Tuesday, December 31, 2019 3:14:15 PM(UTC)  | Reason: Formatting

Rank: Driver's Permit
#60 Posted : Wednesday, January 1, 2020 1:17:11 AM(UTC)
Hey guys, my Forza Horizon 4 on Windows 10 won't launch, when I launch the game the splashscreen comes up and it is there for around a minute, and then my cursor goes into loading icon, then the game closes itself. Tried uninstalling the game, resetting the store and Forza, nothing worked. It has been like this for 2 weeks. Yesterday, I did a clean Windows install and game was working, however, when I try to launch the game today, it is the same problem again. Went through all the solutions posted online but could not fix the problem. Anybody knows how to fix this annoying problem? Thank you for the help.
Rank: Driver's Permit
#61 Posted : Wednesday, January 1, 2020 12:17:14 PM(UTC)
I have exactly the same problem
Quote:
A problem caused this program to stop interacting with Windows.
Faulting application path: D:\WindowsApps\Microsoft.SunriseBaseGame_1.351.461.2_x64__8wekyb3d8bbwe\ForzaHorizon4.exe
Problem Event Name: MoAppHang
Hang type: Activation

I tried ALL the ways from this article. Moreover, I read all the tickets on the Microsoft website, which give only general recommendations, but none of this helped. Reinstalling Windows is NOT an option to solve the problem.
I managed to solve the problem without reinstalling windows:
1. deleted the game
2. deleted the WindowsApps folder
3. dropped the windows store
4. using the registry editor, deleted ALL that relates to the game
5. restarted the computer
6. installed the game
7. it works!

The key factor is to remove all game references from the registry.
Rank: D-Class Racing License
#62 Posted : Wednesday, January 1, 2020 11:15:21 PM(UTC)
Originally Posted by: system1024 Go to Quoted Post
I have exactly the same problem
Quote:
A problem caused this program to stop interacting with Windows.
Faulting application path: D:\WindowsApps\Microsoft.SunriseBaseGame_1.351.461.2_x64__8wekyb3d8bbwe\ForzaHorizon4.exe
Problem Event Name: MoAppHang
Hang type: Activation

I tried ALL the ways from this article. Moreover, I read all the tickets on the Microsoft website, which give only general recommendations, but none of this helped. Reinstalling Windows is NOT an option to solve the problem.
I managed to solve the problem without reinstalling windows:
1. deleted the game
2. deleted the WindowsApps folder
3. dropped the windows store
4. using the registry editor, deleted ALL that relates to the game
5. restarted the computer
6. installed the game
7. it works!

The key factor is to remove all game references from the registry.

If this does work then simply un/reinstalling the game should work.

Or maybe it would actually work without you even doing anything... for actually there's something else at work:
Originally Posted by: FlashyClamp5213 Go to Quoted Post
Originally Posted by: SmithyMC5135 Go to Quoted Post
...

Hang type: Activation

...

Activation (license check) requires a valid connection to the server.

If it fails, either the request failed to reach the server, or the server determined that request invalid.
Rank: Driver's Permit
#63 Posted : Wednesday, January 1, 2020 11:34:31 PM(UTC)
Originally Posted by: FlashyClamp5213 Go to Quoted Post
Originally Posted by: system1024 Go to Quoted Post
I have exactly the same problem
Quote:
A problem caused this program to stop interacting with Windows.
Faulting application path: D:\WindowsApps\Microsoft.SunriseBaseGame_1.351.461.2_x64__8wekyb3d8bbwe\ForzaHorizon4.exe
Problem Event Name: MoAppHang
Hang type: Activation

I tried ALL the ways from this article. Moreover, I read all the tickets on the Microsoft website, which give only general recommendations, but none of this helped. Reinstalling Windows is NOT an option to solve the problem.
I managed to solve the problem without reinstalling windows:
1. deleted the game
2. deleted the WindowsApps folder
3. dropped the windows store
4. using the registry editor, deleted ALL that relates to the game
5. restarted the computer
6. installed the game
7. it works!

The key factor is to remove all game references from the registry.

If this does work then simply un/reinstalling the game should work.

Or maybe it would actually work without you even doing anything... for actually there's something else at work:
Originally Posted by: FlashyClamp5213 Go to Quoted Post
Originally Posted by: SmithyMC5135 Go to Quoted Post
...

Hang type: Activation

...

Activation (license check) requires a valid connection to the server.

If it fails, either the request failed to reach the server, or the server determined that request invalid.


Nope, it's doesn't, only full registry cleaning helps
Rank: Driver's Permit
#64 Posted : Thursday, January 2, 2020 7:56:13 AM(UTC)
Had Horizon 4 since launch date on xbox one, played many many hours. A few months ago it started playing up big time, originally I thought it was Red Dead 2 causing it to run super slow, uninstalled everything on the xbox bar forza and it's still the same. Tried hard resetting, tried factory reset, tried uninstalling and installing again. Nothing, just refusing to launch, it gets the senna loading screen, but then crashes. Cant remove the disc, cant go back to home, cant even get to the xbox menu when the X is pressed on the controller. Is there any other solution to this???????

[Mod Edit - thread merged, please go through Forza Support - MM]

Edited by user Thursday, January 2, 2020 8:01:54 AM(UTC)  | Reason: Not specified

Rank: B-Class Racing License
#65 Posted: : Thursday, January 2, 2020 8:57:04 AM(UTC)
I had Horizon 4 Ultimate Edition since launch date on XB1X and played around 350 hours on it. A few days ago, just before Christmas (Season 17 went live I think) it started playing up with refusing to load and then going back to the Home Page saying it took too long to load.

I have uninstalled everything on the XB1X to do with Forza Horizon 4 and it's still the same. Have tried hard resetting, tried factory reset, tried uninstalling and installing again.

Nothing, just refusing to launch, it gets the Senna loading screen, but then crashes. Repeat about 6 times with some luck!

Can only go back to the Home screen and repeat the shut downs and then if I persevere it will work.

Is there solution/work around to this on an XB1X in the UK or have I got to wait and suffer for an update from Microsoft/PGG???????

Edited by user Thursday, January 2, 2020 12:31:21 PM(UTC)  | Reason: Not specified

Rank: Driver's License
#66 Posted : Thursday, January 2, 2020 11:56:00 AM(UTC)
On my XBox One X I see this happen if I am logged into only one of the two different profiles I have on the console. If I just switch to the main profile instead of logging out of the other one it launches. That is about the only problem with ANY game I have run into with my Xbox One X and I own over 168 games. My PC Gaming headaches are long gone for years now. Never going back to that PC garbage and all the expenses of new video cards and CPU's every year.


Originally Posted by: Sh1kuren Go to Quoted Post
Hello!

Does anyone have a same problem?

The few days ago i purchased Ultimate Edition via Microsoft Store. When i launch the game, it's open default logo window, waiting a few seconds and closing. A few months ago i played with Xbox Game Pass, it was Standard Edition. It's worked fine.

So, i tried download Forza Horizon 4 Demo and it's works fine. My games installed on Disk D, because Disk C is SSD with small size. I tried to reinstall the game, but nothing helped.

What I tried to do for these 2 days:

Reinstall the game
Install Standard Edition (w/o DLC)
Reset the Microsoft Store
Reset the game
Log in Local Windows Account
Log in Microsoft Account
Windows Mem Test
Reinstall Nvidia Driver
Turn off Mic
DISM /Online /Cleanup-Image /RestoreHealth
sfc /sсannow
Read to https://support.forzamotorsport.net/hc/en-us/articles/360007593074-My-Game-is-Not-Launching-or-is-Crashing-on-PC

I looked to Windows Events Log, and what it says:

A problem caused this program to stop interacting with Windows.
Faulting application path: D:\WindowsApps\Microsoft.SunriseBaseGame_1.351.461.2_x64__8wekyb3d8bbwe\ForzaHorizon4.exe

Problem Event Name: MoAppHang
Package Full Name: Microsoft.SunriseBaseGame_1.351.461.2_x64__8wekyb3d8bbwe
Application Name: praid:SunriseReleaseFinal
Application Version: 0.0.0.0
Application Timestamp: 00000000
Hang Signature: 07c1
Hang Type: 4194304
OS Version: 10.0.17763.2.0.0.768.101
Locale ID: 1049
Additional Hang Signature 1: 07c119e4c87ab1d6b6b9dbf735e96c51
Additional Hang Signature 2: 39f4
Additional Hang Signature 3: 39f4f0799772d47f143f209a3b6ad067
Additional Hang Signature 4: 07c1
Additional Hang Signature 5: 07c119e4c87ab1d6b6b9dbf735e96c51
Additional Hang Signature 6: 39f4
Additional Hang Signature 7: 39f4f0799772d47f143f209a3b6ad067

The program ForzaHorizon4.exe version 0.0.0.0 stopped interacting with Windows and was closed.
To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.
Process ID: 10a8
Start Time: 01d579e91a1fd816
Termination Time: 4294967295
Application Path: D:\WindowsApps\Microsoft.SunriseBaseGame_1.351.461.2_x648wekyb3d8bbwe\ForzaHorizon4.exe
Report Id: 0fda27bf-9dc7-4525-9f9b-baf6a97f3c49
Faulting package full name: Microsoft.SunriseBaseGame_1.351.461.2_x648wekyb3d8bbwe
Faulting package-relative application ID: SunriseReleaseFinal
Hang type: Activation

PC Specs:

CPU: i7 3770 @ 3.4Ghz
MB: Asus P8H61 R 2.0
RAM: DDR3 1600 Mhz (16Gb)
GPU: Asus Strix Gaming GTX 950 (2Gb)
SSD: GIGABYTE (120GB) - OS
HDD: Western Digital WD10EZEX - Games
Power Supply: Thermaltake TR2 S 500W
OS: Win 10 / 1809
Nvidia Driver: 436.48

P.S. I don't have MSI Afterburner / Riva Tuner, and yeah, i create the ticket a few hours ago.


Rank: Driver's License
#67 Posted : Thursday, January 2, 2020 11:59:38 AM(UTC)
I just posted about this. It has to do with your XBox Profiles. If you set up Home XBox Owners so you can share the game on 2 separate XBoxes, just make sure you sign into the other profile (The one you use for playing your Forza H4 game, and let the other profile remain logged in so they are both active. It will launch then. Took me a couple of weeks to solve the exact same problem, but launches every time now as long as both profiles are signed in. Enjoy!



Originally Posted by: Berniev666 Go to Quoted Post
I had Horizon 4 Ultimate Edition since launch date on XB1X and played around 350 hours on it. A few days ago, just before Christmas (Season 17 went live I think) it started playing up with refusing to load and then going back to the Home Page saying it took too long to load.

I have uninstalled everything on the XB1X to do with Forza Horizon 4 and it's still the same. Tried have tried hard resetting, tried factory reset, tried uninstalling and installing again.

Nothing, just refusing to launch, it gets the Senna loading screen, but then crashes. Repeat about 6 times with some luck!

Can only go back to the Home screen and repeat the shut downs and then if I persevere it will work.

Is there solution/work around to this on an XB1X in the UK or have I got to wait and suffer for an update from Microsoft/PGG???????


Rank: B-Class Racing License
#68 Posted : Thursday, January 2, 2020 12:36:19 PM(UTC)
I have sold my XB1 Day One Edition recently and so have only, and have ever had, one Game Profile now on ONE XB1X on which I have always played FH4.
Any idea how I sign in in the way that you do Dirtona?
Rank: Driver's License
#69 Posted : Thursday, January 2, 2020 1:42:33 PM(UTC)
Originally Posted by: Berniev666 Go to Quoted Post
I have sold my XB1 Day One Edition recently and so have only, and have ever had, one Game Profile now on ONE XB1X on which I have always played FH4.
Any idea how I sign in in the way that you do Dirtona?


If you only have one profile and no others I have no idea what it will take to fix this. What is crazy is I never play FH4 with my other profile, because it is mainly used for co-op shooters (Private games in my house) but the game a few months ago started with the "Took too long to load" error and just by accident I still had my guest profile logged in and the game launched. Without that guest profile running along side of my main Gamertag profile I can NEVER launch the game successfully. This only happens with Horizon 4 too. Horizon 2, Forza Motorsport 6 & 7 load with just my main profile logged in. So its not the Turn 10 servers. Its definitely a recent bug they introduced.

The configuration I use is the same as the way this Youtube video describes it. Sharing licenses on two separate xboxes. Microsoft allows it.
https://www.youtube.com/watch?v=tdYtSDkbBKQ


Sorry.

Edited by user Thursday, January 2, 2020 1:47:02 PM(UTC)  | Reason: Not specified

Rank: Racing Permit
#70 Posted : Thursday, January 2, 2020 3:35:30 PM(UTC)
https://forums.forzamoto...Loading-on-start-up.aspx

Long story short, there is no sure-fire fix that works for everyone, and there's zero indication there's one coming soon.
Rank: Driver's Permit
#71 Posted : Saturday, January 4, 2020 1:06:56 AM(UTC)
Originally Posted by: Sr Crumbbiscuit Go to Quoted Post
https://forums.forzamotorsport.net/turn10_postst159747_PC--Infinite-Loading-on-start-up.aspx

Long story short, there is no sure-fire fix that works for everyone, and there's zero indication there's one coming soon.


Oh really. What a great message to wake up to after messing around until deep in the night trying to get this garbage to work.
Of course it stops working as soon as i purchased the ultimate addons pack.

I guess i will have to request a refund in that case.
Rank: Driver's Permit
#72 Posted : Saturday, January 4, 2020 6:14:08 AM(UTC)
Interestingly enough, when i set my date back to december 2019, i get the actual game launching as far as those intro videos, but it will get stuck again as soon as they are over and the actual game would start.
If i set it back to the current date, it will just close itself after the splashscreen as usual.


Apologies for the double post, but my account is under moderation for some reason and i can't see my posts until they are approved.

Edited by user Tuesday, January 7, 2020 12:44:59 AM(UTC)  | Reason: Not specified

Rank: Driver's Permit
 2 users liked this post.
#73 Posted : Saturday, January 4, 2020 11:47:32 AM(UTC)
Really starting to annoy me now, cant even play the game after spending this much money on it. Its pathetic
Rank: Driver's Permit
 2 users liked this post.
#74 Posted : Monday, January 6, 2020 1:21:22 PM(UTC)
More confirmations on later pages of the Microsoft answers thread that the issue only began after upgrading to / purchasing the ultimate add ons bundle, including someone who bought the game on NYE:
https://answers.microsof...fbb-04313e659683?page=11

And another confirmation from a PSA I posted on reddit of someone only encountering issues AFTER ultimate edition:
https://www.reddit.com/r...from_the_splash/fczdsms/

Still no official acknowledgement of the issue I see. Suppose they have just returned to work though.

This is getting ridiculous. I'm not going to pretend that I know anything about game development but it is clear that something breaks after upgrading the base game to the ultimate edition. You even have some clues as to what might be causing it with that haphazard registry fix posted by that user in the Microsoft answers thread. Talks to MS about what could be causing this are what's needed right now and more importantly how to roll out a fix. Not that they are free from blame either mind you, it could well be that something to do with the MS Store structure that's caused this in the first place.

I give it a couple of weeks before I send a summary of this sorry tale to the gaming press. Then we'll see how fast they fix it when the negative coverage starts happening.

Edited by user Monday, January 6, 2020 1:23:24 PM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#75 Posted : Tuesday, January 7, 2020 12:44:12 AM(UTC)
Hey,
I contacted their support and they just told me that i dont need to reply anymore, because they are aware of the issue and are working on a fix.
Thats all.

I highly suspect that no fix at all will come and that the devs aren't even working on the game anymore, but rather a new game.
It has been months since these issues started popping up and there hasn't even been as much as an official acknowledgement about this problem.

I can't tell for sure, but where i work, this is a sign that the devs already moved on and that the issue will not be fixed.
28 Pages12345>>PrevNext

Notification

Icon
Error