This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
Rank: Driver's Permit
#1 Posted : Saturday, April 13, 2019 12:41:12 PM(UTC)
Hello Forza Communtiy!

I (maybe others too) have a problem with DLC cars. Well. Two problems, actually:

1. When I want to DRIVE a CAR from the DLCs (Fortune Island and so on...), I can drive it for about 5 - 10 min then the GAME CRASHES.

2. DLC cars CAN NOT be DRIVEN when the console is DISCONNECTED from the INTERNET. Why is that? I've bought the car pass, but can't drive those when my console is offline?

Looking forward to get those problems fixed.

Thanks in advance.

Rank: R-Class Racing License
 2 users liked this post.
#2 Posted : Saturday, April 13, 2019 1:32:15 PM(UTC)
Try going to car pass in the store and installing, it should download each individual car. This works for me on my non home consoles.


Vice president, moderated club.
Rank: Driver's Permit
#3 Posted : Thursday, April 18, 2019 8:00:26 AM(UTC)
Okay, I'll try that later.

Thanks!
Rank: Driver's Permit
#4 Posted : Friday, April 19, 2019 1:43:22 AM(UTC)
Well... I just noticed that they are installed.

So problem not solved :/
Rank: Racing Legend
 1 user liked this post.
#5 Posted : Friday, April 19, 2019 2:51:03 AM(UTC)
Is your console set as your home console

Have you also set your console to play offline in console settings ..not just disconnected it from online

Edited by user Friday, April 19, 2019 2:52:45 AM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#6 Posted : Thursday, April 25, 2019 12:10:57 PM(UTC)
Hmm... Don't know.

I'll try that too!

Thanks!
Rank: Driver's Permit
#7 Posted : Friday, June 14, 2019 2:31:43 PM(UTC)
Long time no see!

It works now. I was able to "use" the cars even though they weren't "installed".
I looked up in the add ons and there I had to actually install it.

Thanks for the help everyone!

PS: Sorry that I reply that late.

Notification

Icon
Error