This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
Rank: Driver's Permit
#1 Posted : Wednesday, April 17, 2019 9:04:27 PM(UTC)
So I've been having this issue with my game starting to stutter for over half a year now and it's starting to really annoy me. When I play about an hour the game starts to lag. I've noticed while designing my car and then going back to driving there was stutter which made the game unplayable, whenever I play the game for too long, I just can't play it because of the stutter. It's really game breaking. When moving 40KMH I was already experiencing a ton of stutters which made driving impossible. When starting the game, I have about 40-60 constant fps, but after a while of doing stuff, the game really loses those FPS and my game starts to stutter when not even moving fast.

Specs:
Intel I5 4460S CPU
8GB Ram
Geforce GTX 1050TI Superclocked (Not even close to a year old)

I've tried: Reinstalling the game, rebooting my computer and directly opening FH4, closing every application running in the background and foreground and even turning Vsync on and off. Didn't notice any changes.

Every other game runs completely fine

I would appreciate any help towards this issue since this is making FH4 unplayable.

Edited by user Wednesday, April 17, 2019 9:10:56 PM(UTC)  | Reason: Not specified

Rank: Driver's License
 1 user liked this post.
#2 Posted : Friday, April 19, 2019 8:26:05 AM(UTC)
The game stutters when your cpu usage reaches 100%
The only way to solve it is to cap your framerate (using the limiter in the game options) so the cpu usage never reaches 100%
Likely in your case you may have to lock the framerate at 30fps to stop it stuttering :(

Regards
ps I'm using the slightly more powerful 4460 and had similar issues
Rank: Driver's Permit
 1 user liked this post.
#3 Posted : Friday, April 19, 2019 7:19:40 PM(UTC)
I use to have this problem on both FM7 and FH4, to after updating to build 1903 it's been smooth, and my CPU usage was never near 100% (i7 5960x 4.5ghz).

Make sure video drivers and windows is up to date along with audio drivers and what not.
Rank: Driver's Permit
#4 Posted : Friday, May 3, 2019 5:54:39 PM(UTC)
OK, thank you. I'll try and update to 1903. I recently updated to 1809.

Edited by user Friday, May 3, 2019 6:01:11 PM(UTC)  | Reason: Not specified

Notification

Icon
Error