This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
Rank: Driver's Permit
#1 Posted : Sunday, January 22, 2017 5:48:37 AM(UTC)
I was racing on the goliath race (15 laps) when, after an hour, rewinds started to glitch. There was no animation but a black screen with "please wait", but it still was usable. On my 9th lap, i was going to the biron bay beach, i crashed and i used a rewind, but it teleported me into surfers paradise in last place. I tried to continue racing but if i couldn't use rewind because it was teleporting me to surfers paradise.

I lost maybe 2hours for nothing so please turn10 and playground games do something.
Rank: S-Class Racing License
 2 users liked this post.
#2 Posted : Sunday, January 22, 2017 7:30:20 AM(UTC)
Originally Posted by: Ludoretro112 Go to Quoted Post
I was racing on the goliath race (15 laps) when, after an hour, rewinds started to glitch. There was no animation but a black screen with "please wait", but it still was usable. On my 9th lap, i was going to the biron bay beach, i crashed and i used a rewind, but it teleported me into surfers paradise in last place. I tried to continue racing but if i couldn't use rewind because it was teleporting me to surfers paradise.

I lost maybe 2hours for nothing so please turn10 and playground games do something.

And your problem differs how from this: https://forums.forzamoto...017_Rewind-glitcj.aspx, literally 9 post below this one? Or maybe the title, Rewind Glitcj" confused you.
And the Talby goes to,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,Whoever thought up the Story Mode
Rank: A-Class Racing License
 1 user liked this post.
#3 Posted : Sunday, January 22, 2017 7:32:46 AM(UTC)
Originally Posted by: Ludoretro112 Go to Quoted Post
I was racing on the goliath race (15 laps) when, after an hour, rewinds started to glitch. There was no animation but a black screen with "please wait", but it still was usable. On my 9th lap, i was going to the biron bay beach, i crashed and i used a rewind, but it teleported me into surfers paradise in last place. I tried to continue racing but if i couldn't use rewind because it was teleporting me to surfers paradise.

I lost maybe 2hours for nothing so please turn10 and playground games do something.


Jeez, yet another Goliath thread... Until this issue is fixed (if it ever is), either avoid using rewind or only do 5 or 6 laps at a time.
Life, liberty, and the pursuit of absolute speed
Rank: Driver's Permit
#4 Posted : Thursday, January 4, 2018 5:25:28 AM(UTC)
Same here,after 20 laps.

Edited by user Thursday, January 4, 2018 6:22:45 AM(UTC)  | Reason: wrong section

Rank: Driver's Permit
#5 Posted : Sunday, January 21, 2018 2:12:17 AM(UTC)
Every time I try to go into my cars, it takes at least 15 mins for the page to open and it freezes. When it opens I select a car it freezes again and it stays frozen. Please can you fix my problem.
Rank: Driver's Permit
#6 Posted : Saturday, March 10, 2018 6:15:42 PM(UTC)
I noticed that the water is not being swept to the side of the window from the wipers on Xbox one x....Its completely gone. But it's there on Pc and the Xbox one/Xbox one s?????
Rank: Driver's Permit
#7 Posted : Saturday, February 9, 2019 8:15:37 PM(UTC)
Okay I'm having a little big trouble cuz I'm trying to play normally but the the time for downloading sources are so long so idk what I could do in this case, I already re-installed the game but still being in a long time charge, did anyone know how to solve this problem (this bug appeared in the latest update)
Rank: Driver's Permit
#8 Posted : Wednesday, March 6, 2019 11:25:56 AM(UTC)
whenever i paint any car or put a design on it my friend can't see it

Notification

Icon
Error