Rank: Racing Permit
 1 user liked this post.
#1 Posted : Thursday, October 26, 2017 4:58:23 PM(UTC)
I constantly run into a situation where Forza 7 will load splash screen then the window disappears. The error logs show "Unable to start DCOM Server / The error: 317" for my Forza 7 launch attempt.

The *temporary* fix is to re-download any DLC (Day-1, Hoonigan, or VIP) and then the problem goes away until the next time it's triggered - which I don't know the cause of.

This starting happening after the 1709 Fall update.

[10/29/17] Still having to do the redownload DLC workaround. Hope someone is working on this. I haven't seen where Turn 10 has acknowledged this problem yet.

[11/01/17] Downloaded VIP DLC to fix this again.

[Nov/10/17] Downloaded VIP DLC to fix this again.

[Nov/12/17] Downloaded VIP DLC to fix this morning.

Edited by user Friday, May 3, 2019 8:47:38 AM(UTC)  | Reason: Not specified

Rank: C-Class Racing License
#2 Posted : Thursday, October 26, 2017 5:39:12 PM(UTC)
Same issue here, but a more robust workaround is to sign in to your system with your MS account. This starts the DCOM process for Forza 7 normally.
Rank: B-Class Racing License
#3 Posted : Thursday, October 26, 2017 8:11:37 PM(UTC)
I had this issue when i used CCleaner + CCEnhancer. i had to sign in to my windows store account again (and xbox).
This problem also gave me sometimes "game is not in your account" error or something.

Edited by user Thursday, October 26, 2017 8:12:13 PM(UTC)  | Reason: Not specified

Rank: Racing Permit
#4 Posted : Friday, October 27, 2017 7:33:35 AM(UTC)
Originally Posted by: Lexandro Albion Go to Quoted Post
Same issue here, but a more robust workaround is to sign in to your system with your MS account. This starts the DCOM process for Forza 7 normally.


I do not use a MS account and only sign into apps I want connected. I haven't had the problem prior to the 1709 Fall update.
Rank: B-Class Racing License
#5 Posted : Friday, October 27, 2017 7:48:27 AM(UTC)
In that case try signing into your Xbox app.
Rank: Racing Permit
#6 Posted : Friday, October 27, 2017 7:57:46 AM(UTC)
Originally Posted by: Trackah123 Go to Quoted Post
In that case try signing into your Xbox app.


Xbox app is one of the apps that is signed into with MS account. The Store is another that is signed into. The game works once I re-install the DLC, but then something causes the DCOM error "317".

I see from the Horizon 3 boards that it was a known issue that was being worked on, but then there was nothing further I could find. Apparently it's creeped into Forza 7 with the Fall update.
Rank: Racing Permit
#7 Posted : Friday, October 27, 2017 8:00:34 AM(UTC)
Originally Posted by: Dr Cain Go to Quoted Post
Originally Posted by: Trackah123 Go to Quoted Post
In that case try signing into your Xbox app.


Xbox app is one of the apps that is signed into with MS account. The Store is another that is signed into. The game works once I re-install the DLC, but then something causes the DCOM error "317". I should start timing it, because it appears to happen a few days after I fix it, like it's running on a schedule. Maybe it's a Store bug that needs fixing.

I see from the Horizon 3 boards that it was a known issue that was being worked on, but then there was nothing further I could find. Apparently it's creeped into Forza 7 with the Fall update.


Rank: Driver's Permit
#8 Posted : Friday, October 27, 2017 4:32:12 PM(UTC)
Originally Posted by: Dr Cain Go to Quoted Post
Originally Posted by: Trackah123 Go to Quoted Post
In that case try signing into your Xbox app.


Xbox app is one of the apps that is signed into with MS account. The Store is another that is signed into. The game works once I re-install the DLC, but then something causes the DCOM error "317".

I see from the Horizon 3 boards that it was a known issue that was being worked on, but then there was nothing further I could find. Apparently it's creeped into Forza 7 with the Fall update.


How do you reinstall the hoonigan dlc?, I cannot find anywhere in the store or windows to uninstall and reinstall it.
Rank: Racing Permit
 2 users liked this post.
#9 Posted : Sunday, October 29, 2017 7:00:32 AM(UTC)
Go to Settings, and then Apps. Click on "Forza 7" and click "Advanced options". From there delete one of the DLCs and then redownload it from the Store.
Rank: Driver's Permit
#10 Posted : Monday, October 30, 2017 8:41:06 AM(UTC)
I had the same problem. For me it worked start the game from the windows store itself, now starts normally
Rank: Racing Permit
#11 Posted : Monday, October 30, 2017 9:42:29 AM(UTC)
I've tried from the Store and the Xbox app with no change when this happens. The only fix for me has been re-downloading one of the DLC.
Rank: Driver's Permit
#12 Posted : Monday, October 30, 2017 10:19:04 AM(UTC)
I fixed this because i have a similar error but in mine it says something like unable to star dcom server and a location but when i saw that location i realised that my game wasnt installe there so i moved the game from Apps & Features to C: (i have it installed in D) And magically all my Forza Games started to work not only the one that i moved (Forza 6 Apex) but also the other two FH3 & FM7... I hope this can fix your problems
Rank: Racing Permit
#13 Posted : Monday, October 30, 2017 12:23:28 PM(UTC)
Let us know how this works out for you in a few days. Someone else posted moving their game, and just like re-downloading DLC, it only worked temporarily.

Moving or reinstalling the game, or re-downloading DLC appears to refresh your license but for some reason it's only temporary.
Rank: Racing Permit
#14 Posted : Friday, November 10, 2017 6:29:59 PM(UTC)
Had to download DLC again to get this to work.
Rank: Driver's Permit
#15 Posted : Thursday, November 23, 2017 12:51:10 AM(UTC)
Same issue here. Probably unrelated but worth stating, 7 worked just fine without this and any issues until after i tried using an xbox 1 wireless controller adapter and xbox 1 controller. The controller worked for about 2-4 mins then would disconnect, reconnect (pushing button), then disconnect. After that sequence followed the nasty blue screen. [Mod Edit - Abbreviated profanity, profanity and profanity that is disguised but still alludes to the words are not permitted - D].

Edited by user Thursday, November 23, 2017 12:02:04 PM(UTC)  | Reason: Not specified

Rank: Driver's Permit
#16 Posted : Saturday, February 17, 2018 11:24:58 AM(UTC)
Hello,



Like we mentioned before, this is an issue we are currently aware of and investigating. This issue is not specific to your computer. If the steps below didn’t work, you will need to wait until we resolve this issue.



Apologies for any inconvenience.


This was the reply I am getting from Turn 10 about this issue
Rank: Racing Permit
#17 Posted : Sunday, February 18, 2018 8:05:24 AM(UTC)
It appears to be more a problem with Microsoft Store, and in turn, means F7 will be my first, last, and only thing I buy from there until it's fixed.

Edited by user Sunday, February 18, 2018 8:06:05 AM(UTC)  | Reason: Not specified

Rank: C-Class Racing License
#18 Posted : Sunday, February 18, 2018 9:19:39 AM(UTC)
Disclaimer: This was posted in another thread. And it does work so credit goes to that person who posted it.
---
What you need to do (PC) is:
Open Services.
Scroll down to Windows PushToInstall Service
Right click on it and start the service
Start Forza 7

This time Forza 7 will start and load. I'm not sure why Windows PushToInstall Service is helping but it does. And it's a service that will stop on it's own. So even if you change it to Automatic it's status will turn off on its own. So for now, just start the service when Fora 7 ctd on launch.
Rank: Racing Permit
#19 Posted : Tuesday, February 20, 2018 6:52:34 PM(UTC)
Originally Posted by: The Sniper 8U Go to Quoted Post
Disclaimer: This was posted in another thread. And it does work so credit goes to that person who posted it.
---
What you need to do (PC) is:
Open Services.
Scroll down to Windows PushToInstall Service
Right click on it and start the service
Start Forza 7

This time Forza 7 will start and load. I'm not sure why Windows PushToInstall Service is helping but it does. And it's a service that will stop on it's own. So even if you change it to Automatic it's status will turn off on its own. So for now, just start the service when Fora 7 ctd on launch.


This method works for me. More convenient than reinstalling DLC. Hopefully Turn 10 is aware of this workaround as well as it looks like a prime suspect or could lead to one.
Rank: Driver's Permit
#20 Posted : Wednesday, March 14, 2018 7:38:43 AM(UTC)
Pretty anoying this isnt fixed yet, ive made a bat/cmd file to do this automatically and start forza7. (needs to be run as administrator!)

net start "Windows PushToInstall Service"
explorer.exe shell:appsFolder\Microsoft.ApolloBaseGame_8wekyb3d8bbwe!forzamotorsport7
Rank: Driver's Permit
#21 Posted : Friday, March 1, 2019 8:42:49 AM(UTC)
I'm having a DCOM 10010 error: Microsoft.OpusPG_1.0.125.2_x64__8wekyb3d8bbwe!OpusReleaseFinal" konnte innerhalb des angegebenen Zeitabschnitts mit DCOM nicht registriert werden.

Not a single one of your fixes worked as of First of march 2019. I'm not able to play FH3 since 2 months.
Rank: Driver's Permit
#22 Posted : Sunday, April 28, 2019 4:34:42 AM(UTC)
everyone try this https://support.forzamot...it/requests/33053?page=1 OR
i did this:
1)open xbox app
2) Disconnect the account from xbox app Only
3) Disconnect internet
4) launch the game (let it crash)
5) relog on XBOX app
6) reconnect on the internet
7) launch the game
Rank: Forza Staff
#23 Posted : Friday, May 3, 2019 8:47:56 AM(UTC)
Please submit a ticket https://support.forzamot...et/hc/en-us/requests/new so we can investigate further.

Notification

Icon
Error