This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
2 Pages12Prev
Rank: S-Class Racing License
#26 Posted : Friday, May 4, 2018 6:26:37 AM(UTC)
I had no idea what yesterday update was for, but after installing on my Xbox one x, I noticed right away that my garage menu s rolled much faster than before.

I also notice a few more missing thumbnails. I had 799 cars, I put a few in the auction and sold some, got down to 775. Same deal, still faster but several missing thumbnails. I noticed as I was selling some cars that were in fact had a missing thumbnail, once sold, one of the other cars that was visible before, now had a missing thumbnail.

Oh, it appears selecting a car on the turn table, the tires no longer stay solid to the moving table, but do stay with the car.
Rank: D-Class Racing License
 1 user liked this post.
#27 Posted : Friday, May 4, 2018 9:21:52 AM(UTC)
Why can't we just choose cars from the Car Collection menu? Wouldn't that make sense?
Rank: Driver's License
#28 Posted : Friday, May 4, 2018 11:24:30 AM(UTC)
I'm having some issues as well. There is an issue where you can't put a tuning setup onto your car.
Big Boy in Action
YT: RP Gaming

Rank: Driver's Permit
#29 Posted : Friday, May 4, 2018 12:05:12 PM(UTC)
Spent 5 hrs in the same lobby last night with no crashing. It was nice, menu still rough though. Would like it if we got a little more time between races.
Rank: S-Class Racing License
#30 Posted : Friday, May 4, 2018 12:13:17 PM(UTC)
Spoke to soon. Wheels still staying with rotating table when selecting a car in rivals.
Rank: Driver's Permit
 4 users liked this post.
#31 Posted : Saturday, November 17, 2018 1:03:45 PM(UTC)
Well.. almost end of 2018 and the game is still very laggy. Scrolling through the menu is still frustrating. Also the loading times after a race. Credits showing up, stuff flys over the screen in the background, my 3D driver model is dithering around, cars in the pit lane having wild sex in the background, useless animations for choosing a new car - no wonder it is laggy.

I mean.. I play on Xbox One X, the most powerful console ever made, they say. But I never noticed that when the game is running.

Turn 10.. you all reading this complains from the community. Any reply to the players? Anything?

Oh.. how much I wish Forza 7 has the classy menu from GT Sport. Forza 8 would be the best racing game ever.
Rank: A-Class Racing License
 5 users liked this post.
#32 Posted : Saturday, November 17, 2018 3:11:38 PM(UTC)
1 year, 1 month and a little over 2 weeks since FM7 was released.

Car selection is still unresponsive as hell. The worst I've ever seen.
Good job with the 3d cars, 3d drivers and 3d backgrounds....really helped a lot...

Edited by user Saturday, November 17, 2018 5:04:18 PM(UTC)  | Reason: Not specified

Rank: Racing Permit
#33 Posted : Thursday, November 22, 2018 10:23:12 PM(UTC)
Originally Posted by: The Consolero Go to Quoted Post
Well.. almost end of 2018 and the game is still very laggy. Scrolling through the menu is still frustrating. Also the loading times after a race. Credits showing up, stuff flys over the screen in the background, my 3D driver model is dithering around, cars in the pit lane having wild sex in the background, useless animations for choosing a new car - no wonder it is laggy.

I mean.. I play on Xbox One X, the most powerful console ever made, they say. But I never noticed that when the game is running.

Turn 10.. you all reading this complains from the community. Any reply to the players? Anything?

Oh.. how much I wish Forza 7 has the classy menu from GT Sport. Forza 8 would be the best racing game ever.


Drawing on my background in PC gaming, I don't think the One X has anything to do with it because it still has a CPU bottleneck despite having a considerably more powerful GPU. However, the main issue is with the game as far as menu lag goes - everything is in 3D so hiccups are to be expected, unless they can cleverly modify the code further. Perhaps a significantly faster CPU on the X may have helped.

Here's what I do: patiently wait and admire the visuals. :)
Rank: B-Class Racing License
 5 users liked this post.
#34 Posted : Friday, November 23, 2018 1:30:36 AM(UTC)
I run the game on a PC with a 4.4GHz i7 CPU and it's laggy just the same. It's just not a well written piece of software.

Recently I played Forza Motorsport 3 on my Xbox 360 for the first time in a long time. It was incredible how fast, smooth and responsive the entire UI experience was.

Flashiness and graphic heavy menus which take ages to load and make the system laggy and unresponsive is stupid, that's the only word for it. It's a really stupid design decision.

Especially in multiplayer races. At the end of a race, it's an absolute mess. Typically you'll be shown the results for literally just a few seconds, blink and you miss it, then you're into the sequence of tedious screens which jerk and stutter and lag, all the while there is a countdown timer telling you to vote for the next map. This is often completely unresponsive as the bloated software desperately tries in vain to do more than one thing at the same time, ie. load the next graphic heavy results screen with your avatar dancing around.

You're often left with no more than 30 seconds to choose your car for the next race, using the horribly sluggish and unresponsive car selection screen.

It's a dog's dinner.
Rank: Driver's Permit
 1 user liked this post.
#35 Posted : Monday, February 11, 2019 7:38:26 AM(UTC)
Yeah that garage lag is painful. I don't understand how that is not patched almost after a whole year.
Can't do 3D pictures of car ? Here is how: Evertime you edit/buy car make photot of it and get some frame. Voila Turn10 you just now have a picture. Run script for all cars like that and change loading of car for picture instead. Voila you fixed garage lag.
Rank: Racing Permit
#36 Posted : Monday, February 11, 2019 1:41:57 PM(UTC)
I may be off base, but pre-render doesn't seem to be the problem.

It's entirely too common that car thumbnail images don't update with a new livery download, or when a car is bought off the auction with a livery. Most of the time the image shown is of the stock unpainted car. And it will continue to show that in the thumbnail until you edit something that makes it re-render the thumbnail. Like change wheels, or change spoiler, or just paint the car some color yourself. That makes it show the current new state. You can then revert to what you want, and the thumbnail image will likely work correctly going forward (unless you download a new livery, then it may happen again).

If they are not pre-rendering, then I fail to see how they could have screwed it up to produce that bug...

But regardless, the time lag for flipping through a full garage to find what you want is utterly ridiculous. There is simply nothing in the garage that could justify those hangups.

It seems to be trying to access the internet to phone home at various relatively unpredictable points. However, it does seem like it's far more pronounced when you accidentally hesitate a moment on a car with downloaded livery. That was consistent enough that I've removed and deleted most of my liveries with the exception of some I really liked for favorite cars. I just usually go with a factory paint. But it still does it, though I feel like it's less of an issue.

Edited by user Monday, February 11, 2019 1:43:52 PM(UTC)  | Reason: Not specified

2 Pages12Prev

Notification

Icon
Error