This site uses cookies for analytics and personalized content. By continuing to browse this site, you agree to this use. Learn more
Rank: Driver's License
 1 user liked this post.
#1 Posted : Wednesday, February 6, 2019 7:04:12 PM(UTC)
Went to go run a lap at Daytona, check the new 599Evo's performance on a oval (can't check the stats). ZERO Drivatar's, run the lap & everything fine. Check the replay and magically another 599XX falls from the sky, hits the ground, UFO's itself into the air, fall thru the track track, I hit it, UFO's itself higher this time, I t-bone it, and then it meets it's final resting place. ALL IN REPLAY, JUST REWIND & PLAY
Here's the link https://www.youtube.com/...48s&feature=youtu.be
Rank: B-Class Racing License
#2 Posted : Wednesday, February 6, 2019 9:46:45 PM(UTC)
This game gets weirder every update. What the heck is going on with these countless glitches and bugs T10...sheeeeesh. idk man that's weird.
Rank: Driver's Permit
#3 Posted : Saturday, February 9, 2019 2:38:01 PM(UTC)
Same problem here - I'm getting the stretch limo parked on the start/finish line, random cars including the one I'm currently driving parked around the track and wandering onto the track, and started a lap the other day with a Fiat parked on top of my car.

Also getting the other reported glitches - 0-60, 0-100 and 1/4 mile times all showing as less than a tenth of a second, and the race shop restock timer issue. I'd say I'm having more problems with network connection since the update as well.

All in all, a massively disappointing update. Hey Turn10, if we return the free cars, can we have our game back please?

Notification

Icon
Error