Xbox One version won't start

Hi! So I pre-ordered the digital Xbox One version of the game, and so far so good.

Today wanted to play some more, it said it had an update. I did it, and now the game won’t even launch. Just opens the picture from the “cover” (the beautifull Porsche 911 GT2 RS) and exits to xbox main screen. If I try and close the game, nothing shows up, meaning it’s closed already.

Any fix for this?


Have you tried hard resetting/ cold booting your console properly yet including pulling the power plug from the wall

Yes I did. Decided to delete the game and try reinstall. Will see

Yup, today I came home to play some Forza and it does exactly this. Splash screen shows up and then goes back to xbox home. Until yesterday night it was working just fine. Seems like some update has been installed during the day. Anyone know how to fix this? I have already reset my xbox one and so…

Having same issue. Did you resolve it?

I am having the same problem. I have tried all the tricks minus deleting the game. But I would rather not go there. As it takes like 2 days to download for me.

I am also having the same issue today. Worked fine the last two days.

Same issue here today. Worked fine the last two days.

I am having this problem as well. Game will not start up.

wow I got digital Xbox One version of the game, play just fine now it won’t play at all…:frowning:

Having same problem

Same today for me. Been working fine. Anyone find a fix?

1 Like

Same issue for me. Preloaded the game but it wouldn’t launch. Tried everything including copying it from the external HDD to the internal, but nothing worked. Finally deleted it and reinstalled it, then it worked fine. two days later, the same thing is happening. Been playing it on PC since last Friday with no issues what so ever. I don’t want to keep deleting and re downloading it. All other games on the xbox launch just fine. This is getting really annoying.

1 Like

Same here… Worked fine for 2 days, now it crashes to the XB1 home screen every time I try to start the game. Working just fine for a friend of mine. Bleh…

Looks like this is a recent issue we’re all having suddenly

This is horse sh!t

1 Like

I can’t get mine to start either.

same here was working now it won’t boot just starts and crashes back to home screen with no error message

Me and 2 friends are having the problem too.

same problem have done every way possible to reset, but always crashes no matter what i do