Windows Build 1903 and excruciatingly long load times

Last week, my PC got updated to Windows 10 May Update build 1903. Now after initial Turn10 Studios and Microsoft Game Studios splash videos, where the game asks to Press Enter, it takes 4-5 minutes for Continue button to show up while camera endlessly pans around the Mclaren Senna.
If I disable my Ethernet adapter, it loads instantly. But throws up Xbox Parental Control error if I re-connect my ethernet and try to connect to Horizon life.

I have replicated this problem on all the 3 PCs which I know have Windows build 1903 installed. Loading is instant on previous build 1809.

Anyone convey this problem to the devs?

1 Like

It takes much more time for the game to load the XBOX profile in Windows 10 version.

Here it takes less than 1 minute, but even so, it’s a long delay if comparated to Windows 10 version 1809.

I have the exact same issue. I tried to report it by submitting a ticket, but the response I got was unrelated to the issue.

Here’s a video of the load time. Forza Horizon 4 2019 06 05 10 58 41 - YouTube



[Mod Edit - Abbreviated profanity, profanity and profanity that is disguised but still alludes to the words are not permitted - D]




Not only a long load time but Horizon Life keeps disconnecting with build 1903, especially when doing the Forzathon/group activities. I have a 50/50 chance of completing the hourly Forzathon due to the constant disconnects.

I’m having EXACTLY the same problem since updating Windows. Will this ever get fixed? Game is on a SSD, so storage speed isn’t the problem. I play on ultra settings.

PC Specs:
Ryzen 5 1600
RX 570 8GB 1400MHz
16GB RAM 2933MHz

not the only one’s.

+1, on 1809 loaded fast


Same here. thought it was the manual installation of the car pack but update 1903 was just before i had this issue the 1st time.
loading takes forever now.

1 Like

Same here, loading times is like 5 times longer since 1903.

Same issue here.

16GB DDR4 Ram
Nvidia 1060 6GB

Installed on an SSD. Loaded quick before, takes ages now that I’ve updated to 1903.

1 Like

Someone on Reddit was saying this was fixed with the LEGO update…is that not the case? I don’t want to upgrade to 1903 if it’s still broken.

Hasn’t been fixed for me. A friend on an Alienware laptop doesn’t have this issue. (He’s on 1903)

Not in my case.

no still the same after lego expansion.

Same issue. Fast on 1809, very slow on 1903. Ryzen 1600, 16GB, RX580 8GB, 512GB NVMe x4 SSD.

Also, now crashing when loading after pressing the Continue button, which is something another thread has been posted about.

1 Like

me too, there’s nothing I can do to start the game