Wheels clutch shifter not detected

I made my own horizon 4 shifter but it doesn’t work on steam (it work on microsoft). Steam won’t catch my shifter and I can’t bind my gears. Please help. I cannt set the controller in the steam controller settings
Sorry for my bad english.


Like in the title my h-shifter (for the g29 and g920 )does not work in the games I play but on the Logitech G-hub, it is detected could you please help me.

1 Like

Hello i have problems with my clutch in fh4 in every other game i play the clutch works perfectly but in forza the game refuses to recognize my clutch axis.

I cant map it in game and i have tried to use the defualt g25 profile in forza still doesnt work anyone have any ideas?


1 Like

hello guys im unable to use my logitech g29 in forza horizon 4 steam ,
in game i only see keyboard and controller setting , while my g hub detect my wheel very well

i used to play FH4 cracked version and my wheel work really good but why not in steam version guys

help me guys if got another way to use the wheel even using emulator

1 Like

Any solution or workaround to get the Momo racing force wheel to work with the Steam version of the game?

Support doesn´t answer and it seems a common problem.

I feel like I´m missing out but I will return the game, if there is no solution to this.

The game doesn´t recognize there’s a wheel plugged in - so no chance of mapping anything. Also won´t allow to map it as game controller.

I would be very grateful for any help!


I use a Logitech G27 steering wheel. I just brought Forza Horizon 4 on Steam. I went to configure my settings and I did all my other settings then it got to the clutch. When I pressed the clutch pedal, it did not detect it. I then tried the Brake pedal and it detected that. I don’t know what’s wrong and I also tried searching it up and nothing came up. My clutch works on other games, it’s just this game it doesn’t work on.

1 Like

Exactly the same issue.

I bought the game on Steam and my clutch is not recognized only there. Other steam games recognizing clutch.

It is very upset to see that developers are ignoring these claims.

1 Like

I was trying to connect handbrake with G29 to Forza horizon 4 but there was no luck. I watched couple of Youtube videos and they said i should use emuwheel. I tried to follow what they were saying until the step where i have to edit the VIDPID files in save data.
I was looking for the files i could not find anything because i have FH4 steam edition. Any idea how to edit them or where to find the exact files.

1 Like

[Mod Edit - thread merged to keep similar cases together. If you haven’t tried Forza Support, try there. - MM]

FH4 on PC/Steam will no recognize my TH8A shifter the first time the game opened or when trying to map gear positions in wheel settings. In reading on other forums it sounds like this may be an issue on the steam platform but not 100% sure.

  • TH8A is plugged directly into the PC, not via USB hub or switcher
  • TH8A works fine and maps fine on all other racing games I’ve tried (Project Cars 2, Assetto Corsa)
  • Most recent drivers for wheel (T300RS GT) and shifter (TH8A) installed

What I’ve tried so far:

  • Uninstall/Reinstall driver for shifter and wheel base
  • plug shifter directly into wheel base and USB to PC (Thrustmaster support states USB Only for PC and direct to wheel base won’t work)
  • Verified TH8a shifter on FH4 supported controllers list
  • unplugged/replugged shifter
  • Tried USB 2 and USB 3 ports
  • Tried multiple USB2/3 ports
  • Ensured FH4 was updated

Any help or tips is appreciated

— EDIT: not sure why this post keeps getting added to this thread every time i try to post it. the TH8A is supported for FH4 per your supported device list as is multi-USB devices. Clumping all of these “wheel/clutch/shifter” device threads into 1 just alienates the posters who need help and gives off the impression that these are all of the same issue which doesn’t actually appear to be the case. This is frustrating

1 Like

İ have same problem on my G27 steering wheel on only STEAM version. İ can’t assign clutch pedal and force feedback is bad. Please fix it FORZA.


Forza Horizon 4 on steam version working very strangely. I’m using MOMO Racing force-feedback, on MS store it was detected and working well, but on steam version it doesn’t even show wheel settings, while other games are working nice on the wheel. Sad for me, not sure if i want to keep the game or refund it now, after all the odds

Need help to solve my Issue, FH4 cant recognize my Logitech g29 racing wheel

Hi, I have recently bought a Logitech G27. It works in Windows and Every Game perfectly, besides Forza Horizon 4. In Forza, when i try to assign my left “Clutch” Pedal to use it as the clutch ingame it is just not detecting any input. Ive read that many people have the same problem, but i need a solution.

Here’s what i tried:
Using other USB Ports (2.0, 3.0)
Reinstalling drivers.
Reinstalling Forza Horizon 4.
Plugging the wheel directly into the PC and into a Hub.

I hope someone can help me.

Was gonna buy this too…

I’m using a G29 + TLCM and both are connected to my pc through usb individually and I the game won’t recognize my pedals but my wheel is. I bought the game on steam and my setup is easily detected by other games like ACC, ETS2, Raceroom etc, please send help


I’m still using the Logitech G27 and it did not work well with newer drivers than Logitech Profiler 5.10.127 which is from 2010.
Install this and open the Profiler, check in device Properties that all the Pedals and buttons work,

This video might help

make sure, in Settings, you leave ' allow games to interact ' ticked and ' combine pedals ' unticked.

Finally adjust your settings in the actual game.

Thanks, but it didn’t help. I tested everything like shown in the video and everything worked. And i don’t understand what you mean with newer drivers than Logitech Profiler 5.10.127, because the only drivers i can find on the Logitech Website, are 3 Downloads for the 5.10.127 version, there is nothing newer or older. Forza is still not detecting my clutch.
But thanks for your help.

I got it to work, thx for the help

G27 Clutch not detected
This wasn’t an issue on the windows store version, so what gives? I’m aware others are posting about this but this obviously isn’t being addressed. There’s no reason this should be happening when it wasn’t an issue on the windows store version and AFAIK there doesn’t seem to be a solution that anyone has found.